Results 1 to 10 of 10

Thread: Visual Boy Advance running too fast

  1. #1
    Join Date
    Nov 2004
    Beans
    27

    Visual Boy Advance running too fast

    Hi all!

    I'm having a problem with VBA - it's running at twice the speed it's supposed to. Tried Googling around for this problem since I know some friends've had similar problems, but I couldn't find much of an answer anywhere.

    Anyhow, anyone know why my VBA runs at 2x the speed, and how to fix it? It ran fine mostly before I upgraded to Edgy. Right now I'm running Edgy Eft on a Centrino 1.8 GHz w/512 MB RAM and Intel 915 chipset. It also appears to be a problem with Debian.

  2. #2
    Join Date
    Mar 2006
    Location
    /home/sven
    Beans
    275

    Re: Visual Boy Advance running too fast

    try this:
    Code:
    sudo etc/init.d/powernowd stop
    it should disable a kind of cool 'n quiet technique that fixes the problem for cedega to start it again use
    Code:
    sudo etc/init.d/powernowd start
    Biography: sven@sven-desktop:~$ - Location: /home/sven - Interests: /usr/bin/ut2004 /usr/local/games/enemy-territory/et - Occupation: root@sven-desktop:/home/sven#

  3. #3
    Join Date
    Nov 2004
    Beans
    27

    Re: Visual Boy Advance running too fast

    That did not solve it, the vba is still running on 200% speed. Thanks for the suggestion though. Any other takers?

  4. #4
    Join Date
    Jan 2007
    Beans
    44
    Distro
    Ubuntu 6.06 Dapper

    Re: Visual Boy Advance running too fast

    Are you running it on wine/cedega or did you get it from synaptic?

  5. #5
    Join Date
    Nov 2004
    Beans
    27

    Re: Visual Boy Advance running too fast

    Sorry, guess I should have clarified that one. It's the native version (i.e. got it from the repositories). Why emulate something that you can get in native mode?

  6. #6
    Join Date
    Feb 2006
    Beans
    8

    Re: Visual Boy Advance running too fast

    I had tried VBA both in windows xp and ubuntu. In windows XP you have a throttle option to control speed but it doesnt work in linux. I'm not in front of my computer right now but I think that I opened the cfg file that its created in your home directory and change set the throttle to 50 or 60 instead of 0 (auto).

  7. #7
    Join Date
    Nov 2004
    Beans
    27

    Re: Visual Boy Advance running too fast

    Yes, that did the trick, mostly. Now if I could just fix the garbled sound that appears, that'd be super schweet, but atleast now I can play the darn thing. Thanks!

  8. #8
    Join Date
    Sep 2006
    Beans
    Hidden!
    Distro
    Ubuntu 6.10 Edgy

    Re: Visual Boy Advance running too fast

    Quote Originally Posted by Wertigon View Post
    Yes, that did the trick, mostly. Now if I could just fix the garbled sound that appears, that'd be super schweet, but atleast now I can play the darn thing. Thanks!
    Yeah, the sound is really crappy

  9. #9
    Join Date
    Dec 2006
    Location
    Canberra, AUS
    Beans
    366
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Visual Boy Advance running too fast

    The method I got the speed back to somewhere around 100% was to change the sound quality to the highest available. I think it was 44 or 48khz.

  10. #10
    Join Date
    Aug 2006
    Beans
    87

    Re: Visual Boy Advance running too fast

    An alternative is to use Mednafen. It emulates GBA well, among other systems (NES, etc.). I found it to be more flexible in terms of screen resolution than VisualBoyAdvance, and it has no throttle or sound problems.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •