Page 23 of 104 FirstFirst ... 1321222324253373 ... LastLast
Results 221 to 230 of 1032

Thread: HOWTO Install Samsung Unified Printer Driver

  1. #221
    Join Date
    Dec 2006
    Beans
    678

    Re: HOWTO Install Samsung Unified Printer Driver

    Quote Originally Posted by mudman00 View Post
    Perhaps tweedledee can explain the error message....I am thinking about sending him a PM, but he tells us not to do so in the intial post and he has been updating periodically. Thoughts?
    Your error from the install script could have arisen lots of ways (in my experience, the error is equivalent to saying "script tried to do something and it didn't work"). However, there are two more likely possibilites. One (my personal bet) is that when you first extracted the archive, one or more files (not necessarily install.sh itself) was corrupted, especially given the apparent conflicts recently between Samsung's creation of the archive and the ability of programs to extract from it. The other common cause is that soemwhere in all the steps you followed or advice you were given, you changed the shell you were running (e.g., from dash to bash).

    It does appear you and yahs have brough to light a couple of points that I will incorporate into the initial post, including the need to clarify/re-emphasize the "delete auto-installed printers" steps.
    Last edited by tweedledee; April 9th, 2009 at 01:24 PM.

  2. #222
    Join Date
    Dec 2006
    Beans
    678

    Re: HOWTO Install Samsung Unified Printer Driver

    Quote Originally Posted by ozp View Post
    I have a CLX-3160FN

    Ive tried 3 drivers and none are good

    Do you know how to configure any driver in order to get better color print results?

    here is what I get from those drivers. Is this the quality you get?
    You may just want to try other related printer drivers. I get large variations in printer quality (mainly color tones) depending on the exact configuration and driver I use, and have seen cases where the best output is to use a driver for a different printer altogther. Unfortunately, I have not found any system for dealing with this other than trial and error, and occasionally an update to the printer backend (CUPS, etc.) that you are using will also have an effect (good or bad).

  3. #223
    Join Date
    Dec 2006
    Beans
    678

    Re: HOWTO Install Samsung Unified Printer Driver

    Quote Originally Posted by |-|ans View Post
    Noticed the referral to the older printer driver at the Samsung site as well. Using a CLP-500 I started with the described way and had quite some issues doing so. Indeed unpacking was tricky and also the printer (although connected) was not found. At some point after trying a lot I did look at a newer printer (with the 3.x driver offered for download) and grabbed that Unified Printer Driver. To my suprise the CLP-500 (file CLP-500splc.ppd) and many more are in there as well.
    Thanks for the tip, I will look into this.

  4. #224
    Join Date
    Dec 2006
    Beans
    678

    Re: HOWTO Install Samsung Unified Printer Driver

    Quote Originally Posted by dmikulec View Post
    I just updated to Ubuntu 8.10 and installed the new Unified Linux Driver (ver.3.00.37). I followed their instructions (including the Configurator) and installed thru 95% when a gif display window opened and installation stopped. Installation resumed when I closed that window. The printer does not work. System>Admin>Printing recognizes my ML-2010 but reports "Stopped - Filter "rasterospl2" for printer "ML-2010" not available: No such file or directory"

    I would appreciate any direction on how to rectify this situation.

    Thanks,

    Don
    Did you get this issue resolved by adjusting the USB port used (or something else)? This could also be a case of the need to juts delete all installed printers and re-add them in the control panel.

  5. #225
    Join Date
    Aug 2008
    Beans
    78

    Re: HOWTO Install Samsung Unified Printer Driver

    Regarding HOWTO Install Samsung Unified Printer Driver

    I started using Ubuntu 8.04 April 2008 and I have followed your excellent post many times with various installs using Drivers from Samsung.co.uk

    I have separate partitions purely for installing and testing and since the release of Unified Driver ver 3.00.37 I have installed 8.04.1, 8.04.2, Linux mint 6, Intrepid and Jaunty beta all with 100% success.

    If the printer is turned off, I usually get the following message after running sudo ./install.sh

    libstdc++.so.5 (gcc 3.0.x .. 3.3.x) not found, install ... done
    libtiff.so.3 not found, install ... done
    GUI mode installer execution failed, proceeding in text mode
    **** Running text mode install
    **** Press Enter to continue or q and then Enter to quit:

    **** Non-priviliged users found:
    nobody yahs
    **** Are you going to use USB-connected devices ?
    **** If yes, users allowed to scan or manage printers should be added to lp
    **** group. The list of non-privileged users proposed for addition is shown above.
    **** Press y and then Enter to add users or Enter to leave lp group intact:

    **** Print drivers for the following device models available:
    CLP-300splc CLP-310splc CLP-350ps CLP-500splc CLP-510splc CLP-550ps CLP-600splc CLP-610splc CLP-650ps CLP-660ps CLP-770ps CLX-216xsplc CLX-3160splc CLX-3170splc CLX-6200ps CLX-6240ps CLX-8380ps mfp560 mfp750 ML-1450ps ML-1510spl2 ML-1520spl2 ML-1610spl2 ML-1630spl2 ML-1630wspl2 ML-1640spl2 ML-1710spl2 ML-1740spl2 ML-1750spl2 ML-2010spl2 ML-2150ps ML-2150spl2 ML-2240spl2 ML-2245spl2 ML-2250spl2 ML-2510spl2 ML-2550ps ML-2550Sps ML-2550Sspl2 ML-2560ps ML-2570ps ML-2850ps ML-2855ps ML-3050spl2 ML-3470ps ML-3560spl2 ML-4050DMVps ML-4050ps ML-4550ps ML-6060ps ML-7300ps ML-8x00ps scx4100 scx4200 scx4300 scx4500 scx4500w scx4725 scx4x16 scx4x20 scx4x21 scx4x24 scx4x26 scx4x28ps scx5312f scx5635ps scx5835ps scx5x30 scx6x20PCL scx6x20 scx6x20PS scx6x22ps scx6x45ps scx6x55ps sf531p
    **** Please enter model to install and press Enter: scx4100
    INFO: Installing MFP port and SANE backend libraries ...
    cat: /etc/modprobe.conf: No such file or directory
    INFO: Installing GUI lpr ...
    INFO: Fixing file ownership and permissions ...
    INFO: Registering SANE backend ...
    INFO: Registering CUPS printer ...
    * Restarting Common Unix Printing System: cupsd [OK]
    INFO: CUPS restart OK
    INFO: Creating menu entries ...
    INFO: Finishing installation ...
    **** Text mode install finished

    Printing and Scanning now work perfectly.

    If the printer is turned on, Ubuntu finds it and assigns a generic printer on usb://Samsung/SCX-4100%20Series which doesn't work as there is a limited choice of drivers to choose from.
    Having downloaded and extracted the Unified Driver File and Run the command sudo ./install.sh
    I stil get the error messages
    libstdc++.so.5 (gcc 3.0.x .. 3.3.x) not found, install ... done
    libtiff.so.3 not found, install ... done
    The installation then starts the gui interface. Follow the prompts and printing and scanning is provided. Printing on mfp:/dev/mfp4. Scanner comes up as flatbed scanner SCX-4100 Series on USB:0
    You now have 2 printer icons in the Samsung Unifed Driver Configurator and if you select properties for the printer on usb://Samsung/SCX-4100%20Series and change the printer driver to, in my case SCX-4100 the printer works properly, so you have a choice of using either one.

    Regarding your post

    "General Note: Samsung is using different versions of the binary driver and installer script for different locales and printers; you probably need one fairly specific to your printer, but your mileage may vary, as switching from a more-or-less consistent framework to multiple releases seems to have reduced Samsung's file packaging reliability."

    A while back, I was helping a user install a printer and after many tries he/she asked where I was downloading The Unified Driver from. I am working out of UK, using Isle of Man server. The user was using Chinese Samsung site so he/she downloaded from UK and had instant success. Since then I have tried downloading from different Samsung sites but I am unable to generate any errors in my installations. For me, (ver 3.00.37) is fantastic - download, open terminal, change directory, run sudo ./install.sh - perfect every time (So far!)
    Many thanks for the post, I'm trying to find something similar for logitech quickcam communicate stx!!

  6. #226
    Join Date
    Mar 2005
    Location
    BC, Canada
    Beans
    28
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO Install Samsung Unified Printer Driver

    Fantastic directions. I just managed to install my SCX-4300 on my boyfriend(truthfatal)'s computer, after he had kind of tried to but given up. As a mac user with a broken power adapter, who desperately needs to print her art history slides for her final exam on Thursday, I thank you profusely.
    Faith is the truth of passion. Since no passion is more true than another, faith is the truth of nothing.

  7. #227

    Re: HOWTO Install Samsung Unified Printer Driver

    I have just installed the latest version 3.xx (3.00.37) driver on Ubuntu 9.04 (final), for my Fuji Xerox WorkCentre PE220 printer (~= Samsung SCX-4521). I have to say that it's very easy to install the driver now... just works out-of-box! The steps involved are:

    Step 1: Prepare the Driver
    Untar the tarball:

    $ tar zxf UnifiedLinuxDriver.tar.gz

    Step 2: Run the Installer with Root Privilege

    $ cd cdroot
    $ sudo ./autorun

    This is simple. The installer will gently prompt you to run the installer with root privileges if you don't specify 'sudo'.

    Simply follow the instructions in the graphical installer:
    1. Add users you allow to access the printer into the lp group. (To add future users, simply re-run the installer, use the 'Users and Groups' administration utility, or simply use the adduser command.)
    2. Select 'Samsung SCX-4x21 Series' for this printer model
    3. Test to print and it should work!


    For details (including a list of past problems): http://www.vyvy.org/main/en/node/146

  8. #228
    Join Date
    Dec 2006
    Beans
    678

    Re: HOWTO Install Samsung Unified Printer Driver

    Question for anyone who has installed the version 3 driver: have you tried/managed to UNinstall it? I was doing some testing, and managed to end up with a broken v2 and v3 at the same time. I need to clean my system and start over with this, but as best as I can tell, the uninstaller is broken.

    I've also determined that the major difference in all the installer scripts just has to do with what language and printer the installer tries to work with by default; since those often don't work, I don't think the variations in the installer script actually matter.

    I'm going to do some more testing as time allows the next couple of weeks, mainly to determine how well the v3 driver works under various conditions and how many old bugs/issues still remain. If the uninstall issues persist, and since I'll basically have worked through every step of the installer by that point, I may just go ahead and package a .deb for the installation. At the very least, I will overhaul the main instructions to match the current status of the driver more closely.

    If anyone has insight/experience with the install/uninstall/upgrade from v2 to v3 processes, or knows of significant differences in the install scripts beyond what I've determined, please share.

    Also, as I do not have a MFP printer and so can't test scanning, can anyone enlighten me as to how useful the Samsung Unified Driver Configurator actually is?

  9. #229
    Join Date
    Aug 2008
    Beans
    78

    Re: HOWTO Install Samsung Unified Printer Driver

    Just seen your latest post so I thought I'd test the uninstall feature.

    My main Ubuntu is 8.04.2 though I have other copies on different partitions. Clicking on the uninstall option from the Samsung Unified Driver generated a message that I needed supervisor privileges to run program. So I opened a terminal changed to this directory /opt/Samsung/mfp/uninstall and ran the command sudo ./uninstall.sh.

    Surprise, suprise - GUI screen appeared asking if I wanted to uninstall, said yes and off it went. As far as I can tell everything has disappeared except a menu item in Other which reads Uninstall Samsung Unified Driver and clicking on it gives the error message
    Could not launch menu item - Failed to execute child process "/opt/Samsung/mfp/uninstall/uninstall.sh" (No such file or directory). The Samsung Directory under opt has definitely gone and SCX-4100 has gone from System, Administration, Printing.

    The Samsung Unified Driver Configurator allows you to do a scan without needing any other program, such as Xsane. Other than that, you can check and change your printer settings, port settings and print a Samsung test page rather than the Ubuntu test page.

    I'm in complete agreement with previous post from vyvee - ver 3.00.37 works near perfectly. I have completed successful installations of my SCX-4100 on Hardy 8.04.1 and 8.04.2, Intrepid and Jaunty.

  10. #230
    Join Date
    Jan 2009
    Beans
    46

    Re: HOWTO Install Samsung Unified Printer Driver

    my ML-2850ND is missing the envelope size 10 in the 'paper size' of the printer properties. please help.

Page 23 of 104 FirstFirst ... 1321222324253373 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •