What nvidia driver version are u using?
Actually right now I've succeded in both 8776/9746 in 2.6.20-rc7.
Maybe you just need some patching for your nvdia driver.
It's better if you can go to the nvidia linux forum and ask there.