Page 9 of 22 FirstFirst ... 789101119 ... LastLast
Results 81 to 90 of 218

Thread: How to: Xubuntu - Thunar Native Windows Network Browsing

  1. #81
    Join Date
    Apr 2007
    Beans
    6

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by detyabozhye View Post
    Awesome dude, maybe later I'll write an automated shell script for this.
    Hi! Where's the script?

  2. #82
    Join Date
    Mar 2007
    Location
    Dayton. OH
    Beans
    47
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Excellent thread Thanks!!

  3. #83
    Join Date
    Sep 2007
    Location
    UK
    Beans
    20
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by reset3x View Post
    Great thread!!!

    I was having problems with this breaking and not having the shares show up after rebooting my PC's. I've found that assigning static IP's to the effected systems works great. Using DHCP seems to hose everything for me....
    Thanks for that, it was up and down like a lady of the nights undergarments for me, assigned a static IP to the windows box and it's now solid.

    S

  4. #84
    Join Date
    Apr 2007
    Beans
    5
    Distro
    Xubuntu 7.10 Gutsy Gibbon

    Re: How to: access network files on Xubuntu

    I'm a newbie to Xubuntu and my experience might be helpful. I found the easiest way to access my network files was by clicking on 'computer' in Accessories. This gives me the Nautilus Gnome file manager that lets me 'go' to Network and gives me access to any computers on my network. I don't use Thunar at all. Very simple for someone like me that knows nothing about the innards of Linux.

    Note: I installed Ubuntu first and then added Xfce, so am not sure if a basic Xubuntu install will give you the Nautilus file manager or if you have to add it.

    Running Xubuntu/Ubuntu on an8 year old Dell with 128Meg ram. Works great!

  5. #85
    Join Date
    Oct 2007
    Beans
    6
    Distro
    Xubuntu 7.10 Gutsy Gibbon

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Has anyone gotten this to work on xubuntu with the share needing a password? I did a fresh install of xubuntu gutsy, did not do any updates, set my username and password in fusesmb.conf and it was working. Then I turned on automatic updates and let it update. Now I can only see the workgroup, server, and share but I cannot see inside the share. The connection times out and I think that fusesmb is ignoring the conf settings. I know the server is fine because this was working, and I can access it fine when I boot windows. Any ideas?

  6. #86
    Join Date
    Apr 2006
    Beans
    53

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Nice howto. A while ago I used nautilus because of its samba support.

    Have I done something wrong if I can see my samba share, but under workgroup I can't see any other computers but mine?

    Since I don't use Xubuntu, but use Gutsy alternate install+xfce4, I don't have user account manager GUI. But i added myself to /etc/groups file:
    Code:
    fuse:x:106:virx
    If I haven't mounted /media/network yet, then
    Code:
    /media$ ls -la
    total 52
    drwxr-xr-x  7 root     root     4096 2007-11-22 19:23 .
    drwxr-xr-x 21 root     root     4096 2007-10-30 20:39 ..
    lrwxrwxrwx  1 root     root        6 2007-10-30 20:33 cdrom -> cdrom0
    drwxr-xr-x  2 root     root     4096 2007-10-30 20:33 cdrom0
    lrwxrwxrwx  1 root     root        7 2007-10-30 20:33 floppy -> floppy0
    drwxr-xr-x  2 root     root     4096 2007-10-30 20:33 floppy0
    drwxr-xr-x  2 root     root     4096 2007-11-11 22:24 iso
    drwxrwxrwx  2 virx     fuse     4096 2007-11-22 19:23 network
    drwxrwx---  1 root     plugdev 28672 2007-11-07 22:08 sdb1
    After mounting I get strange "test" message:
    Code:
    /media$ fusesmb /media/network/
    test
    And permissions change too:
    Code:
    :/media$ ls -la
    total 48
    drwxr-xr-x  7 root     root      4096 2007-11-22 19:23 .
    drwxr-xr-x 21 root     root      4096 2007-10-30 20:39 ..
    lrwxrwxrwx  1 root     root         6 2007-10-30 20:33 cdrom -> cdrom0
    drwxr-xr-x  2 root     root      4096 2007-10-30 20:33 cdrom0
    lrwxrwxrwx  1 root     root         7 2007-10-30 20:33 floppy -> floppy0
    drwxr-xr-x  2 root     root      4096 2007-10-30 20:33 floppy0
    drwxr-xr-x  2 root     root      4096 2007-11-11 22:24 iso
    drwxr-xr-x  3 virx     virx  4096 2007-11-22 19:27 network
    drwxrwx---  1 root     plugdev  28672 2007-11-07 22:08 sdb1
    Does it mean other computers cannot write themselves into that directory, since there is no permission for "fuse"?

  7. #87
    Join Date
    Apr 2006
    Beans
    53

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    So I tried started from the beginning. At first undid everything at opposite order and then carefully did every step from HOWTO.

    What I didn't get was any changes to fuse, but what I got was getting rid of networking configuration - I guess thanks to removing fusesmb packet and removing "fuse" fom /etc/modules (It was there before I started messing with fuse - so I should have not delete it). After reboot Got message something like: no /etc/networking/interfaces file. After recreating it:
    no /etc/network/if-pre-up.d

    In some strange reason I had 2 NICs in my PC, so I managed to get networking up again through the other NIC, but cannot use networking service, because of missing configuration.
    ifconfig shows at eth0 (NIC i used before messing with fuse):
    in last line - "Interrupt:21 Base address:0x2000"

    Is there any way for recovering network settings?

    EDIT: aptitude reinstall ifupdown helped.

    Now I only have fuse problem, can someone give me any guidlines for seeing other computers from network directory?
    Last edited by virx; November 27th, 2007 at 08:36 PM.

  8. #88
    Join Date
    Sep 2006
    Location
    Groningen / Netherlands
    Beans
    113

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    like so many others...

    I wish to thank you very much!

    I also made a launcher to fusesmb.cache in the panel, so it's really really easy to browse the network and keep mounts fresh.
    huzzah! this has made my xfce experience much better.
    The Linux Counter Project #432059
    The Ubuntu Counter Project #8465
    In his house at R'lyeh dead Cthulhu waits dreaming, yet he shall rise and his kingdom shall cover the Earth.

  9. #89
    Join Date
    Mar 2006
    Beans
    19

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I did the recipe sent by Taz and I had no problems. Xubuntu 7.10 on PIII with 550 MHz and 400 Mb RAM.

  10. #90
    Join Date
    Dec 2007
    Beans
    43

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    WORKED ON XUBUNTU 7.10. THANKS

    Quote Originally Posted by Tazix View Post
    Since Thunar doesn't have native network Browsing, here is a good way to accomplish it:

    1) In XFCE's Applications -> System -> Shared Folders. (This should trigger a Samba install if you don't already have a share, and it should allow you to define the proper workgroup)

    2) Install fusesmb in Synaptic (from Universe repository)

    3) Edit /etc/modules and add the word 'fuse' to the modules list to be loaded (without quotes), and save the file.

    4) Reboot, so the fuse module loads, and the proper workgroup is read for samba.

    5) In XFCE Applications -> System -> Users and Groups... Properties of your username... User Priveleges Tab... check "Allow use of fuse file systems..."

    6) Create a directory that you are going to mount your network browse to... I used /media/network. Change permissions to read / write for group and others (777).

    *** 6.5) In a terminal, type: sudo chown <username>:fuse /media/network
    (Where <username> is your user account logon name)

    *** 6.6) Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked.

    *** 6.7) Reboot the system and triple check with step 6.6

    7) In XFCE Applications -> Settings -> Autostarted Applications... Add an application... name and describe as you wish... for command line, put: fusesmb /media/network (Or whatever mountoint you created).

    8) Open Thunar, and navigate to the parent folder of your mountpoint... then drag the 'mounpoint folder' to the places (shortcut) pane of thunar.

    9) Logout and log back in (So the user privilege and fusesmb autostart will take affect)

    *** Added steps to help prevent some access denied issues some people have been experiencing with fusesmb.

    My original thread on this topic is here: http://www.ubuntuforums.org/showthread.php?t=300310

    I hope this helps my fellow Xubuntu users... and I also hope that the Xubuntu team somehow enables something similar by default, or at least as an install option.

    -Taz

Page 9 of 22 FirstFirst ... 789101119 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •