Page 5 of 22 FirstFirst ... 3456715 ... LastLast
Results 41 to 50 of 218

Thread: How to: Xubuntu - Thunar Native Windows Network Browsing

  1. #41
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by SBFC View Post
    Just curious as to what your solution is for shares that require a specific username password. The windows boxes show up fine, but I get an access denied to my linux share due to it having to authenticate.

    Anyway to have a prompt?

    Should also add that I'm perfectly fine mounting password required shares with linneighborhood (which I currently am). Was just wondering if there was a way to access password shares via thunar...cause the thunar method is damn nice.
    No dialogs, but you can set up passwords manually in ~/.smb/fusesmb.conf
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  2. #42
    Join Date
    Jun 2006
    Beans
    29
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    More on the fuse and /network/media access denied issue...

    Just did a fresh install edgy on my old laptop.

    I purposely did a couple extra steps to ensure that it would work.

    Step 6.5) In a terminal, type: sudo chown <username>:fuse /media/network
    (Where <username> is your user account logon name)
    Step 6.6) Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked.
    Step 6.7) Reboot the system and triple check with step 6.6

    Oh... and this is all done on a non-updated Xubuntu Edgy. I don't know if the problem has been a glitch all along, or if it's a glitch introduced with some package that is updated.

    Hope that helps,

    Taz

  3. #43
    Join Date
    Apr 2005
    Beans
    1,345

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I've got a strange problem. I have set up fusesmb on Feisty and it seems ok. But quite often when I am copying something from the network it fails and /media/network folder disappear. I have to reboot to get it back. I tried:
    Code:
    fusesmb /media/network
    fuse: bad mount point `/media/network': Transport endpoint is not connected
    and
    Code:
    /media$ ls -l
    total 4
    lrwxrwxrwx 1 root root    6 2007-03-04 14:46 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2007-03-04 14:46 cdrom0
    ?--------- ? ?    ?       ?                ? network
    I have no idea what is going on
    ASUS K53S Ubuntu 14.04 64-bit
    ASUS U36jc, i5-480M, 2.66GHz, 4Gb, nVidia Optimus Ubuntu 14.04 64-bit
    HP DV6-2113sa, AMD Turion™ II M620, 4Gb, ATI Radeon™ HD 4530 Ubuntu 14.04 64-bit
    ASUS 1015PX Netbook Lubuntu 14.04

  4. #44
    Join Date
    Jun 2006
    Beans
    29
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by foxy123 View Post
    I've got a strange problem. I have set up fusesmb on Feisty and it seems ok. But quite often when I am copying something from the network it fails and /media/network folder disappear. I have to reboot to get it back. I tried:
    Code:
    fusesmb /media/network
    fuse: bad mount point `/media/network': Transport endpoint is not connected
    and
    Code:
    /media$ ls -l
    total 4
    lrwxrwxrwx 1 root root    6 2007-03-04 14:46 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2007-03-04 14:46 cdrom0
    ?--------- ? ?    ?       ?                ? network
    I have no idea what is going on
    Looks sort of like what happened to me when I tried installing it on my second Edgy Machine.

    Try sudo ls -l

    It's like the directory gets locked up by root somehow.

    Then you need to unload fusesmb, delete the /network directory (with sudo), recreate it, change permissions and ownership, then reload fusesmb. Make sure that your user account is in the fuse group. Sometimes it takes a few tries before the settings stick.

    Something wonky goes on and settings don't stick on certain machines sometimes. I have no clue why. The 1st and 3rd machines I tried it on, I had no issues. But my second machine took several attempts before it worked right.

    Hope that helps,

    Taz
    Last edited by Tazix; March 8th, 2007 at 12:03 AM.

  5. #45
    Join Date
    Mar 2007
    Location
    Barcelona, Catalunya
    Beans
    4
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Hi,

    I have some curious problem. I tried to do this succesfully some days ago, but yesterday I reinstalled Xubuntu on my laptop and now I can't install "fusesmb", simply because it doesn't appears in the synaptic package manager. There's only a "fuse-utils"... So I can't neither use the "fusesmb" command in terminal.

    Any idea how to solve this?

    Thank you!

  6. #46
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by tabako View Post
    Hi,

    I have some curious problem. I tried to do this succesfully some days ago, but yesterday I reinstalled Xubuntu on my laptop and now I can't install "fusesmb", simply because it doesn't appears in the synaptic package manager. There's only a "fuse-utils"... So I can't neither use the "fusesmb" command in terminal.

    Any idea how to solve this?

    Thank you!
    Try enabling the universe repository.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  7. #47
    Join Date
    Mar 2007
    Location
    Barcelona, Catalunya
    Beans
    4
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Well, I re-installed the universe repository (it was installed yet, but some things were missing ) . I installed the fusesmb package but i can't access the network anyway. Is there some method to check the connection or something? I can't connect neither to the other computer by it's IP... I don't know what to do, it was really much easyer with Ubuntu and Nautilus

    I reinstalled the Windows on the other computer too, it's maybe some additional config in windows that I'm forgetting to do?

    I remember that the last time, after configuring samba etc... I had a samba console on settings or accesories, but there isn't now, is it possible that there is something wrong with the samba installation, or even with Xubuntu install...?
    Last edited by tabako; March 12th, 2007 at 04:11 PM.

  8. #48
    Join Date
    Apr 2005
    Beans
    1,345

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I've got another problem. I can see shares in my /media/network/WORKGROUP/MYPC but I can access them. When I click on any share I've got:
    Code:
    Failed to open directory "diskl".
    Connection timed out.
    I can mount the shares with LinNeighborhood without any problem.
    ASUS K53S Ubuntu 14.04 64-bit
    ASUS U36jc, i5-480M, 2.66GHz, 4Gb, nVidia Optimus Ubuntu 14.04 64-bit
    HP DV6-2113sa, AMD Turion™ II M620, 4Gb, ATI Radeon™ HD 4530 Ubuntu 14.04 64-bit
    ASUS 1015PX Netbook Lubuntu 14.04

  9. #49
    Join Date
    Oct 2005
    Beans
    5

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Thanks Tazix for the excellent how-to! Got my machine (Xubuntu Edgy connecting to Thecus N2100 NAS) working very quickly for the first user. The problems came when setting up other users on the same PC trying to mount the same /media/network share - maybe this sheds some light on the permissions problems seen by others....

    Just using an autostart 'fusesmb /media/network' for each user I'd get problems:
    1) 1st user logs in, accesses share OK, logs out.
    2) 2nd user logs in. Share completely disappeared in Thunar. From console
    Code:
    /media$ ls -l
    <entries removed>
    ?--------- ? ?    ?       ?                ? network
    as seen elsewhere. Also
    Code:
    /media$ cat /etc/mtab
    <entries removed>
    fusesmb /media/network fuse rw,nosuid,nodev,allow_other,max_read=32768,user=1st_user 0 0
    Basically the mount is persisting after the user who created it logs out, so the directory permissions of the mount look screwed to the next user who logs in. To work around this, I tried reacocard's trick and changed the autostart for each user to 'fusesmb /media/network -o allow_other' and also created the file /etc/fuse.conf
    Code:
    /media$ cat /etc/fuse.conf
    user_allow_other
    Starting again with a re-created /media/network, everything is fine as subsequent users logging in get to reuse the first user's mount, which is OK until I want to mount shares with restricted access. As per EatMorePie I've given each user a ~/.smb/fusesmb.conf
    Code:
    [global]
    username=YourSMBUsername
    password=YourSMBPassword
    So now:
    1) 1st user logs in, accesses share OK (including their private directories), logs out.
    2) 2nd user logs in. Inherits first user's mount including credentials!! Can access first user's private directories, but can't access their own! Oops!

    As a workaround, I've changed the autostart for each user to 'fusesmb /media/network -o allow_other,nonempty'. This has the effect of forcing a new mount with the correct credentials as each user logs in. It's good enough to use at home the stop the kids accidentally deleting work I'm trying to protect on my Raid1 NAS. It is obviously not good security though, as it relies on the next user to play nice and replace the previous user's mount.....

    Any ideas how to tear down the mount at logout? Do I need to add a script somewhere with 'fusesmb /media/network -o hard_remove'?

    The other side effect, which may or may not be a problem, is that /etc/mtab ends up like this:
    Code:
    /media$ cat /etc/mtab
    <entries removed>
    fusesmb /media/network use rw,nosuid,nodev,allow_other,max_read=32768,user=1st_login 0 0
    fusesmb /media/network fuse rw,nosuid,nodev,allow_other,max_read=32768,user=2nd_login 0 0
    fusesmb /media/network fuse rw,nosuid,nodev,allow_other,max_read=32768,user=3rd_login 0 0
    <...etc>
    For each entry in /etc/mtab there is still a live fusesmb process, belonging to whichever user's autostart created it. Of course a reboot cleans up all the processes and associated mtab entries. So maybe the question should be, is there a better way to launch fusesmb instead of autostart, so that the process gets killed automatically at logout?

    Any suggestions for a more elegant multi-user PC setup much appreciated
    Last edited by mw99; March 15th, 2007 at 02:07 PM.

  10. #50
    Join Date
    Oct 2005
    Beans
    5

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I can partly answer my own questions:

    "Bug 2382 - Request - Add ability to kill processes at xfce shutdown" at http://bugzilla.xfce.org/show_bug.cgi?id=2382 suggests there's no easy way to kill the fusesmb processes when the xfce session ends.

    The author states "I know this can be done easily by editing $HOME/.xinitrc (and that works fine for now), but it would be nice to have this ability inside xfce." Any script writers out there know how to run fusesmb from inside .xinitrc instead of using xfce autostart?

Page 5 of 22 FirstFirst ... 3456715 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •