Page 2 of 22 FirstFirst 123412 ... LastLast
Results 11 to 20 of 218

Thread: How to: Xubuntu - Thunar Native Windows Network Browsing

  1. #11
    Join Date
    Jul 2005
    Location
    Waikerie, South Australia
    Beans
    217
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    This works well until the network changes. It only picks up what's on the network at boot not anything that is added later. Is there any way to refresh the network?

    EDIT: I just found the answer to my own question from here http://ubuntuforums.org/showthread.php?t=71797
    Just open a terminal and type in
    Code:
    fusesmb.cache
    Last edited by sawjew; December 5th, 2006 at 01:57 AM. Reason: found solution

  2. #12
    Join Date
    Sep 2006
    Beans
    70

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Hi all...Newbie alert

    I have followed the how-to but when I reach the final step (opening the /media/network folder) there is no MSHOME inside.

    When I check /media/network folder permissions I find Owner (Root) is still read and write but Group and Others have been changed to read only.

    The "Allow use of fuse filesystems etc" box mentioned in step 5 is ticked.

    sudo chmod 777 /media/network gives permission denied.

    mount /media/network gives....

    according to mtab, fusesmb is already mounted on /media/network mount failed

    FWIW, in "Process Manager" I have two instances of fusesmb running.

    Any advice appreciated.

    Regards
    Miguel

  3. #13
    Join Date
    Jun 2006
    Beans
    29
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Miguellint View Post
    sudo chmod 777 /media/network gives permission denied.
    Sounds like either your sudo is messed up, or fusesmb is "locking" the changing of the directoy or something.

    Since I don't see any way in the help / man pages to start / stop fusesmb... Try undoing step 7, so it doesn't auto start (remove the auto started application in xfce)

    If you are also running it in your fstab, edit and take it out of there too.

    Reboot... then try to sudo chmod 777 /media/network in a terminal window.

    If you can successfully change the permissions to 777, Then redo step 7 and don't add anything to your fstab.

  4. #14
    Join Date
    Sep 2006
    Beans
    70

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Tazix View Post
    Sounds like either your sudo is messed up, or fusesmb is "locking" the changing of the directoy or something.

    Since I don't see any way in the help / man pages to start / stop fusesmb... Try undoing step 7, so it doesn't auto start (remove the auto started application in xfce)

    If you are also running it in your fstab, edit and take it out of there too.

    Reboot... then try to sudo chmod 777 /media/network in a terminal window.

    If you can successfully change the permissions to 777, Then redo step 7 and don't add anything to your fstab.
    Hello Taz....Thanks for the reply. Still no success.

    There's no mention of fusesmb in my /etc/fstab.

    Without the fusesmb autostart I can manually sudo chmod 777 /media/network.

    But after I fusesmb /media/network in the terminal the permissions change back to Owner rw, Group and Others ro which was my original problem.

    However once I do the fusesmb /media/network command my /etc/mtab has a fusesmb entry....

    fusesmb /media/network fuse rw,nosuid,nodev,max_read=32768,user=samsung 0 0

    (samsung is my username). Is this of any help?

    Thanks
    Miguel

  5. #15
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Miguellint View Post
    But after I fusesmb /media/network in the terminal the permissions change back to Owner rw, Group and Others ro which was my original problem.
    Try running fusesmb with this command instead:
    Code:
    fusesmb /media/network -o allow_other
    that should fix the permissions so anyone can access it.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  6. #16
    Join Date
    Sep 2006
    Beans
    70

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by reacocard View Post
    Try running fusesmb with this command instead:
    Code:
    fusesmb /media/network -o allow_other
    that should fix the permissions so anyone can access it.
    Hello reacocard....Thanks for taking the time to reply.

    I entered the command as you suggested but there's no change except /etc/mtab now reads.....

    fusesmb /media/network fuse rw,nosuid,nodev,allow_other,max_read=32768,user=sa msung 0 0

    Before I entered the fusesmb command, /media/network was owned by root and everyone had read and write permissions.

    After I entered the fusesmb command, /media/network was owned by samsung (my user name) and Group and Others became read only. When I try to manually change the permissions I get "access denied"

    Should "system/users_and_groups/root/properties/user privileges/allow use of fuse...." be ticked or not. My "user_name/allow use of fuse...." is ticked as per Taz's original instructions, but root isn't. (FTR, I've tried root ticked and not ticked and neither seem to make a difference.)

    Any help appreciated.

    Thanks
    Miguel

  7. #17
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Miguellint View Post
    I entered the command as you suggested but there's no change except /etc/mtab now reads.....

    fusesmb /media/network fuse rw,nosuid,nodev,allow_other,max_read=32768,user=sa msung 0 0

    Before I entered the fusesmb command, /media/network was owned by root and everyone had read and write permissions.

    After I entered the fusesmb command, /media/network was owned by samsung (my user name) and Group and Others became read only. When I try to manually change the permissions I get "access denied"
    Try doing fusesmb as root instead:
    Code:
    sudo fusesmb /media/network -o allow_other
    that should work. If this fails, you could just mount fusesmb with read-write for your current user in /home/<username>/Network, thereby avoiding the permissions problem altogether.

    Should "system/users_and_groups/root/properties/user privileges/allow use of fuse...." be ticked or not. My "user_name/allow use of fuse...." is ticked as per Taz's original instructions, but root isn't. (FTR, I've tried root ticked and not ticked and neither seem to make a difference.)
    Yes, allow fuse should be checked. Having root's checked shouldn't matter, as root has access to everything.
    Last edited by reacocard; December 19th, 2006 at 04:18 PM.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  8. #18
    Join Date
    Sep 2006
    Beans
    70

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Hello again reacocard,

    My apologies. I seem to have been wasting everyones time.

    I tried your latest suggestions but with no success.

    So I resized my 60GB Xubuntu partition down to 50GB and used the freed up 10GB for a fresh install of Xubuntu to the new 10GB partition (called Xubuntu2)

    Lo and behold, by following Taz's original instructions there were no problems setting up the samba network share in the fresh installation. So something is amiss in my original installation.

    I doubt I have the ability to track down what's causing the problem so it looks like I might just increase the size of my new 10 GB partition and gradually migrate to it from the old partition.

    Crude, I know. But it gets the job done which is the main thing.

    Again, apologies for wasting your (and Taz's) time.

    Regards
    Miguel

  9. #19
    Join Date
    Apr 2005
    Beans
    1,350

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Miguellint View Post
    Hello again reacocard,

    My apologies. I seem to have been wasting everyones time.

    I tried your latest suggestions but with no success.

    So I resized my 60GB Xubuntu partition down to 50GB and used the freed up 10GB for a fresh install of Xubuntu to the new 10GB partition (called Xubuntu2)

    Lo and behold, by following Taz's original instructions there were no problems setting up the samba network share in the fresh installation. So something is amiss in my original installation.

    I doubt I have the ability to track down what's causing the problem so it looks like I might just increase the size of my new 10 GB partition and gradually migrate to it from the old partition.

    Crude, I know. But it gets the job done which is the main thing.

    Again, apologies for wasting your (and Taz's) time.

    Regards
    Miguel
    I had a similar problem but then it was gone. I am not sure that I did much for that. I remeber creating another dir in /media but have never used it as /media/network started to work fine.

    Try to uninstall all the fuse stuff and do it again. Might help.
    ASUS K53S Ubuntu 14.04 64-bit
    ASUS U36jc, i5-480M, 2.66GHz, 4Gb, nVidia Optimus Ubuntu 14.04 64-bit
    HP DV6-2113sa, AMD Turion™ II M620, 4Gb, ATI Radeon™ HD 4530 Ubuntu 14.04 64-bit
    ASUS 1015PX Netbook Lubuntu 14.04

  10. #20
    Join Date
    Jun 2006
    Beans
    29
    Distro
    Xubuntu 6.10 Edgy

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Miguellint View Post
    Hello again reacocard,

    So I resized my 60GB Xubuntu partition down to 50GB and used the freed up 10GB for a fresh install of Xubuntu to the new 10GB partition (called Xubuntu2)

    Lo and behold, by following Taz's original instructions there were no problems setting up the samba network share in the fresh installation. So something is amiss in my original installation.
    Sorry for the long time to reply. Busy Holliday Season for me this year.

    It sounds like something was forcing security permissions on your original install... Like an SELinux install option (Not sure if Xubuntu has this... haven't done an install in a while). But the point is... It looks like some security app (whether installed durring or after your original install) was overridding any permissions that you were trying to set.

    Glad it worked for you on a fresh install, though.

    -Taz

Page 2 of 22 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •