Page 14 of 22 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 218

Thread: How to: Xubuntu - Thunar Native Windows Network Browsing

  1. #131
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,277
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    do you have a dns server or WINS server running locally or are you using your hosts file?
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  2. #132
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    It's using avahi the mdns thing. This is installed by default and enabled on ubuntu. And I usually install bonjour on the windows machines so they use mdns as well.

  3. #133
    Join Date
    Sep 2006
    Beans
    3

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Tazix: thanks for the how-to, works well on XUbuntu 8.04 . Newbies will have problems applying this to the system, so I think it should get into installation as a option (which is turned on by default)

  4. #134
    Join Date
    Aug 2007
    Beans
    25
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by Tazix View Post
    Since Thunar doesn't have native network Browsing, here is a good way to accomplish it:

    1) In XFCE's Applications -> System -> Shared Folders. (This should trigger a Samba install if you don't already have a share, and it should allow you to define the proper workgroup)

    2) Install fusesmb in Synaptic (from Universe repository)

    3) Edit /etc/modules and add the word 'fuse' to the modules list to be loaded (without quotes), and save the file.

    4) Reboot, so the fuse module loads, and the proper workgroup is read for samba.

    5) In XFCE Applications -> System -> Users and Groups... Properties of your username... User Priveleges Tab... check "Allow use of fuse file systems..."

    6) Create a directory that you are going to mount your network browse to... I used /media/network. Change permissions to read / write for group and others (777).

    *** 6.5) In a terminal, type: sudo chown <username>:fuse /media/network
    (Where <username> is your user account logon name)

    *** 6.6) Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked.

    *** 6.7) Reboot the system and triple check with step 6.6

    7) In XFCE Applications -> Settings -> Autostarted Applications... Add an application... name and describe as you wish... for command line, put: fusesmb /media/network (Or whatever mountoint you created).

    8) Open Thunar, and navigate to the parent folder of your mountpoint... then drag the 'mounpoint folder' to the places (shortcut) pane of thunar.

    9) Logout and log back in (So the user privilege and fusesmb autostart will take affect)

    *** Added steps to help prevent some access denied issues some people have been experiencing with fusesmb.

    My original thread on this topic is here: http://www.ubuntuforums.org/showthread.php?t=300310

    I hope this helps my fellow Xubuntu users... and I also hope that the Xubuntu team somehow enables something similar by default, or at least as an install option.

    -Taz
    Only problem is that if you are using a wireless network, it takes time to connect, and the autostart script tries to run to fuse the netmount in samba before the wireless net is connected and fails. After the wireless net is connected, the fused samba mount is not readable. Is there any way to get the fuse smb script to wait to run until the wireless net is connected, or to keep checking for available workgroup computers at stated time intervals after the wireless net is connected?

    JRW

  5. #135
    Join Date
    Jan 2008
    Beans
    1

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I tried this, and whenever I actually try to mount fuse to the folder ($ fusesmb /media/network), I can no longer access the folder. I am told that permission is denied, and an ls shows "d????????? ? ? ? ? network" for the entire folder. Did I do something wrong?

  6. #136
    Join Date
    Oct 2006
    Location
    Flanders, Belgium
    Beans
    205

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I'm having a similar and very annoying problem. I'm running Xubuntu Hardy with fusesmb configured the way it should. I was able to access shared folders on all of my machines in my home network (one is W2K, one is Mint and the other one Ubuntu Hardy) with no problem. Suddenly, I can no longer access the folders. My PC sees the machines and the folders but when double-clicking the folders I immediately get a "Verbinding verlopen" ("Connection timed out" in Dutch) error. This is driving me crazy. I've been googling for days now, no solutions found.
    Here's how to install Vista in 2 minutes:
    http://www.youtube.com/watch?v=FVbf9tOGwno

  7. #137
    Join Date
    Apr 2005
    Beans
    1,357

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    I've got a similar problem on Intrepid. It starts ok but then Network folder disappears after a couple of click.
    ASUS K53S Ubuntu 14.10 64-bit
    ASUS 1015PX Netbook Lubuntu 14.10
    Two Dell laptops with 14.04

  8. #138
    Join Date
    May 2008
    Beans
    19
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Quote Originally Posted by foxy123 View Post
    I've got a similar problem on Intrepid. It starts ok but then Network folder disappears after a couple of click.
    Just want to say that I'm having the same problem. It works for a few seconds, and then blips out.

    I'm wondering if loading a different program (i.e. other than Thunar) would be useful?

  9. #139
    Join Date
    Jan 2007
    Beans
    30

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    Have the same exact problem after upgrading from hardy to intrepid.
    doing
    umount /media/network
    fusesmb /media/network

    remounts for several seconds and then goes back to the mentioned error.
    Never had this problem in hardy.

    running ls -l gives:

    ls: cannot access network: Transport endpoint is not connected
    total 48
    .
    .censored
    .
    d????????? ? ? ? ? ? network
    .
    .censored

    while running sudo ls -l gives:

    ls: cannot access network: Permission denied
    total 48
    .
    .censored
    .
    d????????? ? ? ? ? ? network
    .
    .censored
    Last edited by benma; November 4th, 2008 at 09:18 PM.

  10. #140
    Join Date
    Jan 2007
    Beans
    30

    Re: How to: Xubuntu - Thunar Native Windows Network Browsing

    It seems it's a Thunar problem, because if i don't open Thunar and browse /media/network from CLI, nothing happens - fusesmb stays connected.
    Last edited by benma; November 4th, 2008 at 10:03 PM.

Page 14 of 22 FirstFirst ... 41213141516 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •