Page 1 of 26 12311 ... LastLast
Results 1 to 10 of 252

Thread: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

  1. #1
    Join Date
    Jan 2005
    Location
    Baltimore, MD, USA
    Beans
    865
    Distro
    Ubuntu Development Release

    Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    This Guide is Dead
    I am no longer supporting this guide. I will leave it up for posterity but if you want compositing effects, please upgrade to feisty (and beyond) and use System->Preferences->Desktop Effects. This guide was a hack to get things running when this technology was new, and now the technology has been tested and made more official (and it works better than this guide).

    That said, here is the original guide:


    Howto: ATI Radeon Mobility 9000 + Edgy FGLRX ( 8.28 ) + Beryl
    First I would like to thank Lennart Hansen and his guide, and also the Ubuntu Forums for helping me find the FGLRX solutions for suspend/hibernate.

    Also I would like to thank my Computer Vision professor for having boring lectures, inspiring me to get beryl working instead of paying attention. Also my Computer Integrated surgery professor for being boring and giving me the motivation to write this guide instead of paying attention. Be cool stay in school!

    This guide has 3 parts:
    - FGLRX
    - Beryl and XGL
    - Tweaks & Optimizations

    Just to clear things up, when I write:
    Code:
    $ echo hello
    The "$" means to run this on the command line. You can open a terminal by going to Applications->Accessories->Terminal.

    When I say Edit "file" I mean run: "$ sudo gedit file" or "$ sudo nano -w file", or any other way you want to edit it.

    FGLRX
    Update your packages:
    Code:
    $ sudo aptitude update
    $ sudo aptitude dist-upgrade
    Install the driver and module:
    Code:
    $ sudo aptitude install xorg-driver-fglrx
    For some reason, linux-restricted modules will install the modules, but when you reboot they disappear. So what we do is install them, copy the fglrx module to a safe folder, and then uninstall them. You will have to do this for every kernel update. When I figure out a better way to do this, I'll update the guide.
    Code:
    $ sudo aptitude install linux-restricted-modules-`uname -r`
    Now copy the module (the first line creates the directory, so if it is already there and there is an error, it is not a problem):
    Code:
    $ sudo mkdir /lib/modules/`uname -r`/misc
    $ sudo cp /lib/modules/`uname -r`/volatile/fglrx.ko /lib/modules/`uname -r`/misc/fglrx.ko
    Now uninstall the package:
    Code:
    $ sudo aptitude remove linux-restricted-modules-`uname -r`
    Now update your module list:
    Code:
    $ sudo depmod -a
    Now you've all seen this before if you've tried to use fglrx. If you know what you are doing, you can just edit xorg.conf manually to use fglrx, or just type this:
    Code:
    $ sudo aticonfig --initial 
    $ sudo aticonfig --overlay-type=Xv
    Add this to the end of xorg.conf ("$ sudo gedit /etc/X11/xorg.conf" to edit it):
    Code:
    Section "Extensions"
            Option      "Composite" "0"
    EndSection
    Now you have two choices to test fglrx.
    1) The easy way: reboot
    2) If you know what you are doing, log out, switch to a console, stop gdm, rmmod radeon and modprobe fglrx, then start gdm. Then you don't have to reboot.

    Log in and make sure that fglrx is working:
    Code:
    $ fglrxinfo
    Mine spits out:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: MOBILITY/RADEON 9000 DDR Generic
    OpenGL version string: 1.3.1091 (X4.3.0-8.28.8)
    Make sure it says ATI and not Mesa.

    Beryl and XGL
    Big thanks to this guide:
    http://lhansen.blogspot.com/2006/10/...untu-edgy.html

    I pretty much copied what he did, but on the command line, because it is easier to do in a text-howto. You can also do things his way.

    Edit /etc/apt/sources.list and add this:
    Code:
    # beryl
    deb http://ubuntu.beryl-project.org edgy main
    deb-src http://ubuntu.beryl-project.org edgy main
    
    # beryl-svn
    deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
    deb-src http://download.tuxfamily.org/3v1deb edgy beryl-svn
    The second batch are for the svn releases. As of 2/7/2007 when I edited this, only the svn releases and old versions (<=1.4) are working, so naturally I want the svn because it has cool stuff.

    So if you do not want to install the svn packages, you have to manually downgrade to 1.4 to get it to work.

    Now update your repo:
    Code:
    $ sudo aptitude update
    $ sudo aptitude dist-upgrade
    Now install XGL and Beryl:
    Code:
    $ sudo aptitude install beryl emerald-themes xserver-xgl
    Now create the XGL script. Edit "/usr/bin/startxgl" and paste in this:
    Code:
    #!/bin/sh
    Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
    DISPLAY=:1
    exec dbus-launch --exit-with-session gnome-session
    Make it executable:
    Code:
    $ sudo chmod +x /usr/bin/startxgl
    Now make a separate session for XGL. Edit "/usr/share/xsessions/xgl.desktop":
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=Xgl
    Comment=Start an Xgl Session
    Exec=/usr/bin/startxgl
    Icon=
    Type=Application
    Now log out, and log in with the XGL session (click Sessions and choose XGL). Once you log in, run "beryl-manager" to start beryl. You can add this to your session start up programs if you want, but its good to test it first.

    If you try to move a window and it crashes, read the next section!!!

    Tweaks & Optimizations
    Read first
    You can always log in to normal gnome and run "beryl-manager" to edit settings without beryl being loaded. This is very useful.

    Start beryl-manager automatically
    Click System->Preferences->Sessions
    Go to the Startup Programs tab and click Add, then type "beryl-manager".

    Crashes & Performance
    I had trouble with wobbly windows, and also since the Mobility 9000 isnt that great a card, I tuned some stuff down for good responsiveness. Download the attached beryl-settings.Profile and click the beryl-manager icon and click Beryl Settings Manager and click import and import the attached file (after unzipping).

    Also check out this post:
    http://www.ubuntuforums.org/showthread.php?t=276498

    Dashing Good Looks
    I opened the emerald theme manager (right click the beryl icon) and chose the human theme, because I like it. Also I clicked the Emerald Settings tab and made the Titlebar Doubleclick Action = Maximize/Restore.

    Hey why don't my caps/skydome work?!
    If your caps don't work, try converting to PNG. Also, for skydome, make sure your resolution of your image is a power of two by a power of two. Like any of these dimensions:
    512x512, 2048x1024, 4096x512, etc... Any combo of a power of two will work.

    FGLRX Suspend and Hibernate
    Edit "/etc/default/acpi-support" and change the following lines:
    Code:
    MODULES_WHITELIST="fglrx"
    SAVE_VBE_STATE=false
    POST_VIDEO=false
    DOUBLE_CONSOLE_SWITCH=true
    Turn off the gnome-panel "launching box" that runs slow in xgl
    Run gconf-editor and go to:
    /apps/panel/global
    and uncheck "enable animations"
    Attached Files Attached Files
    Last edited by Paerez; August 13th, 2007 at 06:58 PM.
    Knowledge is half the battle.
    The other half is violence!

  2. #2
    Join Date
    Oct 2006
    Beans
    5

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    Thanks for writing this guide, unfortunately I cannot get past the first half of installing the fglrx drivers.

    fglrxinfo gives me:

    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc.
    OpenGL renderer string: Mesa DRI R200 20060602 AGP 4x NO-TCL
    OpenGL version string: 1.2 (1.3 Mesa 6.5.1)
    Any help is appreciated

  3. #3
    Join Date
    Oct 2005
    Location
    Raleigh, NC
    Beans
    44
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    i get an error message that says:

    XGL Absent, checking for NVIDIA
    Nividia Absent, assuming AIGLX
    beryl: No composite extension



    i have an ati card and the fglrx installed. i have added:

    Section "Extensions"
    Option "Composite" "0"
    EndSection

    to the bottom of my xorg.conf file. (i had to do this to get edgy to give me anything graphical after 6.04 -> 6.10

    but i have xserver-xgl installed, i even installed xserver-xorg-video-ati.
    im not sure what's going on, but i did have compiz working on 6.04 and so i know beryl should work on my 6.10...

    is anyone else having a similar problem?

  4. #4
    Join Date
    Apr 2006
    Beans
    58

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    I don't see any attachement. Can you please re-attach the profile?

  5. #5
    Join Date
    Jul 2006
    Beans
    4

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    hi, thanks for the guide, it worked with me but I cant play 3dgames with wine after beryl installed and running, is it possible to run games under beryl?
    thx

  6. #6
    Join Date
    Jan 2005
    Location
    Baltimore, MD, USA
    Beans
    865
    Distro
    Ubuntu Development Release

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    Hey all:

    1) I attached the file, my bad...
    2) I can't get 3d working in any applicaion within beryl, it says that DRI is not found. My mplayer is really slow using Xv, and gl2 doesn't work.
    3) For those of you who can't get it to work, can you post your video card?
    Last edited by Paerez; November 3rd, 2006 at 03:23 PM. Reason: clarification
    Knowledge is half the battle.
    The other half is violence!

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    So you, even, cant make Direct Rendering work. Can you run Beryl/Compiz without it?

  8. #8
    Join Date
    Jan 2005
    Location
    Baltimore, MD, USA
    Beans
    865
    Distro
    Ubuntu Development Release

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    I get direct rendering working, and thus beryl working too. What I can't get to work is any 3d application other than beryl. So it's like beryl hogs the 3d, and whenever another app tries to do 3d, it crashes X.
    Knowledge is half the battle.
    The other half is violence!

  9. #9
    Join Date
    Oct 2006
    Beans
    5

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    I have an ATI Mobility Radeon 9000

    I've followed numerous guides on this forum to try and get Direct Rendering to work, but it always reverts back to Mesa

  10. #10
    Join Date
    Jan 2005
    Location
    Baltimore, MD, USA
    Beans
    865
    Distro
    Ubuntu Development Release

    Re: Howto: ATI Mobility Beryl/XGL FGLRX in Edgy

    ok, go to a terminal and type in the following commands, and paste me the output:
    Code:
    $ sudo modprobe fglrx
    $ lsmod | grep fglrx
    $ lsmod | grep radeon
    Knowledge is half the battle.
    The other half is violence!

Page 1 of 26 12311 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •