Page 98 of 137 FirstFirst ... 488896979899100108 ... LastLast
Results 971 to 980 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #971
    Join Date
    Jun 2009
    Location
    Indiana
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    From man pam_mount
    Code:
    Configuration
           The   primary   configuration   file   for   the  pam_mount  module  is
           pam_mount.conf.xml.   On  most  platforms  this  file  is   read   from
           /etc/security/pam_mount.conf.xml.  On  OpenBSD pam_mount reads its con‐
           figuration file from  /etc/pam_mount.conf.xml.   See  pam_mount.conf(5)
           documenting its use.
    After installing ->
    Code:
    dmizer@ubuntu-jaunty:~$ ls /etc/security/
    access.conf  limits.conf     namespace.init  pam_env.conf        sepermit.conf
    group.conf   namespace.conf  opasswd         pam_mount.conf.xml  time.conf
    But it's not in either /etc/security or /etc. That howto guide is stating that it should be there. If I have to create it, that's another thing. Haha. I feel pretty dumb right now, since I can't find this, but I honestly don't see it.

  2. #972
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    The howto I pointed you to indicates that the file is pam_mount.conf, but the file is actually pam_mount.conf.xml according to man.

    Just to be sure, post the following:
    Code:
    ls /etc/security
    Also post:
    Code:
    aptitude search pam-mount
    Last edited by dmizer; June 16th, 2009 at 02:24 PM.

  3. #973
    Join Date
    Jun 2009
    Location
    Indiana
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    The howto I pointed you to indicates that the file is pam_mount.conf, but the file is actually pam_mount.conf.xml according to man.

    Just to be sure, post the following:
    Code:
    ls /etc/security
    Also post:
    Code:
    aptitude search pam-mount
    Code:
    rootadm@ubuntu1:/etc/security$ ls /etc/security
    access.conf  limits.conf     namespace.init  pam_env.conf         sepermit.conf
    group.conf   namespace.conf  opasswd         pam_lwidentity.conf  time.conf
    Code:
    rootadm@ubuntu1:/etc/security$ aptitude search pam-mount
    p   libpam-mount                    - PAM module that can mount volumes for a us

  4. #974
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Looks like you don't actually have libpam-mount installed, which would explain why you couldn't find the conf file

    Try again:
    Code:
    sudo apt-get install libpam-mount

  5. #975
    Join Date
    Jun 2009
    Location
    Indiana
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Looks like you don't actually have libpam-mount installed, which would explain why you couldn't find the conf file

    Try again:
    Code:
    sudo apt-get install libpam-mount
    Ah! There we go! Haha thanks a lot! Sorry it took so long for that to finally get resolved.

  6. #976
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Mount samba shares with utf8 encoding using cifs

    My fault, I had the -s flag in apt-get.

    /me fixes previous post.
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  7. #977
    Join Date
    Jun 2009
    Location
    Indiana
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by bodhi.zazen View Post
    My fault, I had the -s flag in apt-get.

    /me fixes previous post.
    Aha yeah. I wasn't sure if that needed to be there myself. I should have realized it. Ah well. I'm not having much success however, but it's pointless for me to continue trying. My boss says he can get XP Pro licenses for $2 a license... So he wants to go that direction. Thanks for the help though. I'm still going to reference this however, and try to figure out how to mount the specific drive to the specific login though. It has me on the ropes, and I'll be damned if I give up! Lol Thanks though.

    Google
    is your best friend

  8. #978
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ZackM View Post
    My boss says he can get XP Pro licenses for $2 a license... So he wants to go that direction.
    Ugh, sorry

    Don't forget to remind him about the necessary firewall and virus subscriptions (each with yearly renewals of course).

  9. #979
    Join Date
    Jun 2009
    Location
    Indiana
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Ugh, sorry

    Don't forget to remind him about the necessary firewall and virus subscriptions (each with yearly renewals of course).
    Haha thank you for your condolences. He knows about the firewall and virus subscriptions, but feels it'd be easier on everyone I guess. Ah well... You win some you lose some I guess. We'll switch to Open Source some day.

    Google
    is your best friend

  10. #980
    Join Date
    Jan 2008
    Location
    Australia
    Beans
    24
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Great How To dmizer, tried in vein to mount my password protected network drive, and following your instructions (with one minor tweak) now it just works, and with much less fuss than in windows!!

    I had read in another How To that when mounting a shared network drive with cifs you need to replace the NETBIOS name with the ip address of the network drive, which was the final tweak to getting everything working for me.

    Sorry if this question has been answered already, but this thread is huge!!
    My network drive is formatted in FAT32 and is an Airport Disk, being that it is plugged into an Airport Extreme Router. The router uses smb to broadcast a virtual filesystem on the network so as to make it mountable in any OS. Not sure if this is applicable to my problem, but I'm getting the
    Code:
    [18.312000] CIFS VFS: Server not responding
    [18.312000] No response for cmd 5 mid 8
    error you mentioned on shutdown.

    Do I still use the same commands you wrote underneath to fix this, even though my set up is slightly different than mounting shares directly on a server/partition?

Page 98 of 137 FirstFirst ... 488896979899100108 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •