Page 94 of 137 FirstFirst ... 44849293949596104 ... LastLast
Results 931 to 940 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #931
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by sloppyc View Post
    Good to know, I didn't realize.
    Well, I've since learned that sometimes it is enabled and sometimes it's not. What causes it to be enabled or disabled, I've yet to determine ...

    Quote Originally Posted by sloppyc View Post
    That didn't have any effect. I'm embarrassed to admit that the formatting of my .smbcredentials was incorrect all along. That's what I get for doing things in a hurry late at night.

    So, the guide works flawlessly in jaunty as-is, just as it did in Hardy for me. Thanks again
    You might not be surprised to hear that I've made the very same mistake more times than I care to admit

  2. #932
    Join Date
    Jul 2008
    Beans
    68
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    Haha We all have our moments.

  3. #933
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I've just installed Kubuntu on another machine, and running into the old cfs server not responding issue on shutdown, however the PostSession file that I used in Ubuntu doesn't exist.

    Any help would again be appreciated.
    David

  4. #934
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by swatsbiz View Post
    I've just installed Kubuntu on another machine, and running into the old cfs server not responding issue on shutdown, however the PostSession file that I used in Ubuntu doesn't exist.

    Any help would again be appreciated.
    David
    How about an all gui way of doing this?

    Open "system settings" > "advanced" > "login manager" > "Shutdown (5)"

    Replace the Halt and Reboot commands as follows:
    /etc/init.d/umountnfs.sh&&/sbin/halt
    /etc/init.d/umountnfs.sh&&/sbin/reboot

    Click "apply"

    Done.

  5. #935
    Join Date
    Apr 2007
    Beans
    30
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Alright, I read through the first few pages of this thread, and I haven't gotten anywhere. I have a Thecus N4100Pro that I'm trying to mount via the command line, and I'm having issues. I dual boot between Windows and Ubuntu 9.04, so I'm using CIFS instead of NFS. I feel like I've tried every command known to man. If I go to Places -> Connect to Server..., I can connect to and mount my share just fine:



    That works perfectly. I have 2 users, 1 with read/write permission, and 1 with just read permission, and the mount works flawlessly with both users.

    However, when I try to mount it via the command line (which is desirable because I eventually want to permanently mount it via fstab later), it just won't work. I can get it to mount via the following command:

    Code:
    sudo mount -t cifs //192.168.1.100/share /media/galactica/ -o user=fangs404,password=PW,domain=WORKGROUP,file_mode=0777,dir_mode=0777
    It mounts, and I see it on my desktop. However, when I go to open the folder, I get this error:



    What am I doing wrong? Dah, this is frustrating!

  6. #936
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try this:
    Code:
    sudo chown fangs404:fangs404 /media/galactica
    Where "fangs404" is your UBUNTU username.

    Then try your manual mount command again. You will probably also have better luck if you enable name browsing by configuring /etc/nsswitch.conf and installing winbind as outlined under "Pre-work".

    Also, a word of advice. Always check the dates of threads. While the first post in this thread is up to date and current (as shown by the "version history"), the subsequent posts are quite old and not current.

    So, when you run into a thread like this, don't bother with reading through the first sevral pages, always start from the last page and work your way forward, as the last page will have the most recent and up to date information.

  7. #937
    Join Date
    Apr 2007
    Beans
    30
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try this:
    Code:
    sudo chown fangs404:fangs404 /media/galactica
    Where "fangs404" is your UBUNTU username.

    Then try your manual mount command again. You will probably also have better luck if you enable name browsing by configuring /etc/nsswitch.conf and installing winbind as outlined under "Pre-work".

    Also, a word of advice. Always check the dates of threads. While the first post in this thread is up to date and current (as shown by the "version history"), the subsequent posts are quite old and not current.

    So, when you run into a thread like this, don't bother with reading through the first sevral pages, always start from the last page and work your way forward, as the last page will have the most recent and up to date information.
    Alright, I tried the chown command, and I also installed winbind which allows me to do this now:



    That works just as 192.168.1.100 did before. It works without issue. Now I try this:

    Code:
    sudo mount -t cifs //galactica/share /media/galactica/ -o user=fangs404,password=PW,domain=WORKGROUP,iocharset=utf8,file_mode=0777,dir_mode=0777
    However, the same thing is happening - it's mounting, but I still can't access it due to invalid permissions (the same error I posted above). Have any other ideas?

  8. #938
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try this:
    Code:
    sudo mount -t cifs //galactica/share /media/galactica/ -o rw,user=fangs404,password=PW,domain=WORKGROUP,iocharset=utf8,file_mode=0777,dir_mode=0777
    If that doesn't work, please post the output of:
    smbtree

  9. #939
    Join Date
    Apr 2007
    Beans
    30
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    It didn't work. I ran smbtree, it asked for my password, I typed it, and then it didn't output anything.

    Code:
    fangs404@fangs404-desktop:~$ smbtree
    Password: 
    fangs404@fangs404-desktop:~$
    Not sure why.

  10. #940
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try this instead:
    Code:
    smbtree --user=fangs404
    Then, when it asks for your password, type the password of the computer you're trying to connect to (not your Ubuntu password).

    What OS is running on the computer you're attempting to connect to?

Page 94 of 137 FirstFirst ... 44849293949596104 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •