Page 92 of 137 FirstFirst ... 42829091929394102 ... LastLast
Results 911 to 920 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #911
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by nadip View Post
    My only problem is that I cannot make other admin group users see and edit files on a samba server share, from a winXP machine.
    You'll need to correctly configure a samba server. Please see the 1st link in my sig.

    Quote Originally Posted by KatmanHH View Post
    Welllllllll I aint quite outta the woods yet. I can access the drive fine but I tried to start moving some data over there and it says I don't have the permission to do that.

    I think it is only a tiny fix but not sure where to go. Could I have a pointer? Please?

    Thanks
    What NAS device do you have (make and model number)

  2. #912
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Its a 320 Gig Maxtor. Couldn't find a model number..... This seems to be the only discription on it (Maxtor Shared Storage II)....?

    Thanks
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  3. #913
    Join Date
    Dec 2007
    Location
    Estonia
    Beans
    44
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for the wonderful howto!

    With "user=myusername,password=mysambapassword" in/etc/fstab it works like a charm. However, having my credentials in /root/.smbcredentials does not work for me - although I'm on Hardy Heron and do have nounix option in /etc/fstab I still get:

    Code:
    vussvillem@vussvillem-desktop:~$ sudo mount -a
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    Curiously, if I have both "credentials=/root/.smbcredentials" and "password=mysambapassword" in /etc/fstab I get samba share mounted with this note :
    Code:
    vussvillem@vussvillem-desktop:~$ sudo mount -a
    
    mount.cifs warning - password specified twice
    So "credentials=/root/.smbcredentials" works only partly for me. Has anyone else had this problem and how to fix it?

    May it be related to the fact that I do have a domain in samba server as well? However, I've tried to have "username=WORKGROUP\myusername" in /root/.smbcredentials and I've added "domain=WORKGROUP" option to /etc/fstab without any success.

  4. #914
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by KatmanHH View Post
    Its a 320 Gig Maxtor. Couldn't find a model number..... This seems to be the only discription on it (Maxtor Shared Storage II)....?

    Thanks
    I could not find very much information on your device.

    What is your current fstab line?

    Quote Originally Posted by vussvillem View Post
    [snip]So "credentials=/root/.smbcredentials" works only partly for me. Has anyone else had this problem and how to fix it?

    May it be related to the fact that I do have a domain in samba server as well? However, I've tried to have "username=WORKGROUP\myusername" in /root/.smbcredentials and I've added "domain=WORKGROUP" option to /etc/fstab without any success.
    Double check to make sure that your /root/.smbcredentials file is formatted correctly. As indicated in the howto, you should NOT use a gui text editor to create the file, and it's VERY sensitive to spaces and line feeds. Make sure that there are NO spaces before or after the equal signs.

    As indicated by your error, you can use either smbcredentials or username/password options in your mount line, but you can't use both.

  5. #915
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    I could not find very much information on your device.

    What is your current fstab line?
    I'll check at work tomorrow. The drive is at the office. Thanks.
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  6. #916
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    my fstab line.


    # Mount our network drive
    //mss-willows/Public /media/Public cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77 0 0

    Is that mode=0777 right? Or does that not have anything to do with it?

    Thanks
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  7. #917
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Yes, the 0777 is correct. Try the nounix option like so:
    Code:
    //mss-willows/Public /media/Public cifs guest,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

  8. #918
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    OKAY...... That worked perfectly. Now if only I even had a clue what makes that make it work.

    Thanks a million by the way. That makes my life much easier now.=D>
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  9. #919
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by KatmanHH View Post
    OKAY...... That worked perfectly. Now if only I even had a clue what makes that make it work.

    Thanks a million by the way. That makes my life much easier now.=D>
    Disabling Unix file extensions makes cross platform permissions issues go away

  10. #920
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    OH-Kay. I got it now. Thanks again
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

Page 92 of 137 FirstFirst ... 42829091929394102 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •