Page 91 of 137 FirstFirst ... 41818990919293101 ... LastLast
Results 901 to 910 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #901

    Re: Mount samba shares with utf8 encoding using cifs

    Hi, i had the same problems and i fixed like this.

    this is my sftab file

    Code:
    //23.11.74.90/Media 	/mnt/media 	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    //23.11.74.90/Document	/mnt/document 	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    //23.11.74.90/Files	/mnt/files	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    I hope this help you

  2. #902
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by pajarraco View Post
    Hi, i had the same problems and i fixed like this.

    this is my sftab file

    Code:
    //23.11.74.90/Media 	/mnt/media 	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    //23.11.74.90/Document	/mnt/document 	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    //23.11.74.90/Files	/mnt/files	smbfs iocharset=utf8,username=MyUsername,password=MyPassword,uid=1000,gid=1000,dir_mode=0777,file_mode=0777 0 0
    I hope this help you



    Thank you so much (to everyone). This, finally worked for me.

    NOTE: Even though in 9.04, the problem loggin out is present and you have to umount your cifs units before shutdown, otherwise, a pretty freeze is shown.

    Best regards!
    Pepe

  3. #903
    Join Date
    Oct 2004
    Location
    London
    Beans
    43
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    @dmizer - Thanks for the guide, I was able to resolve issues I was having with my EeePC seeing my Samba shares correctly by following the pre-work steps.

  4. #904
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Grimmy View Post
    @dmizer - Thanks for the guide, I was able to resolve issues I was having with my EeePC seeing my Samba shares correctly by following the pre-work steps.
    My pleasure.

    I also posted a condensed version of the fix in that thread.

  5. #905
    Join Date
    Apr 2009
    Location
    Sydney, Australia
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Hi, I'm a new Ubuntu user, and dmizer, the "nounix" option worked for me. What does that option actually do?
    Thanks for the guide..

  6. #906
    Join Date
    Jul 2008
    Beans
    62

    Re: Mount samba shares with utf8 encoding using cifs

    Thank you for this post it was very helpful to me. Something that might be helpful to other is that I had to unmount the share, and remount the share in order for the change to take effect. Using mount -a didn't make a difference in the effectivness of the iocharset variable. A umount, then a mount works perfect. Thanks again.

  7. #907
    Join Date
    Mar 2009
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer:
    This is my first post on this forum.
    I am at the end of my first week learning ubuntu-
    I am trying to set up a samba pdc and I might say the progress is noticeable.
    My only problem is that I cannot make other admin group users see and edit files on a samba server share, from a winXP machine. Only the root account has been allowed to do that. It is of course a clear case of permissions. How can I change the permissions on those shares so that the files can be accessed by other people than myself (root)?
    I have tried to apply your remedy but Iºm a afraid that is too difficult for me at this stage. Basically I have found my UID and GID but I donºt know how to insert them in the fstab file. What do you mean by netbiosname/sharename and media/sharename? And how exactly should I edit the fstab file?
    Please help me. My PDC is almost up and running.
    Many thanks in advance.


    Quote:
    Files owned by root. If you can view but not change, delete, or add new files to your Samba share, try this fix:

    1) Find your uid and gid (normally both are 1000, but double check):
    Code:

    cat /etc/passwd | grep ubuntu-username

    The output will look something like this (my uid and gid are marked in red):
    Code:

    $ cat /etc/passwd | grep dmizer
    dmizer:1000:1000:dmizer,,,:/home/dmizer:/bin/bash

    2) Add gid, uid, and nounix options to your fstab line like so:
    Code:

    //netbiosname/sharename /media/sharename cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,n ounix,file_mode=0777,dir_mode=0777 0 0 (end of quote)

  8. #908
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Thank you immensely. After fighting a network storage drive for a day the first post on this thread hooked me right up perfect. Its there through a reboot and everything. SHWEEEEEEEEEET!
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  9. #909
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Welllllllll I aint quite outta the woods yet. I can access the drive fine but I tried to start moving some data over there and it says I don't have the permission to do that.

    I think it is only a tiny fix but not sure where to go. Could I have a pointer? Please?

    Thanks
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

  10. #910
    Join Date
    May 2008
    Location
    Northern California
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Is this a problem with my Ubuntu box or with the network storage drive?
    resU noreH ydraH
    resU epolakcaJ ytnuaJ a woN :tidE
    40.01 dicuL woN :niaga tidE

Page 91 of 137 FirstFirst ... 41818990919293101 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •