Page 90 of 137 FirstFirst ... 40808889909192100 ... LastLast
Results 891 to 900 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #891
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Thank you so much!!

    I have now my TERA (1 TB ) in "places"....

    But I couldn`t resolve the encoding issue yet!

    I've tried:

    iocharset=iso8859-1
    iocharset=iso8859-15
    nls=iso8859-1 (and 15)
    nls=utf8

    but no luck. As I said before, TERA is NTFS formatted, but is installed into a 8.10 Ubuntu.

    Any help???

    Thanks again!

    Quote Originally Posted by dmizer View Post
    If you want the share to appear in places, you have to mount it in /media rather than /mnt like so:

    Code:
    //192.168.1.13/tera        /media/tera    cifs              guest,rw,iocharset=iso8859-7,file_mode=0777,dir_mode=0777 0 0
    Let me know if that does what you need.

  2. #892
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    ^_Pepe_^, as far as I can see, you have three options:
    utf8, iso8859-1, and iso8859-15

    You could also try:
    iocharset=nls_iso8859-15
    iocharset=nls_iso8859-1
    iocharset=cp1252

    I really struggle to find information about character sets and codepage on the internet. It seems that very few people are knowledgeable about the subject. It would also be extremely helpful to know exactly what characterset you're TERA drive is using.

  3. #893
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Hi!

    Thank you for our time and help.

    I think that clearly iso8859-15 is my issue, because it has á,é,í,ó,ú,ñ and € (€ symbols is the difference between -1 and -15 versions).

    After this, I have guessed that iocharset=iso8859-15 has been replaced by nls=iso8859-15, but no luck yet.

    I have to found out the solution to "CIFS server not responding" hang on logout. Fortunately I found solution on this same forum (with a workaround script).

    But the charset is still not fine.



    How can I find my TERA disk charset? This HDD was previously mounted and installed into XP machine, but I installed (without changes) in my Ubuntu machine (virus free)...

    This is my recent fstab line (see very useful _netdev command, than wait for network to connect for mounting the unit):
    Code:
    //192.168.1.13/tera         /media/TERA  cifs _netdev,auto,exec,user,rw,nls=iso8859-15 0 0
    Thanks!!!!!!!!!!!!!!


    Quote Originally Posted by dmizer View Post
    ^_Pepe_^, as far as I can see, you have three options:
    utf8, iso8859-1, and iso8859-15

    You could also try:
    iocharset=nls_iso8859-15
    iocharset=nls_iso8859-1
    iocharset=cp1252

    I really struggle to find information about character sets and codepage on the internet. It seems that very few people are knowledgeable about the subject. It would also be extremely helpful to know exactly what characterset you're TERA drive is using.
    Last edited by ^_Pepe_^; April 13th, 2009 at 10:36 PM.

  4. #894
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    More information to this.

    I have VNC connected to my 8.10 machine, where I have physically connected TERA unit, and tried to mount "My Documents" (NTFS, of course) folder from my Windows machine, and I there was strange characters on ñ, á...either using utf8 and iso8859-15.

    Regards
    ^_Pepe_^

  5. #895
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ^_Pepe_^ View Post
    More information to this.

    I have VNC connected to my 8.10 machine, where I have physically connected TERA unit, and tried to mount "My Documents" (NTFS, of course) folder from my Windows machine, and I there was strange characters on ñ, á...either using utf8 and iso8859-15.

    Regards
    ^_Pepe_^
    Sounds like your file names got corrupted somehow. I've had this happen before and the only fix was to rename all the broken file names.

  6. #896
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Sounds like your file names got corrupted somehow. I've had this happen before and the only fix was to rename all the broken file names.
    I have tried it this morning, but I could. If I press F2 to change the name, system throws an error saying something about codification.

    I'll keep on searching....

    Rgds

  7. #897
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ^_Pepe_^ View Post
    I have tried it this morning, but I could. If I press F2 to change the name, system throws an error saying something about codification.

    I'll keep on searching....

    Rgds
    You'll have to fix the file names directly rather than over samba.

  8. #898
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ^_Pepe_^ View Post
    This is my recent fstab line (see very useful _netdev command, than wait for network to connect for mounting the unit):
    Code:
    //192.168.1.13/tera         /media/TERA  cifs _netdev,auto,exec,user,rw,nls=iso8859-15 0 0
    That is in the troubleshooting section of my howto

    Something that might be causing you trouble is that you're using the nls=iso8859-15 option. This is not a valid cifs option. If you think you need nls, you should try mounting with this option:
    iocharset=nls_iso8859-15

    I also ran across this earlier: http://www.nslu2-linux.org/wiki/HowT...FATFileSystems

    With that in mind, you might try this:
    Code:
    //192.168.1.13/tera         /media/TERA  cifs _netdev,auto,exec,user,rw,iocharset=cp850 0 0

  9. #899
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Ok!

    I don't give up, but I didn't improve a bit.

    Let's sum up:

    1. If I type smb://mylinuxmachineIP/tera, I can reach all my tera files, with perfect codification, both nautilus and console.

    2. Unfortunately, this is not enough, because this files can't be reachables from applications (Amarok, Picasa, AFAIK...) unless you mount your unit in /mnt/TERA...

    3. If I use my mount in fstab, I can see my TERA disk (ntfs formatted) perfectly but, with wrong codification. ñ,á,é,í,ó,ú are substituted by ?

    4. But...(this is incredible...) if I open Picasa 3.0, and I "add folder" from my TERA disk... I can see correct names. Only nautilus and ls command (in console) are wrong.

    Ok, I can survive with this, but I'm not giving up.

    BTW, Does anybody know how to create a direct link to a "smb://..." location on the desktop. Furthermore, is there any applet for the bars to mount net shares as there're for local mounts?

    To be honest, I have spent 3 procrastination days to customize my 9.04 RC...

    Thanks to everyone
    Pepe

  10. #900
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ^_Pepe_^ View Post
    BTW, Does anybody know how to create a direct link to a "smb://..." location on the desktop. Furthermore, is there any applet for the bars to mount net shares as there're for local mounts?
    Thanks to everyone
    Pepe
    Glubs...

    Autoreply. Right button, new luncher, and so on...

    Sorry!

    Regards

Page 90 of 137 FirstFirst ... 40808889909192100 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •