Page 87 of 137 FirstFirst ... 3777858687888997 ... LastLast
Results 861 to 870 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #861
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    If you've enabled netbios name resolution as outlined in my howto, you should also try this:

    Code:
    //netdrive/PUBLIC\40DISK\401 /media/landisk cifs credentials=/root/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777 0 0

  2. #862
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    Hi Dmizer,

    I tried, but without success

    It seems there are more people on the net who have this problem can't solve it. I've been looking for mount error 6 cifs specific.

    The strange thing is, I can access the samba drive via places-network-netdrive but it didnt ask for a login so I don't have any rights. This is the reason why I want to perma mount this drive with password access.

    I will try by removing credentials to add it but that will get me back to the beginning of why i wanted to have this perma mount....

    >> nope didn't work, in the end i still get the mount error 6.

  3. #863
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Obsolete Zero View Post
    Hi Dmizer,

    I tried, but without success

    It seems there are more people on the net who have this problem can't solve it. I've been looking for mount error 6 cifs specific.

    The strange thing is, I can access the samba drive via places-network-netdrive but it didnt ask for a login so I don't have any rights. This is the reason why I want to perma mount this drive with password access.

    I will try by removing credentials to add it but that will get me back to the beginning of why i wanted to have this perma mount....

    >> nope didn't work, in the end i still get the mount error 6.
    If you can access the drive fine without credentials, then your NAS drive is configured to share files without password protection. This is why you're getting the error 6. Ubuntu is attempting to send a username and password, but your NAS is not responding.

    Does this work?
    Code:
    //netdrive/PUBLIC\40DISK\401 /media/landisk cifs guest,rw,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777 0 0

  4. #864
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    SOLUTION FOUND!!!!!!!!!!!!!!!!!!

    sorry, i'm extremely happy


    ok problem is i found out after more investigations on the interwebs is that for spaces in sharename you need to use \040 not \40

    so, it works now

    thanks for all the help Dmizer! I'm not sure if your tutorial has \40 or \040 but it is the latter that needs to be used!

  5. #865
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Obsolete Zero View Post
    SOLUTION FOUND!!!!!!!!!!!!!!!!!!

    sorry, i'm extremely happy


    ok problem is i found out after more investigations on the interwebs is that for spaces in sharename you need to use \040 not \40

    so, it works now

    thanks for all the help Dmizer! I'm not sure if your tutorial has \40 or \040 but it is the latter that needs to be used!
    Heh, yup ... tutorial says \040

    Glad you're working!

  6. #866
    Join Date
    Jul 2008
    Beans
    68
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Talking Re: Mount samba shares with utf8 encoding using cifs

    Thanks to the OP! This worked flawlessly on the first try. I just skipped the netbios part and substituted the IP address for my own needs. Now I have my shared media from my Vista box mounted at bootup. Awesome.


  7. #867
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Beans
    108
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Hi, following your guide got me up and running, however the shares do not mount at boot, rather I have to run 'sudo mount -a' in terminal to get the shares to appear (after which they work flawlessly).

    Here is my fstab:
    Code:
    //familydesktop/c /media/familyc cifs iocharset=utf8,credentials=/home/family/.smbcredentials,uid=1000,_netdev 0 0
    //familydesktop/media /media/media cifs iocharset=utf8,credentials=/home/family/.smbcredentials,uid=1000,_netdev 0 0
    //familydesktop/music /media/music cifs iocharset=utf8,credentials=/home/family/.smbcredentials,uid=1000,_netdev 0 0
    Any help would be much appreciated as you can see I added '_netdev' in the hope it would fix my problem but alas, it wasn't the case.
    ThinkPad X201 - i5-520M - 8GB DDR3 RAM - Intel HD Graphics - 1GB GeForce 560 Ti eGPU - Xubuntu 14.04/Windows 8 Pro
    Gaming PC - i5-4670 - 16GB DDR3 RAM - 3GB Radeon R9 280X - Windows 8 Pro

  8. #868
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try editing /etc/rc.local and add "mount -a" to the file like so:

    Code:
    sudo nano /etc/rc.local
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    mount -a
    exit 0

  9. #869
    Join Date
    Jun 2007
    Location
    Sydney, Australia
    Beans
    108
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    I tried that.. on reboot, still nothing mounts automatically.

    Any other ideas?
    ThinkPad X201 - i5-520M - 8GB DDR3 RAM - Intel HD Graphics - 1GB GeForce 560 Ti eGPU - Xubuntu 14.04/Windows 8 Pro
    Gaming PC - i5-4670 - 16GB DDR3 RAM - 3GB Radeon R9 280X - Windows 8 Pro

  10. #870
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    What Ubuntu release are you using (Hardy, Ibex ...)?

    Please post the contents of /etc/network/interfaces

Page 87 of 137 FirstFirst ... 3777858687888997 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •