Page 86 of 137 FirstFirst ... 3676848586878896136 ... LastLast
Results 851 to 860 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #851
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    A very common cause of this error is simply not having smbfs installed. Please make sure smbfs is installed by running the following command:
    Code:
    sudo aptitude install smbfs
    If that does not solve your problem, I suggest that you try removing the illegal "é" character from the name of your share as this can cause the error 13 as well.

  2. #852
    Join Date
    Jun 2008
    Location
    France
    Beans
    34
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer,

    I had smbfs installed, but changing my sharename to videos unfortunately didn't make the trick.

    I am now using NFS for this anyway, but I'd like to know the root cause for knowledge's sake.

    Thanks!

  3. #853
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by eti.que View Post
    Hi dmizer,

    I had smbfs installed, but changing my sharename to videos unfortunately didn't make the trick.

    I am now using NFS for this anyway, but I'd like to know the root cause for knowledge's sake.

    Thanks!
    You'll have better luck with NFS anyway.

    Have you enabled the root account on the client, but not the server? Or, enabled root on both? This could cause problems with uid and gid. There is a fix for this in the troubleshooting section.

  4. #854
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    hey dmizer,

    As it seems you are the samba guru on the ubuntuforums

    I have a question.

    I've managed to get most things working, when i check the smbtree everything seems to be there however I'm getting this mount error 6, no such device or directory.

    My question is I have this folder on my netdrive called PUBLIC DISK 1 i want to access/ perm mount. i use %20 for the whitespaces in fstab but i'm not sure if this is supported and what I should do to make it work. I think this is the reason for the error.......

    added the smbtree.

    What are your thoughts?

    tnx in advance!
    Attached Images Attached Images

  5. #855
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    In my howto under "Troubleshooting" there is a section on "Space in path name". That should fix you up

  6. #856
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    DOH!!! i can't belief i didnt see that one

    many thanks!!!!!

    just tried, still no luck it does add "try with upper case share name" but result is still mount error 6

    Well I advanced one step

  7. #857
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    What's your current /etc/fstab mount line?

  8. #858
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    my mount line is:

    //192.168.149/PUBLIC\40DISK\401 cifs credentials=/root/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777 0 0

    i use the ip since i gave my network drive a fixed IP.

  9. #859
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    You forgot to make a mount point.

    In order to make a permanent mount, you need an empty folder where Ubuntu can cache the landisk files. In my howto, I suggest creating an empty folder in /media. For example:
    Code:
    sudo mkdir /media/landisk
    Then your fstab line would look like this:
    Code:
    //192.168.149/PUBLIC\40DISK\401 /media/landisk cifs credentials=/root/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777 0 0

  10. #860
    Join Date
    Jul 2008
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    eermmm that would be my bad since i forgot to add that to my line of code. I was at the office writing this. I did make a folder to mount it to called netdrive.

    I made a landisk in media after your post however, and still i get the same error. I was away for the weekend so i couldn't work on it. I'll let you know if I make any progress this week!

Page 86 of 137 FirstFirst ... 3676848586878896136 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •