Page 8 of 137 FirstFirst ... 6789101858108 ... LastLast
Results 71 to 80 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #71
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by wilberfan View Post
    I just noticed that something has added three lines to the end of my smb.conf file:
    remove them, or comment them out and test again. (don't forget to restart your samba server after you've made changes to smb.conf
    Is there something in Edgy that does that??
    i don't know ... but i can test it tonight after i get home from work. did you dist-upgrade from dapper?

  2. #72
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    OK. I decided to be a little more methodical about this!

    Thinking perhaps that I had tweaked something that shouldn't be tweaked, yesterday morning I did a clean reinstall of Edgy. I wrote down each step to keep track of what I did and the result.

    Here's what I've learned so far:

    smbtree would only give 'clean' results (ie, no timeout errors) if I had NO OPENDNS IP ADDRESSES anywhere! (not in the router, nor in the DNS tab of Network Settings)

    I was able to get a clean smbtree with Static (not DHCP) IP settings and the router ip address (192.168.0.1) in the Networking control panel.

    My problem now is when I try and do a manual mount, I'm getting this:

    amdsignin@AMD64:~$ sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,iocharset=utf8,f ile_mode=0777,dir_mode=0777
    mount: wrong fs type, bad option, bad superblock on //DELL-Ubuntu/DellFiles,
    missing codepage or other error

    In some cases useful info is found in syslog - try
    dmesg | tail or so
    I hadn't seen that error on my previous attempts (pre- clean install), and I'm a little baffled at what it's telling me...
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  3. #73
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by wilberfan View Post
    My problem now is when I try and do a manual mount, I'm getting this:

    amdsignin@AMD64:~$ sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,iocharset=utf8,f ile_mode=0777,dir_mode=0777
    mount: wrong fs type, bad option, bad superblock on //DELL-Ubuntu/DellFiles,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    I hadn't seen that error on my previous attempts (pre- clean install), and I'm a little baffled at what it's telling me...
    what did dmesg | tail say? also, try the mount command without the utf8 option:
    Code:
    sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,file_mode=0777,dir_mode=0777
    also just noticed, there was a space after the "f" in file_mode=0777 ... that might have caused your problem.

    edit:
    i did a bit more reading over at opendns and fount a possible solution which might allow you to use your opendns settings.

    try using open dns addresses and use this line for your mount command:
    Code:
    sudo mount -t cifs //DELL-Ubuntu./DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,file_mode=0777,dir_mode=0777
    note the "." after DELL-Ubuntu. this may or may not work, but that's the solution that opendns gives for this problem.
    Last edited by dmizer; November 14th, 2006 at 12:21 AM.

  4. #74
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    I appreciate your ongoing research! Here's what happened when I tried again tonight:

    me@AMD64:~$ sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,file_mode=0777,d ir_mode=0777
    mount: wrong fs type, bad option, bad superblock on //DELL-Ubuntu/DellFiles,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    me@AMD64:~$ dmesg | tail
    [17179599.816000] NET: Registered protocol family 31
    [17179599.816000] Bluetooth: HCI device and connection manager initialized
    [17179599.816000] Bluetooth: HCI socket layer initialized
    [17179599.824000] Bluetooth: L2CAP ver 2.8
    [17179599.824000] Bluetooth: L2CAP socket layer initialized
    [17179599.828000] Bluetooth: RFCOMM socket layer initialized
    [17179599.828000] Bluetooth: RFCOMM TTY layer initialized
    [17179599.828000] Bluetooth: RFCOMM ver 1.7
    [17180613.276000] CIFS VFS: cifs_mount failed w/return code = -22
    [17180768.972000] CIFS VFS: cifs_mount failed w/return code = -22
    (Note: The space after the d in "dir_mode=" was NOT entered into the terminal--that's some artifact of this posting procedure...)

    I'll try your opendns workaround AFTER I get at least ONE clean connection from one machine to the other!
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  5. #75
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i vaguely recall having this exact same problem.

    what happens when you do this:
    Code:
    sudo aptitude install smbfs

  6. #76
    Join Date
    Mar 2006
    Location
    Quaoar
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    I've tried this guide and everything seemed to be OK until the end, when I did the sudo mount -a, and I got:

    Code:
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    Now, my windows share doesn't need a password, because I've always accessed it without one, is there something I'm missing?

    The line I added to the fstab, looks like this:

    Code:
    //DIMENSIONE310/C$ /media/here cifs guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    and my smbtree looks like this:

    Code:
    HERE
            \\UBUNTU                        ubuntu server (Samba, Ubuntu)
                    \\UBUNTU\ADMIN$                 IPC Service (ubuntu server (Samba, Ubuntu))
                    \\UBUNTU\IPC$                   IPC Service (ubuntu server (Samba, Ubuntu))
                    \\UBUNTU\linux          
                    \\UBUNTU\hdb1           
                    \\UBUNTU\print$                 Printer Drivers
            \\DIMENSIONE310  
                    \\DIMENSIONE310\C$              Default share
                    \\DIMENSIONE310\ADMIN$          Remote Admin
                    \\DIMENSIONE310\x       
                    \\DIMENSIONE310\DeskJet-        \\UBUNTU\DeskJet-610CL
                    \\DIMENSIONE310\My Music       
                    \\DIMENSIONE310\print$          Printer Drivers
                    \\DIMENSIONE310\SharedDocs     
                    \\DIMENSIONE310\IPC$            Remote IPC
                    \\DIMENSIONE310\My Documents
    (I'm not sure if this is relevant or not, but I can browse my shares with firefox with no problem.)

  7. #77
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Rebeca View Post
    The line I added to the fstab, looks like this:

    Code:
    //DIMENSIONE310/C$ /media/here cifs guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    and my smbtree looks like this:

    Code:
    HERE
            \\UBUNTU                        ubuntu server (Samba, Ubuntu)
                    \\UBUNTU\ADMIN$                 IPC Service (ubuntu server (Samba, Ubuntu))
                    \\UBUNTU\IPC$                   IPC Service (ubuntu server (Samba, Ubuntu))
                    \\UBUNTU\linux          
                    \\UBUNTU\hdb1           
                    \\UBUNTU\print$                 Printer Drivers
            \\DIMENSIONE310  
                    \\DIMENSIONE310\C$              Default share
                    \\DIMENSIONE310\ADMIN$          Remote Admin
                    \\DIMENSIONE310\x       
                    \\DIMENSIONE310\DeskJet-        \\UBUNTU\DeskJet-610CL
                    \\DIMENSIONE310\My Music       
                    \\DIMENSIONE310\print$          Printer Drivers
                    \\DIMENSIONE310\SharedDocs     
                    \\DIMENSIONE310\IPC$            Remote IPC
                    \\DIMENSIONE310\My Documents
    (I'm not sure if this is relevant or not, but I can browse my shares with firefox with no problem.)
    okay ... looks like you're trying to mount a device (C$) rather than a share. it should work if you mount x, My Music, SharedDocs, or My Documents.

    to mount a share with a space in the name use a reverse slash in front of the space like so:
    Code:
    //DIMENSIONE310/My\ Music /media/here cifs guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

  8. #78
    Join Date
    Mar 2006
    Location
    Quaoar
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    That's right. Thank you.

    However, the reverse slash didn't do it for me. fstab doesn't seem to accept any spaces, so I had to use a 040 instead of the space:

    Code:
    //DIMENSIONE310/My\040Music /media/here cifs guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    This was a good, simple guide. Thanks again.

  9. #79
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    i vaguely recall having this exact same problem.

    what happens when you do this:
    Code:
    sudo aptitude install smbfs
    me@AMD64:~$ sudo aptitude install smbfs
    Password:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Building tag database... Done
    The following NEW packages will be installed:
    smbfs
    0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 385kB of archives. After unpacking 922kB will be used.
    Writing extended state information... Done
    Get:1 http://us.archive.ubuntu.com edgy/main smbfs 3.0.22-1ubuntu4 [385kB]
    Fetched 385kB in 1s (228kB/s)
    Selecting previously deselected package smbfs.
    (Reading database ... 91493 files and directories currently installed.)
    Unpacking smbfs (from .../smbfs_3.0.22-1ubuntu4_i386.deb) ...
    Setting up smbfs (3.0.22-1ubuntu4) ...
    Is this what I'd have gotten whether or not I'd install smbfs previously?
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  10. #80
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    Why on earth would I be getting THIS now?!

    me@AMD64:~$ sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/dellshare -o user=dellsignin,password=dellpswd,file_mode=0777,d ir_mode=0777
    mount error: could not find target server. TCP name DELL-Ubuntu/DellFiles not found
    No ip address specified and hostname not found
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

Page 8 of 137 FirstFirst ... 6789101858108 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •