Page 73 of 137 FirstFirst ... 2363717273747583123 ... LastLast
Results 721 to 730 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #721
    Join Date
    Oct 2008
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    scoopy and DarkDead, please post the output of:
    Code:
    ls -n /media/sharename
    -rwxrwxrwx 1 0 0 458840 2008-06-04 18:30 bluesoleil.exe
    drwxrwxrwx 1 0 0 0 2008-07-23 19:51 Bluetooth
    drwxrwxrwx 1 0 0 0 2008-04-19 08:25 Cashbook Data
    -rwxrwxrwx 1 0 0 0 2007-12-03 18:51 Default.rdp
    -rwxrwxrwx 1 0 0 75 2007-11-29 18:48 desktop.ini
    drwxrwxrwx 1 0 0 0 2008-09-21 14:58 Downloads
    drwxrwxrwx 1 0 0 0 2008-06-11 17:44 Duty Rosters
    drwxrwxrwx 1 0 0 0 2008-10-12 18:46 Ella's Stuff
    drwxrwxrwx 1 0 0 0 2008-09-24 07:34 Hana's Stuff
    drwxrwxrwx 1 0 0 0 2008-08-14 18:24 ~Jodie's Stuff
    drwxrwxrwx 1 0 0 0 2008-10-27 19:55 luketest
    drwxrwxrwx 1 0 0 0 2007-12-01 16:23 My Google Gadgets
    drwxrwxrwx 1 0 0 0 2007-11-29 18:48 My Music
    drwxrwxrwx 1 0 0 0 2008-10-25 17:15 My Pictures
    drwxrwxrwx 1 0 0 0 2007-12-01 16:47 My Videos
    drwxrwxrwx 1 0 0 0 2007-12-03 19:38 software
    drwxrwxrwx 1 0 0 0 2007-12-01 17:45 Vision Design
    drwxrwxrwx 1 0 0 0 2007-12-01 19:21 web design

  2. #722
    Join Date
    Nov 2007
    Location
    USA-ish
    Beans
    206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    I'm having a similar problems to the others.

    I've gotten my shared network hard drive to mount after using tips from this thread, but it's owned by root. I've done a recursive sudo chown and sudo chmod to everything, but if I download a file and save it to the share, it won't save due to insufficient permissions.

    I've even unmounted the shared and chown/chmoded the mount point, to no avail.
    Desktop: Quantal on Core2 Duo E8500/Asus P5Q
    Laptop: Precise on S76 Pangolin

  3. #723
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Cammy View Post
    I'm having a similar problems to the others.

    I've gotten my shared network hard drive to mount after using tips from this thread, but it's owned by root. I've done a recursive sudo chown and sudo chmod to everything, but if I download a file and save it to the share, it won't save due to insufficient permissions.

    I've even unmounted the shared and chown/chmoded the mount point, to no avail.
    Any of you with this problem, be sure to check the permissions on the Windows computer. If you are positive that the Windows share permissions are correct, please try adding your Ubuntu user account (same user name and password) to your Windows computer, make sure the Ubuntu user is added to the Windows share, and retest by mounting with a credentials file in /etc/fstab. This should solve the problem.

    In the mean time, I am slowly going back through this thread, because I've solved this before ... I just don't remember how. I would be grateful to anyone who could help with that search.
    Last edited by dmizer; November 3rd, 2008 at 07:40 AM.

  4. #724
    Join Date
    Nov 2007
    Location
    USA-ish
    Beans
    206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    In my case, there is no Windows computer. I have an internal hard drive mounted in a USB 2.0 enclosure and connected to a Linysys nslu2 Network Storage link. This is connected via ethernet to my router.

    I have the same username on the Linksys device that I have on my local machine, and that username has R/W permissions on the network drive. In fact I'm a member of the admin group on the network drive.

    It's the same setup I had when running Feisty, except I had to change my fstab to mount the drive in Hardy because things changed. Here's what my fstab entry for the drive looks like:

    Code:
    //192.168.0.77/music /media/music/ cifs credentials=/root/.credentials/credentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    The credentials file just has:

    Code:
    username=myusername
    password=mypassword
    The drive mounts and I have access, it just seems that anything I download to the drive (or copy to it) ends up owned by "root", assuming the download even works.
    Desktop: Quantal on Core2 Duo E8500/Asus P5Q
    Laptop: Precise on S76 Pangolin

  5. #725
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    @scoopy and DarkDead
    Please try this solution:
    Code:
    //studycom/j/My\040Documents    /media/JodieFiles/       cifs    user,guest,uid=1000,gid=1000,rw,iocharset=utf8,nounix,nobrl,file_mode=0777,dir_mode=0777 0 0
    @Cammy
    Finally found what I was looking for here. Please try this:
    Code:
    //192.168.0.77/music /media/music/ cifs credentials=/root/.credentials/credentials,rw,nounix,iocharset=utf8,uid=1000,gid=1000,file_mode=0777,dir_mode=0777 0 0
    There seems to be a difference in how CIFS acts when presented with a guest account rather than an authenticated login.
    Last edited by dmizer; November 4th, 2008 at 04:53 AM.

  6. #726
    Join Date
    Nov 2007
    Location
    USA-ish
    Beans
    206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    YES! You are the bestest ever! Thank you very much!

    It works properly now.
    Desktop: Quantal on Core2 Duo E8500/Asus P5Q
    Laptop: Precise on S76 Pangolin

  7. #727
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Cammy View Post
    YES! You are the bestest ever! Thank you very much!

    It works properly now.
    Fantastic! Sorry that took a while. I'd forgotten how to fix this. I will add this to the troubleshooting section later this evening.

    Glad you're working!

  8. #728
    Join Date
    Oct 2008
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    All good!!! You Rock!

  9. #729
    Join Date
    Aug 2006
    Location
    Portugal
    Beans
    45
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: Mount samba shares with utf8 encoding using cifs

    Thank you dmizer! It seems to work.

    There's only one strange thing. With your fix my account has read and write privileges over all files in the share (and it's confirmed it has). However I still can't rename or delete those files, it's like I don't have the privileges. But this only happens in the root directory in subsequent directories like /media/sharename/something everything runs smoothly.

    I believe this is probably some problem with Windows file sharing but I couldn't find anything wrong with it. Has anyone experienced something similar?

  10. #730
    Join Date
    Nov 2008
    Location
    England
    Beans
    40
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Hey All,

    had a recommendation that this was the place to go for cifs problems, so here I am.

    I have looked all over the place and I am slowly getting there but I am wondering whether you genii can help that last little bit. (Yes I am hoping flattery will get me everywhere )

    So, essentially I can browse, add, delete and move files to the share but what I cant do is open an existing file, edit it and save it directly back to the mounted share.

    The error message from gedit was "Not a Directory".

    I found out thanks to another post on here that adding the nounix switch to the fstab entries meant that the original problems I was having dissapeared, and this works for 90% of the problem but I still get it in Komodo Edit (Excellent Programming IDE)

    The Error Message reads:

    There was a problem saving project "project.kpf": [Errno 20] Not a Directory:u'/media/files/project.kpf'
    The bit that interested me about that was the preceding "u" before the directory string.

    Thanks in advance! Any thoughts anyone?

Page 73 of 137 FirstFirst ... 2363717273747583123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •