Page 71 of 137 FirstFirst ... 2161697071727381121 ... LastLast
Results 701 to 710 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #701
    Join Date
    May 2008
    Location
    near Milan, Italy
    Beans
    35
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    I used this guide to solve some issues (openoffice and shutdown/reboot), those were very annoying problems.

    I was saying that probably mount -a is done before the network is available (provided by knetworkmanager)

  2. #702
    Join Date
    Oct 2008
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Hey thanks for this.

    I was directed to this thread as I was having issues with saving OpenOffice files to a windows xp home share.

    Got a mount working and it all seems to be running pretty well . . . however, sometimes when i save files to the mounted drive it's read only (little padlock in icon view in nautalis), sometimes this will happen from OpenOffice when I'm doing a save as. sometimes it won't.

    This is my fstab code:
    Code:
    //studycom/j/My\040Documents    /media/JodieFiles/       cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

  3. #703
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by scoopy View Post
    Got a mount working and it all seems to be running pretty well . . . however, sometimes when i save files to the mounted drive it's read only (little padlock in icon view in nautalis), sometimes this will happen from OpenOffice when I'm doing a save as. sometimes it won't.
    Try adding the nounix and nobrl options like so:
    Code:
    //studycom/j/My\040Documents    /media/JodieFiles/       cifs    guest,rw,iocharset=utf8,nounix,nobrl,file_mode=0777,dir_mode=0777 0 0
    Please let me know if that works

  4. #704
    Join Date
    Oct 2008
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try adding the nounix and nobrl options like so:

    Please let me know if that works
    Hey, thanks for getting back so quick! what a legend!

    Tried what you suggested but no change - new files are read only. I can delete them though.

    Thanks again!

  5. #705
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by scoopy View Post
    Hey, thanks for getting back so quick! what a legend!

    Tried what you suggested but no change - new files are read only. I can delete them though.

    Thanks again!
    No problem!

    Did you remount the share (or reboot) after making the change? If not, you should. The changes will not take effect until you remount.

  6. #706
    Join Date
    Oct 2008
    Location
    New Zealand
    Beans
    35
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Yes I did reboot

  7. #707
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Yeesh, OK ... I will take a look at this when I get home from work and have a bit more time to look for possible solutions.

  8. #708
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by scoopy View Post
    Yes I did reboot
    scoopy,

    I have tested multiple configurations in my sandbox, but I have not been able to duplicate your problem.

    Please try this line:
    Code:
    //studycom/j/My\040Documents    /media/JodieFiles/       cifs    guest,user=windows-username,rw,iocharset=utf8,nounix,nobrl,file_mode=0777,dir_mode=0777 0 0
    Replace "windows-username" with the actual username on your Windows computer (eg. administrator).

    If that is not successful, please post the output of:
    Code:
    ls -l /media/JodieFiles
    Last edited by dmizer; October 29th, 2008 at 09:03 AM.

  9. #709
    Join Date
    Oct 2008
    Beans
    28

    Exclamation Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Are you attempting to mount a share on an active directory?
    Yes, I was able to access my home folder, but now I had to switch back to Vista as I couldn't access those AD folders

  10. #710
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Alexandre76 View Post
    Yes, I was able to access my home folder, but now I had to switch back to Vista as I couldn't access those AD folders
    Sorry, mounting AD folders is significantly more complex and outside the scope of this howto. It is possible, but it's a daunting chore, so I certainly sympathize with your need to return to Vista.

    If you feel brave and would like to try again in the future, here are two helpful links: http://anothersysadmin.wordpress.com...in-ubuntu-804/
    http://ubuntuforums.org/showthread.php?t=91510

Page 71 of 137 FirstFirst ... 2161697071727381121 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •