Page 68 of 137 FirstFirst ... 1858666768697078118 ... LastLast
Results 671 to 680 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #671
    Join Date
    Sep 2008
    Beans
    5

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks will use the code annotation instead of quote.

    okay did what you suggested, and i'm now halfway there. I can modify files on the 'fester' server yay!
    The other server 'blueslider' is being more stubborn. If i do a ls on the 2 servers i get a different results
    Code:
    tim@tim:/$ ls -lh /Share/Fester/
    total 2.0G
    drwxrwxrwx 1 tim root    0 2008-06-03 14:09 ADFS
    -rwxrw-rwx 1 tim root    0 2007-08-30 10:07 AUTOEXEC.BAT
    -rwxrwSrwx 1 tim root  219 2007-08-30 09:57 boot.ini
    -rwxrwSrwx 1 tim root    0 2007-08-30 10:07 CONFIG.SYS
    drwxrwxrwx 1 tim root    0 2008-09-19 10:22 data
    
    tim@tim:/$ ls -lh /Share/Blueslider/
    total 2.0G
    drwxrwxrwx 1 root root    0 2006-06-24 20:09 aaadeploy
    drwxrwxrwx 1 root root    0 2006-06-24 20:09 accton
    -rwxrwxrwx 1 root root   45 2006-06-20 15:16 AUTOEXEC.BAT
    ive condensced the results as all i wanted to show was the difference in permissions (Well i presume its permissions)

    Both machines are Windows Server 2003

    Just to illustrate here is what i did to test if the sharing was working
    Code:
    tim@tim:/$ sudo chmod 777 /Share/Blueslider/
    tim@tim:/$ sudo chmod 777 /Share/Fester/
    tim@tim:/$ sudo mount -a
    tim@tim:/$ touch /Share/Blueslider/new.txt
    touch: cannot touch `/Share/Blueslider/new.txt': Permission denied
    tim@tim:/$ touch /Share/Fester/new.txt
    tim@tim:/$ rm /Share/Fester/new.txt

  2. #672
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Okay, try this:

    Unmount both shares:
    Code:
    sudo umount /Share/Blueslider
    sudo umount /Share/Fester
    then, list the directories like so:
    Code:
    ls -l /Share

  3. #673
    Join Date
    Sep 2008
    Beans
    5

    Re: Mount samba shares with utf8 encoding using cifs

    I think we are progresssing..

    Code:
    tim@tim:/$ sudo umount /Share/Blueslider
    tim@tim:/$ sudo umount /Share/Fester/
    tim@tim:/$ ls -l /Share/
    total 8
    drwxrwxrwx 2 root root 4096 2008-09-22 10:43 Blueslider
    drwxrwxrwx 2 tim  root 4096 2008-09-22 10:50 Fester
    I then changed the ownership of the folder to tim
    Code:
    tim@tim:/$ sudo chown tim /Share/Blueslider/
    tim@tim:/$ ls -l /Share/
    total 8
    drwxrwxrwx 2 tim root 4096 2008-09-22 10:43 Blueslider
    drwxrwxrwx 2 tim root 4096 2008-09-22 10:50 Fester
    but alas i still do not have any write access to blueslider

    Code:
    tim@tim:/$ sudo mount -a
    tim@tim:/$ touch /Share/Fester/new.txt
    tim@tim:/$ rm  /Share/Fester/new.txt
    tim@tim:/$ touch Share/Blueslider/newfile.txt
    touch: cannot touch `Share/Blueslider/newfile.txt': Permission denied
    tim@tim:/$ ls -l /Share/
    total 0
    drwxrwxrwx 1 root root 0 2008-09-18 12:35 Blueslider
    drwxrwxrwx 1 root root 0 2008-09-22 14:55 Fester
    I see that the ownership of the share folders changes to root once they are mounted, i presume this is too stop some idiot(myself) from deleting them whilst mounted?

    i also checked the following

    Code:
    tim@tim:/$ ls -l /Share/Blueslider/
    total 2095945
    drwxrwxrwx 1 root root          0 2006-06-24 20:09 aaadeploy
    drwxrwxrwx 1 root root          0 2006-06-24 20:09 accton
    So i presume i'm missing something fairly simple?

  4. #674
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Do you use the same login for your Ubuntu machine as for either (or both) of your Windows machines?

  5. #675
    Join Date
    Sep 2008
    Beans
    5

    Re: Mount samba shares with utf8 encoding using cifs

    I use a windows domain username for the two servers and another (non windows/standalone )logon for the ubuntu machine

  6. #676
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Sorry for the delay in my reply. Been quite busy at work.

    Okay, you said that you have a different login for both Windows computers, so you should have a separate credentials file for each computer.
    Example:
    /home/tim/.smbcredentials_blueslider
    /home/tim/.smbcredentials_fester

    Where .smbcredentials_blueslider has the username and password for blueslider, and .smbcredentials_fester has the unsername and password for fester.

    Then your fstab lines will look like this:
    Code:
    //Blueslider/CDrive /Share/Blueslider cifs credentials=/home/tim/.smbcredentials_blueslider,nounix,noperm,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    //Fester/c$ /Share/Fester cifs credentials=/home/tim/.smbcredentials_fester,nounix,noperm,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Alternatively, you can add your Ubuntu username and password to both Windows computers.
    Last edited by dmizer; September 24th, 2008 at 04:48 AM.

  7. #677
    Join Date
    Sep 2008
    Location
    New Orleans, LA
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Mount samba shares with utf8 encoding using cifs

    I have followed your how to pretty much to the letter, even used the nounix option to try and eliminate the mount error 13: permission denied, but nothing works so far. I get the same error regardless of whether I try to use the wizard for adding a server under places, a sudo mount command or fstab.

    Please help.

    here is my fstab command:


    //CSI/Outdoors /mnt/csi cifs credentials=/home/mmavrice/.smbcredentials,rw,nounix,iocharset=utf8,file_mode =0777,dir_mode=0777 0 0

    here is what a verbose mount -a statement produces:

    mount: proc already mounted on /proc
    parsing options: rw,credentials=/home/mmavrice/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777

    Domain reily


    mount.cifs kernel mount options unc=//CSI\Outdoors,ip=129.81.248.12,user=mmavrice,domain =reily,pass=reily,ver=1,rw,credentials=/home/mmavrice/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777
    mount error 13 = Permission denied

  8. #678
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    mmavrice, there are several things (most of them not related to username password) which cause this error.

    First, make sure that cifs is actually installed:
    Code:
    sudo aptitude install smbfs
    It probably doesn't hurt anything, but it's also probably not a good idea to use a credentials file as well as the user/pass options.

    An IPtables configuration (firestarter) could cause this. Please post the output of:
    Code:
    sudo iptables -L
    Also post the contents of these two files:
    • /etc/hosts
    • /etc/nsswitch.conf


    Finally, post the output of:
    Code:
    smbtree

  9. #679
    Join Date
    Sep 2008
    Location
    New Orleans, LA
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Mount samba shares with utf8 encoding using cifs

    Alright, here we go...

    smbfs is properly installed, I ran aptitude just in case, didn't install anything new.

    I am unclear what you mean when you say i shouldn't use credentials as well as the user/pass options.

    Here is the output of iptables -l:
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Contents of /etc/hosts/:
    Code:
    127.0.0.1 localhost
    127.0.1.1 INTERN-REILY.reily
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Contents of /etc/nsswitch.conf:
    Code:
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files wins dns
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    I have attempted to run smbtree, but it hangs for a long time (I honestly don't know what that is a sign of). Here is the output:
    Code:
    Password: 
    WORKGROUP
    	\\XC-8C27EE      		106 Reily Center
    prs_mem_get: reading data of size 3738880676 would overrun buffer by 3738880426 bytes.
    		\\XC-8C27EE\XC-8C27EE-P    	106 Reily Center
    		\\XC-8C27EE\IPC$           	0ID4D129.81.248.116
    	\\SERVICECALLS   		Network Services Coordinator

  10. #680
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by mmavrice View Post
    I am unclear what you mean when you say i shouldn't use credentials as well as the user/pass options.
    This was my mistake. My apologies.

    Quote Originally Posted by mmavrice View Post
    Here is the output of iptables -l:
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    The above tells me that you don't have a firewall on your Ubuntu machine. But this:
    Quote Originally Posted by mmavrice View Post
    I have attempted to run smbtree, but it hangs for a long time (I honestly don't know what that is a sign of). Here is the output:
    Code:
    Password: 
    WORKGROUP
    	\\XC-8C27EE      		106 Reily Center
    prs_mem_get: reading data of size 3738880676 would overrun buffer by 3738880426 bytes.
    		\\XC-8C27EE\XC-8C27EE-P    	106 Reily Center
    		\\XC-8C27EE\IPC$           	0ID4D129.81.248.116
    	\\SERVICECALLS   		Network Services Coordinator
    Tells me that there is probably some sort of firewall in place between your Ubuntu computer and your Windows computer. Does your Windows machine have a firewall in place? Try disabling it and remount.

    Everything else looks okay. The problem appears to be that your Ubuntu computer doesn't know where your Windows computer is on the network, and this is usually a sign of a firewall interfering.

    Also, make sure that your Windows computer is a member of the workgroup "WORKGROUP".

    Right click on "My computer" > select "Properties" > select the "Network Identification" tab

    Also try this fstab line:
    Code:
    //CSI/Outdoors /mnt/csi cifs credentials=/home/mmavrice/.smbcredentials,rw,domain=WORKGROUP,nounix,iocharset=utf8,file_mode =0777,dir_mode=0777 0 0

Page 68 of 137 FirstFirst ... 1858666768697078118 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •