Page 63 of 137 FirstFirst ... 1353616263646573113 ... LastLast
Results 621 to 630 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #621
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by zeezam View Post
    Still getting the "mount error 13 = Permission denied" error message when I'm using this in fstab:

    Code:
    //192.168.0.100/fred /media/fred cifs credentials=/root/.smbcredentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Make sure you use the netbios name instead of the IP address. Enable wins support as outlined under "Pre Work".

    This DOES make a difference.

  2. #622
    Join Date
    May 2008
    Beans
    105

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Make sure you use the netbios name instead of the IP address. Enable wins support as outlined under "Pre Work".

    This DOES make a difference.
    Did those settings and restarted networking in /etc/init.d.
    Still the same:

    # mount -a
    mount: mount point does not exist
    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

  3. #623
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    do your windows username or password contain spaces or other unusual characters?

  4. #624
    Join Date
    May 2008
    Beans
    105

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    do your windows username or password contain spaces or other unusual characters?
    Yes. I did try with username='my username'
    password='my password'
    Last edited by zeezam; July 30th, 2008 at 10:54 AM.

  5. #625
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try it without the ' around it. The credentials file does not support usernames or passwords with leading spaces, but the man file doesn't say anything special about spaces in any other location.

  6. #626
    Join Date
    May 2008
    Beans
    105

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try it without the ' around it. The credentials file does not support usernames or passwords with leading spaces, but the man file doesn't say anything special about spaces in any other location.
    Thanks now it worked when I removed the ' around '.

  7. #627
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by zeezam View Post
    Thanks now it worked when I removed the ' around '.
    Fantastic! That's really good to know.

  8. #628
    Join Date
    Jul 2008
    Beans
    2

    Re: Mount samba shares with utf8 encoding using cifs

    Hey dmizer,

    I've read through a lot of this forum, and saw a lot of great help, thanks for helping all us ubuntu babies out.

    I've run into a problem with mounting windows vista shares. I'm on hardy.

    I've followed the step-by-step, having installed smbfs and have wins support. Still, when I try to mount my windows share permanently I get this error:

    Code:
    rastem@MediaCenter:~$ sudo mount -a
    retrying with upper case share name
    mount error 6 = No such device or address
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    fstab
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda6
    UUID=200497fd-8b90-479f-b7f5-232b8dfc5d18 /               ext3    relatime,errors=remount-ro 0       1
    # /dev/sdb5
    UUID=dc873d9d-e8ba-469d-aa41-7ce76038daaa /home           ext3    relatime        0       2
    # /dev/sda5
    UUID=1fe1161e-af21-4dc8-979e-7beb34ae0b5e none            swap    sw              0       0
    /dev/scd0                       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/fd0                        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
    //sinistar/deep%20space         /media/metroid  cifs    credentials=/root/.smbcredentials,rw,noperm,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    dmesg | tail
    Code:
    CIFS VFS: cifs_mount failed w/return code = -6
    vdir /media
    Code:
    total 12
    lrwxrwxrwx 1 root root    6 2008-08-06 19:15 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2008-08-06 19:15 cdrom0
    lrwxrwxrwx 1 root root    7 2008-08-06 19:15 floppy -> floppy0
    drwxr-xr-x 2 root root 4096 2008-08-06 19:15 floppy0
    drwxr-xr-x 3 root root 4096 2008-08-06 22:57 metroid
    smbtree
    Code:
    rastem@MediaCenter:~$ smbtree
    Password: 
    WORKGROUP
    	\\SINISTAR
    Sinistar is the name of the vista computer. I can ping via wins and IP, and I can also connect to the folder via Places -> Connect to server

    Am I missing something obvious? I've seen a lot of folks talking about different errors, but not much on error 6. It's either something wily, or cockpit error on my part, but I wanted to throw it up here.

    Any help is greatly appreciated!

    J.

  9. #629
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Heh ... "I hunger!"

    Looks like you've escaped your space incorrectly. Try your fstab line like so:
    Code:
    //sinistar/deep\040space         /media/metroid  cifs    credentials=/root/.smbcredentials,rw,noperm,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    If that doesn't work, try creating a new test share without a space in the directory name, and see if you can connect to that.

    It would so help if little things like this were standardized so that %20 always worked, or \040 always worked.[/rant]

  10. #630
    Join Date
    Jul 2008
    Beans
    2

    Re: Mount samba shares with utf8 encoding using cifs

    That did the trick, you are my hero!

    Nowhere in my research did I find that spaces could cause this issue, though I had a sneaking suspicion it had to be that since 'no such device or address' kept hinting at me that it was something like that.

    Thanks so much for the easy-to-follow walkthrough and your help! I can't wait to hit up amarok now.

    J.

Page 63 of 137 FirstFirst ... 1353616263646573113 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •