Page 61 of 137 FirstFirst ... 1151596061626371111 ... LastLast
Results 601 to 610 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #601
    Join Date
    Jun 2008
    Beans
    52

    Re: Mount samba shares with utf8 encoding using cifs

    The smb.conf file was created with the gui program GSAMBAD, having looked into samba a little more it seems overly complex for what my needs are. Would you agree?

    One idea that has been bugging me, as I did have the root account enabled on the laptop which is now disabled (I think?), could this have somehow messed with the default permissions etc of the inner workings of my OS?

    I'm still coming to terms with the whole sudo vs su idea so I apologize for the newbie question, but hey, I am a newbie...

  2. #602
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    seems way overly complex, but i'm not sure what you're trying to do. having root access and then subsequently disabling it would have had no effect on this issue as far as i know. this appears to be more closely related to your samba server setup.

    have a look at the first link in my sig. i'm positive that the smb.conf example in that howto works.

  3. #603
    Join Date
    Jun 2008
    Beans
    52

    Re: Mount samba shares with utf8 encoding using cifs

    Roger that,

    I guess I was looking for an quick & easy way to set up samba using a gui, I blame way to many years using Windows and being stuck in that mindset.

    I did a bit of googling and came up with a couple of similar issues:

    here and here

    But, I'm not sure if that relates to what we've been trying to fix.

    Having read into samba a bit more, it doesn't seem all that hard to manually configure... especially as I'm only looking to facilitate basic file sharing. So I might just start from scratch...

    Thanks for your input and patience... I'll let you know how I get on

  4. #604
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, either way you'll have to address your smb.conf configuration because you said you were having problems with windows permissions as well.

    both of the links you posted are talking about permission problems with smbfs not cifs. they are also both quite old, and i'm quite sure that the solution posted in the second link will no longer be successful.

  5. #605
    Join Date
    Jun 2008
    Beans
    52

    Re: Mount samba shares with utf8 encoding using cifs

    Figured as much with regards to smbfs & the relative age of the info.

    Hence why I'm starting again...

  6. #606
    Join Date
    Jun 2008
    Beans
    52

    Re: Mount samba shares with utf8 encoding using cifs

    Ok,

    I started everything from scratch and ended up with the same result...

    But, having done a bit more reading, I found something that seems to work:

    in the smb.conf file, when I added the line:

    inherit owner = Yes

    under each share, it all started working as it should...


  7. #607
    Join Date
    Apr 2007
    Beans
    12

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by earthenergie View Post
    Thank you for these well-written instructions. Perhaps you can help me with this problem. After mounting, I can change directory ( to several levels in the mount), create directory and list directories. But if I try to read a file (with cat or more) the terminal hangs following error in kern.log:

    CIFS VFS: RFC1001 size 135 bigger than SMB for Mid=48
    Bad SMB: : dump of 48 bytes of data at 0xdebff380

    I am running a fully patched Hardy and my /etc/fstab entry for the mount is:
    Code:
    //abcdef/HOME	/media/documents cifs auto,iocharset=utf8,uid=abc,gid=abc,credentials=/root/.cifscredentials,file_mode=0755,dir_mode=0755 0 0
    I have searched in vain for clues as to where the fault may lie, but have had no success. Have you seen this type of error before?

    Many thanks.
    Just thought I would add some info to this since I didn't see an explanation to this particular issue. I am experiencing the same issue that earthenergie reported above. Googling and speaking with our storage admin here at work provided this link
    http://kbase.redhat.com/faq/FAQ_103_11046.shtm

    The EMC case referenced in that link states the following:
    Environment: Product: Celerra

    Environment: EMC SW: NAS Code 5.5.26.x and earlier

    Environment: Protocol: Server Message Block (SMB)

    Environment: Protocol: Common Internet File System (CIFS)

    Environment: OS: SuSE Linux 10.2 (2.6.18 Kernel, 1.45 CIFS)

    Environment: OS: Fedora Core 6 (2.6.20 Kernel, 1.47 CIFS)

    Problem: After recent Linux upgrade, accessing CIFS shares causes Linux CIFS client to hang or possibly panic.

    Problem: Celerra server log contains the following or similar error messages when a client attempts to read a file:

    SMB: 3: Client=10.0.0.1 OS='Linux version 2.6.20-1.2925.fc6', LM='CIFS VFS Client for Linux' not registered capa=0xd0dc (R=8/8)

    SMB: 3: Client=10.0.0.1 OS=Linux version 2.6.20-1.2925.fc6 LM=CIFS VFS Client for Linux Extra=- type=- (1)

    SMB: 3: Client=10.0.0.1 OS='Linux version 2.6.20-1.2925.fc6', LM='CIFS VFS Client for Linux' not registered capa=0xd0dc (R=8/8)

    SMB: 3: Client=10.0.0.1 OS=Linux version 2.6.20-1.2925.fc6 LM=CIFS VFS Client for Linux Extra=- type=- (1)



    Change: Recent upgrade to Linux client.

    Root Cause: EMC DART OS was modified to return extended response to NTcreateX only if the bit 0x10 is set in the Create Flag, instead of assuming the extended info is required for a Windows 2000 client (see below). With the code modification, the extended response is only returned when the Extended Response Create Flag is set.

    Affected versions include:



    Fedora Core 6 (32-bit)

    Kernel: 2.6.20-1.2925

    CIFS Module Version: 1.47



    SuSe Linux 10.2

    Kernel: 2.6.18.2-34-default

    CIFS Module Version: 1.45



    SMB Header

    NT Create AndX Request

    Create Flags: 0x00000010

    .... .... .... .... .... .... ...1 .... = Extended Response: Extended responses required

    .... .... .... .... .... .... .... 0... = Create Directory: Target of open can be a file

    .... .... .... .... .... .... .... .0.. = Batch Oplock: Does NOT request batch oplock

    .... .... .... .... .... .... .... ..0. = Exclusive Oplock: Does NOT request oplock

    Fix: Upgrade to NAS Code 5.5.27.5 or later.

    Notes: See AR 87272 for more information.
    Hopefully this information helps. As for testing the above, we have 2 Celerra NAS device from EMC, one with a newer code level and I can browse files on it without a problem. The other has the code referenced and Gnome just spins it's wheels when trying to browse

  8. #608
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by imthemp3king View Post
    Just thought I would add some info to this since I didn't see an explanation to this particular issue.
    thank you so much for the follow up. i couldn't come up with anything myself. glad to have your experience in the thread.

  9. #609
    Join Date
    Jul 2008
    Location
    So Cal, USA
    Beans
    61
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Mount samba shares with utf8 encoding using cifs

    This tutorial rocked my world for my Win2k Advanced Server and Win2k shares on the home lan. Desktop rig is Ubuntu 8.04 Hardy Heron. All 7 of my windows shares show up as sexy little Hard Drive ICONS on the desktop.

    Thank you my good man!

  10. #610
    Join Date
    Jan 2007
    Location
    South Africa
    Beans
    80
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for the great guide, I have manged to mount everything I need. My only problem is that my network connection is a little slow. I am using a wireless connections that activates using a script in the .rc file, which I presume executes after the fstab file, so my shares won't mount until I run the mount -a cmd. Is there antway I can automate this mount -a cmd so I don't have to do it manually everytime ?

Page 61 of 137 FirstFirst ... 1151596061626371111 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •