Page 54 of 137 FirstFirst ... 444525354555664104 ... LastLast
Results 531 to 540 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #531
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by akahige View Post
    Windows share name contains tilde. Actually, I screwed up with the initial mount, since I actually did create the mount point as /media/xfer.

    Followed your instructions. Able to browse and write to the mounted directory. First time I tried copying a directory and got a permission denied, but copied a file then went back and tried the directory again, and that worked okay. Not blazingly fast, but not dog-slow, either -- about 600kbps - 900kbps.
    sounds good to me.

    Quote Originally Posted by akahige View Post
    This seems rather like progress. Given this, do you have any theory as to why writing to the nas isn't performing to the same degree (or should we just give up on that and go with nfs)?
    theory: many nas devices are made cheaply with inferior firmware programming which is incapable of interfacing well with linux. a quick search through this thread should validate my claim

    action: give up and go with nfs for connecting to your nas, and then maybe you can get back to your rounds in the secret garden.

  2. #532
    Join Date
    Jun 2008
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    I had been pretty annoyed for the last few weeks with the substitution of smbfs with cifs in hardy.
    I had tried all the usual hints in this forum but still couldn't get rid of
    "mount error 13 = Permission denied"

    Until now! This sh..y cifs can't deal properly with passwords containing special charakters like german mutated vowels.

    I substituted the "ö" with "#" and my shares have been mounted again!

    Maybe this helps someone else out there.

  3. #533
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by cifs_sucks View Post
    I had been pretty annoyed for the last few weeks with the substitution of smbfs with cifs in hardy.
    I had tried all the usual hints in this forum but still couldn't get rid of
    "mount error 13 = Permission denied"

    Until now! This sh..y cifs can't deal properly with passwords containing special charakters like german mutated vowels.

    I substituted the "ö" with "#" and my shares have been mounted again!

    Maybe this helps someone else out there.
    you can use proxy authentication through squid and smb_auth in order to authenticate with german umlauts.
    Last edited by dmizer; June 12th, 2008 at 12:34 AM.

  4. #534
    Join Date
    May 2007
    Location
    Scotland
    Beans
    13
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    try this:
    Code:
    //192.168.1.4/music /media/sda7/music/Xanthi cifs guest,iocharset=iso8859-7 0 0
    Thanks for the prompt reply dmizer
    I tried iocharset=iso8859-7 and it changes the greek chracters to a black diamond with a question mark in the middle. Any other ideas?!

  5. #535
    Join Date
    Jun 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer

    I have followed your instructions to mount a share manually to the letter and when trying to mount my windows xp pro share using 'sudo mount -t cifs //flem/Music /mnt/music -o username=mywindowsusername,password=mywindowspassw ord,iocharset=utf8,file_mode=0777,dir_mode=0777' I receive the error 'mount error 6 = No such device or address'

    I can connect to the share through nautilus, and can ping the box by ip and by name. I'm new to Linux and can't work out where to go from here. I've looked around and cant find anyone with the same problem or any solution.

    Is there any chance you can help me?

    Thanks in advance.

  6. #536
    Join Date
    Jun 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Ignore my post please, I've figured it out

    Thanks

  7. #537
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Bobba View Post
    Thanks for the prompt reply dmizer
    I tried iocharset=iso8859-7 and it changes the greek chracters to a black diamond with a question mark in the middle. Any other ideas?!
    well, as far as i can tell, there are only two possible encodings for you to use with greek characters (iso8859-7 and unicode), you may need to look into making sure your local login has all the necessary encodings to support greek characters.

    you may have to make sure you're using the LANG environment variable of el_GR.iso8859-7.

    were the file names created on a windows or a linux computer?

  8. #538
    Join Date
    Oct 2006
    Beans
    20

    Re: Mount samba shares with utf8 encoding using cifs

    I'm new to this post and have read the entire 54 pages, whew! My NAS drive (ext2) mounts fine using your guide using cifs. However when trying to move/copy files from my Desktop (Kubuntu 8.04) to the NAS drive folder, I get the error "Could not change permissions for "xxxx.xxx". The files eventually copy over but when copying folders, not all sub-folders and/or files are brought over. Do you have any words of wisdom with this problem? Yes, I'm fairly new to Linux (1 year) and learned a lot reading your post, thanks for being so helpful.

  9. #539
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by jwillar View Post
    I'm new to this post and have read the entire 54 pages, whew!
    just for future reference, when you run into threads like this one that have been around for years and have tens of pages of replies, your best bet is to start from the back and work forward. that way you get the most recent (and most relevant) posts. in this thread, probably the first 10 to 20 or so pages contain very little information that's relevant, or has not been updated an addressed in the first post.

    Quote Originally Posted by jwillar View Post
    My NAS drive (ext2) mounts fine using your guide using cifs. However when trying to move/copy files from my Desktop (Kubuntu 8.04) to the NAS drive folder, I get the error "Could not change permissions for "xxxx.xxx". The files eventually copy over but when copying folders, not all sub-folders and/or files are brought over. Do you have any words of wisdom with this problem? Yes, I'm fairly new to Linux (1 year) and learned a lot reading your post, thanks for being so helpful.
    it's no problem, glad you were able to learn a lot.

    please post the output of:
    Code:
    ls -l /media/sharename
    where "/media/sharename" is the mountpoint you used in your mount line.

  10. #540
    Join Date
    Jun 2008
    Location
    United States
    Beans
    28
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Mount samba shares with utf8 encoding using cifs

    thanks for the help will look and see if i can't get this

Page 54 of 137 FirstFirst ... 444525354555664104 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •