Page 53 of 137 FirstFirst ... 343515253545563103 ... LastLast
Results 521 to 530 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #521
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    sheesh ... i guess i should never assume anything. the fstab mount command you gave me earlier had your share mounted in /media, so i didn't foresee you having a problem with the -R switch.

    you shouldn't have to use the places menu to browse your share. you should see it in your home directory as an additional folder, just as though it's physically located in your ubuntu machine. but maybe i'm just misunderstanding what you meant.

    try copying a file to your share via the command line and see if there are errors shown.

  2. #522
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    sheesh ... i guess i should never assume anything. the fstab mount command you gave me earlier had your share mounted in /media, so i didn't foresee you having a problem with the -R switch.
    I know. Like I said, that was my bad. Too much stress, too little sleep.


    Quote Originally Posted by dmizer View Post
    you shouldn't have to use the places menu to browse your share. you should see it in your home directory as an additional folder, just as though it's physically located in your ubuntu machine. but maybe i'm just misunderstanding what you meant.
    That's all well and fine, but you (the royal you) don't want to mount every machine you *might* consider browsing or throwing a file on. I can barely read those machines -- and I can't even begin to write to them. (I'm not kidding about the 1k per sec. write times. And yet I can stream music to Rhythmbox without a problem.)

    Whatever bad is going on with Places is crashing Nautilus and bits of the desktop. Like I said before, it used to work, but after I installed smbfs, everything started slipping. And shortly thereafter, there was a blizzard of updates to what looked like most of those installed packages. I don't know if that helped or hurt things.

    If there's some kind of network activity via smb, even clicking the Places button will lockup the entire toolbar until things either finish or get canceled.


    Quote Originally Posted by dmizer View Post
    try copying a file to your share via the command line and see if there are errors shown.
    No errors. It just takes forever to create a 0 byte file in the destination directory. (1.5 mins to copy a 16k text file.)

  3. #523
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, i found a post (on experts-exchange of all places) that gives a better way of changing the uid and gid:

    Code:
    sudo usermod -u 1002 michael
    sudo groupmod -g 1002 michael
    then you'll need to search for the old files and folders you created with the old uid/gid:
    Code:
    sudo find / -uid 1000 | xargs ls -al >> olduid.txt
    sudo find / -gid 1000 | xargs ls -al >> oldgid.txt
    review these files to make sure all is accurate. if they all should be changed, then you can run these commands to change the permissions on those files:
    Code:
    sudo su
    find / -uid 1000 | xargs chown michael
    find / -gid 1000 | xargs chgrp michael
    i'm afraid that some of your instability issues may be related to the -R switch, but i have no way of verifying that. if i had given this suggestion even a few seconds of consideration, i wouldn't have posted it. ... you may be better off at this point if you create a new user on your system, so that you have a fresh home folder with all the correct permissions.

    as for slow data transfer ... do you have firestarter, or some other iptables script enabled on your ubuntu computer?
    Last edited by dmizer; June 11th, 2008 at 06:01 AM.

  4. #524
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    well, i found a post (on experts-exchange of all places) that gives a better way of changing the uid and gid:
    Is this moot since it's working, now, or are bits of it still relevant?


    Quote Originally Posted by dmizer View Post
    i'm afraid that some of your instability issues may be related to the -R switch, but i have no way of verifying that. if i had given this suggestion even a few seconds of consideration, i wouldn't have posted it. ... you may be better off at this point if you create a new user on your system, so that you have a fresh home folder with all the correct permissions.
    I haven't seen any evidence that the -R had any negative effect on anything. It's fairly easy to turn the -x bit off of text files. So far, everything else seems to be working as it was previously.

    The thing with -R and the NAS is I'd mounted my home dir on the NAS in my /home dir on the local machine. It's pretty much all data and media. Any apps are Windows based, and Windows doesn't seem to care about the UNIX permissions.


    Quote Originally Posted by dmizer View Post
    as for slow data transfer ... do you have firestarter, or some other iptables script enabled on your ubuntu computer?
    Nope. Firestarted not installed. Haven't done anything to iptables. Should all be stock.

    Here's an interesting question, though... I was doing some research on my own to see if I could find anything out about this transfer/connect issue. Haven't come up with anything, but the networking forum is full of people experiencing the exact same thing -- and finding no one with any clue why.

    There were a blizzard of updates to some of the networking components in the last few days. I don't think they helped anything, but I can't tell if they broke things worse than they were before.

    Got any thoughts on that?

  5. #525
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by akahige View Post
    Is this moot since it's working, now, or are bits of it still relevant?

    I haven't seen any evidence that the -R had any negative effect on anything. It's fairly easy to turn the -x bit off of text files. So far, everything else seems to be working as it was previously.

    The thing with -R and the NAS is I'd mounted my home dir on the NAS in my /home dir on the local machine. It's pretty much all data and media. Any apps are Windows based, and Windows doesn't seem to care about the UNIX permissions.
    if it's working, then leave well enough alone, but keep this in mind if you run into problems later.


    Quote Originally Posted by akahige View Post
    Nope. Firestarted not installed. Haven't done anything to iptables. Should all be stock.

    Here's an interesting question, though... I was doing some research on my own to see if I could find anything out about this transfer/connect issue. Haven't come up with anything, but the networking forum is full of people experiencing the exact same thing -- and finding no one with any clue why.

    There were a blizzard of updates to some of the networking components in the last few days. I don't think they helped anything, but I can't tell if they broke things worse than they were before.

    Got any thoughts on that?
    at this point, i would ditch cifs in favor of nfs since your nas supports nfs.

  6. #526
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    if it's working, then leave well enough alone, but keep this in mind if you run into problems later.
    Will do.


    Quote Originally Posted by dmizer View Post
    at this point, i would ditch cifs in favor of nfs since your nas supports nfs.
    That would be fine, except for the fact that it's not just the nas that was effected by this. I have no ability to write to Windows machines.

    I did some looking, but didn't turn up any tutorials on getting nfs working. Do you know of anything that I might have missed?

  7. #527
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by akahige View Post
    That would be fine, except for the fact that it's not just the nas that was effected by this. I have no ability to write to Windows machines.

    I did some looking, but didn't turn up any tutorials on getting nfs working. Do you know of anything that I might have missed?
    there is a great nfs howto in my sig, but that won't help you with your windows machines.

    on one of your windows machines, try the manual mount with the verbose option like so:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename --verbose -o username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777
    and post the output (be sure to sensor your password)

  8. #528
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    there is a great nfs howto in my sig, but that won't help you with your windows machines.
    Uh... well... I sure managed to miss that.


    Quote Originally Posted by dmizer View Post
    on one of your windows machines, try the manual mount with the verbose option like so:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename --verbose -o username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777
    and post the output (be sure to sensor your password)
    parsing options: rw,username=XXX,password=XXX,iocharset=utf8,file_m ode=0777,dir_mode=0777
    mount error: can not change directory into mount target /media/~xfer

  9. #529
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    humm ... add the rw option, and try making a mountpoint that doesn't contain a tilda. like this:
    Code:
    sudo mkdir /media/xfer
    sudo chmod 777 /media/xfer
    sudo mount -t cifs //netbiosname/sharename /media/xfer --verbose -o rw,username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777
    see if you have more success with writing to this share. does the windows sharename also contain a tilda?

  10. #530
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    humm ... add the rw option, and try making a mountpoint that doesn't contain a tilda. like this:
    Code:
    sudo mkdir /media/xfer
    sudo chmod 777 /media/xfer
    sudo mount -t cifs //netbiosname/sharename /media/xfer --verbose -o rw,username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777
    see if you have more success with writing to this share. does the windows sharename also contain a tilda?
    Windows share name contains tilde. Actually, I screwed up with the initial mount, since I actually did create the mount point as /media/xfer.

    Followed your instructions. Able to browse and write to the mounted directory. First time I tried copying a directory and got a permission denied, but copied a file then went back and tried the directory again, and that worked okay. Not blazingly fast, but not dog-slow, either -- about 600kbps - 900kbps.

    This seems rather like progress. Given this, do you have any theory as to why writing to the nas isn't performing to the same degree (or should we just give up on that and go with nfs)?

Page 53 of 137 FirstFirst ... 343515253545563103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •