Page 52 of 137 FirstFirst ... 242505152535462102 ... LastLast
Results 511 to 520 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #511
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    ls -l /media/nas_media
    Code:
    total 0
    drwxrwxrwx  6 98 98 0 2007-12-31 22:43 audio
    drwxrwxrwx 11 98 98 0 2008-06-08 12:31 images
    drwxrwxrwx 11 98 98 0 2008-04-14 10:12 videos

    ls -n /media/nas_media
    Code:
    total 0
    drwxrwxrwx  6 98 98 0 2007-12-31 22:43 audio
    drwxrwxrwx 11 98 98 0 2008-06-08 12:31 images
    drwxrwxrwx 11 98 98 0 2008-04-14 10:12 videos

    cat /etc/passwd
    Code:
    root:x:0:0:root:/root:/bin/bash
    daemon:x:1:1:daemon:/usr/sbin:/bin/sh
    bin:x:2:2:bin:/bin:/bin/sh
    sys:x:3:3:sys:/dev:/bin/sh
    sync:x:4:65534:sync:/bin:/bin/sync
    games:x:5:60:games:/usr/games:/bin/sh
    man:x:6:12:man:/var/cache/man:/bin/sh
    lp:x:7:7:lp:/var/spool/lpd:/bin/sh
    mail:x:8:8:mail:/var/mail:/bin/sh
    news:x:9:9:news:/var/spool/news:/bin/sh
    uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
    proxy:x:13:13:proxy:/bin:/bin/sh
    www-data:x:33:33:www-data:/var/www:/bin/sh
    backup:x:34:34:backup:/var/backups:/bin/sh
    list:x:38:38:Mailing List Manager:/var/list:/bin/sh
    irc:x:39:39:ircd:/var/run/ircd:/bin/sh
    gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
    nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
    dhcp:x:100:101::/nonexistent:/bin/false
    syslog:x:101:102::/home/syslog:/bin/false
    klog:x:102:103::/home/klog:/bin/false
    avahi-autoipd:x:103:109:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/bin/false
    messagebus:x:104:110::/var/run/dbus:/bin/false
    avahi:x:105:111:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false
    cupsys:x:106:113::/home/cupsys:/bin/false
    haldaemon:x:107:114:Hardware abstraction layer,,,:/home/haldaemon:/bin/false
    hplip:x:108:7:HPLIP system user,,,:/var/run/hplip:/bin/false
    gdm:x:109:118:Gnome Display Manager:/var/lib/gdm:/bin/false
    michael:x:1000:1000:Michael Venables,,,:/home/michael:/bin/bash
    ntp:x:110:120::/home/ntp:/bin/false
    libuuid:x:111:121::/var/lib/libuuid:/bin/sh
    polkituser:x:112:124:PolicyKit,,,:/var/run/PolicyKit:/bin/false
    festival:x:113:29::/home/festival:/bin/false
    pulse:x:114:116:PulseAudio daemon,,,:/var/run/pulse:/bin/false

    I've also been reading over on the ReadyNAS forum, and there may be an issue of the UID numbers needing to match in order for the permissions to be totally sorted. (Can those be changed arbitrarily without creating problems? On the Linux machine to match the NAS, seems to be the best solution.)

  2. #512
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by akahige View Post
    I've also been reading over on the ReadyNAS forum, and there may be an issue of the UID numbers needing to match in order for the permissions to be totally sorted. (Can those be changed arbitrarily without creating problems? On the Linux machine to match the NAS, seems to be the best solution.)
    actually that's what i was trying to determine via the above commands. it looks like the uid and gid on the nas is 98 (which seems strange, so double check that).

    if it is 98, then you could mount with this command:
    Code:
    //RGONAS-01/media    /media/nas_media        cifs    credentials=/root/.smbcredentials,iocharset=utf8,uid=98,gid=98,file_mode=0777,dir_mode=0777 0 0

  3. #513
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    actually that's what i was trying to determine via the above commands. it looks like the uid and gid on the nas is 98 (which seems strange, so double check that).

    if it is 98, then you could mount with this command:
    Code:
    //RGONAS-01/media    /media/nas_media        cifs    credentials=/root/.smbcredentials,iocharset=utf8,uid=98,gid=98,file_mode=0777,dir_mode=0777 0 0
    I did some looking at the files/directories that have locks vs the ones that don't. The ones that don't have "owner = 98 & group = 98", whereas the locked ones are "owner = 1002 & group = users".

    The thing I'm totally baffled by is that I created all of these as my normal user-self (on Windows). I'll have to post to the NAS support forum and see if I can get an explanation as to why this is. Can't remotely fathom why the uid/gid should be anything other than 1002/users -- nor do I get why the smb authentication is doing something different with the same credentials that Windows feeds it.

    Here's an interesting thought, though... I'm wondering if the uid/gid = 98 thing might not be some kind of generic permission that is basically ignored by other uid/gid combinations. If that makes any sense, might it be possible to change your mount command as follows?
    Code:
    //RGONAS-01/media    /media/nas_media        cifs    credentials=/root/.smbcredentials,iocharset=utf8,uid=1002,gid=users,file_mode=0777,dir_mode=0777 0 0
    Once I get some kind of answer from the ReadyNAS folks, I'll post back here and see if we can't make some more headway...

  4. #514
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Something of an update... more like a change in status, since now I've gotten some sleep and had a chance to take a closer look at the consequences of what happened last night.

    Haven't heard from the NAS people, but there's a much more critical problem: smb is completely FUBAR. Using "Places" in Gnome, I can browse some things on the network, but even that is glacially slow. There are all kinds of errors: connection timeouts, files that transfer (writes) at 1k per second and then fail, "didn't get stream file descriptor", etc. And sometimes Nautilus will crash.

    By contrast, the mount point for the NAS that was created in fstab browses instantly -- but the previously mentioned write issues still exist.

    I'm totally out of my depth here, and desperately hoping this can be unhosed, somehow...

  5. #515
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, try changing your ubuntu uid number to 1002.

    this line in /etc/passwd represents your ubuntu user:
    Code:
    michael:x:1000:1000:Michael Venables,,,:/home/michael:/bin/bash
    edit the file with your favorite text editor (i like nano) like so:
    Code:
    sudo nano /etc/passwd
    then, simply change the 1000:1000 to 1002:1002 like so:
    Code:
    michael:x:1002:1002:Michael Venables,,,:/home/michael:/bin/bash
    remount and see if that changes anything for you.

  6. #516
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Well, it certainly changed something... it killed my ability to sudo because it's looking for the old uid -- which also means that I can't change it back.

    Thoughts...?

  7. #517
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    ugh ... sorry about that.

    boot into recovery mode:
    press <ESC> at the startup, where grub is counting down. recovery mode should be the second kernel option in the list. use your arrows to select it, and hit <ENTER> to boot it.

    you will be presented with a root command line.
    edit /etc/group like so:
    Code:
    nano /etc/group
    look for the line that says:
    Code:
    michael:x:1000:
    and change it to this:
    Code:
    michael:x:1002:
    reboot with the following command:
    Code:
    reboot

  8. #518
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    ugh ... sorry about that.
    Keep those apologies comin'!

    Okay, I followed your recovery instructions and things broke even further. When I went to log back into the desktop, I got the following:

    User's $HOME/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions. User's $HOME directory must be owned by user and not writable by other users.
    Then the session terminated and it threw me back to the login screen.

    At this point, I went back into recovery mode and regressed the uid changes from /etc/group and /etc/passwd so that I could get back into the desktop, if nothing else.

    Now what...?

  9. #519
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    frankly, i've never done this before so i'm not entirely sure what you'll run into. didn't expect it to be this difficult though. it's much easier in gutsy where you can edit the users uid/gid via system > admin > users

    here is the fix for your previous error.

    after changing the /etc/group file, reboot into recovery mode again, and run these commands:
    [clipped]
    see this post: http://ubuntuforums.org/showpost.php...&postcount=523

    that should be the end of the issues.
    Last edited by dmizer; June 11th, 2008 at 05:46 AM.

  10. #520
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    frankly, i've never done this before so i'm not entirely sure what you'll run into.
    I hope you're taking notes since the pain of being a guinea pig should go to the greater good.


    Quote Originally Posted by dmizer View Post
    that should be the end of the issues.
    End of the issues that was keeping me out of the desktop, yes. However, the chmod -R 700 probably wasn't the best way of going about things. Did I really need my text files to be set to executable? (And the fact that I had my home directory on the NAS mounted in the local home didn't help when -R went howling into it, either. That's my bad.)

    So... the good news... directories that are mounted in fstab browse very quickly (they should, they're all being served over a gig-e network). However, I can't write to any of them without timeouts -- and at a transfer speed of about 1k, which will then proceed to fail.

    When I try to browse the smb shares on the network (via Gnome places), I continually get errors like this:

    Couldn't display [path]
    There is no application installed for this file type.
    Or timeouts as it struggles to read.

Page 52 of 137 FirstFirst ... 242505152535462102 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •