Page 51 of 137 FirstFirst ... 41495051525361101 ... LastLast
Results 501 to 510 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #501
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    exact syntax in the smb credentials file is critical.

    substituting "user" for "username" and "pass" for "password" will result in a non-functional smb credentials file.

  2. #502
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by bobd72 View Post
    Thanks for a great thread - it has been a huge help to me.
    I am using a network with a single windows machine and a number of Hardy boxes. The windows machine has a partition D$ which gives access to the Hardy machines using cifs.

    If I use the following format in /etc/fstab of a Hardy box it mounts the share correctly in the directory /media/windata at boot.

    //192.168.72.1/D$ /media/windata cifs rw,user=<MyUsername>,pass=<MyPassword>,domain=<MyW orkgroup>,nounix 0 0

    However, If I use a credentials file as below:

    //192.168.72.1/D$ /media/windata cifs rw,credentials=/root/.smb_credentials,domain=<MyWorkgroup>,nounix 0 0

    the directory is empty. Changing permissions on the credentials file appears to make no difference nor does placing the credentials file in my home directory.

    Why?
    final fix for this problem was to install smbfs with the following command:
    Code:
    sudo aptitude install smbfs
    shares became available once smbfs was installed.

  3. #503
    Join Date
    May 2008
    Beans
    21

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks you for you help with this problem dmizer. Now everything works OK. I have another Hardy machine - a Laptop - which has exactly the same problem which I can now resolve.
    I had read somewhere that smbfs was replaced in Hardy by cifs. Is this correct?
    If this is the case and smbfs isn't installed by default but cifs is dependent on it for some functions, others may experience problems. The fact that it worked without the credentials file even though smbfs wasn't installed would perhaps support this?

  4. #504
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by bobd72 View Post
    Thanks you for you help with this problem dmizer. Now everything works OK. I have another Hardy machine - a Laptop - which has exactly the same problem which I can now resolve.
    glad we got you going.

    Quote Originally Posted by bobd72 View Post
    I had read somewhere that smbfs was replaced in Hardy by cifs. Is this correct?
    yes, this is correct. there is more information in the afterword of the howto regarding this.

    Quote Originally Posted by bobd72 View Post
    If this is the case and smbfs isn't installed by default but cifs is dependent on it for some functions, others may experience problems. The fact that it worked without the credentials file even though smbfs wasn't installed would perhaps support this?
    no ... in Hardy, smbfs is merely the name of a metapackage which installs all the requirements for cifs. so, interestingly, "sudo aptitude install smbfs" doesn't actually install smbfs in hardy.

    as near as i can guess, in order to allow Nautilus to mount windows shares in Hardy (in previous releases, nautilus used smbfs not cifs), some basic cifs functionality must be enabled by default.
    Last edited by dmizer; June 5th, 2008 at 08:03 AM.

  5. #505
    Join Date
    May 2007
    Location
    Scotland
    Beans
    13
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Any ideas on how to make Greek characters appear correctly with samba?

    Browsing the folder on the network smb:// appears with the correct filenames in Greek characters, but when I mount the folder I see question marks instead of the correct characters.

    I'm running Fesity and my fstab looks like this:

    //192.168.1.4/music /media/sda7/music/Xanthi cifs guest,iocharset=utf8 0 0

  6. #506
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    I'm on a Hardy system, and while I have been able to browse/read network shares -- WinXP, and an Infrant ReadyNAS (cifs, smb, nfs capable) -- I've had problems writing to them (I get timeout errors that result in empty files). So I decided to try your way of doing things.

    Followed the directions. Everything seemed to go okay, but now I'm seeing differences and problems.

    1) I'm able to mount some of the shares, but many -- not all -- of the files/directories have locks indicating that I don't have permission to write to them. This isn't an issue when I browse the same share with the same credentials from Windows.

    2) I see that now smbtree no longer displays everything in the network (even though I can browse things that "aren't there" in Nautilus)

    3) On certain shares, even though it mounts (or appears to mount) I can't browse it. I get "The folder contents could not be displayed. You do not have the permissions necessary to view the contents of..."

    This is about the point where I decided that it's in my best interests to stop experimenting with things I don't grok, and ask for help.
    Last edited by akahige; June 8th, 2008 at 08:20 PM.

  7. #507
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Bobba View Post
    Any ideas on how to make Greek characters appear correctly with samba?

    Browsing the folder on the network smb:// appears with the correct filenames in Greek characters, but when I mount the folder I see question marks instead of the correct characters.

    I'm running Fesity and my fstab looks like this:

    //192.168.1.4/music /media/sda7/music/Xanthi cifs guest,iocharset=utf8 0 0
    try this:
    Code:
    //192.168.1.4/music /media/sda7/music/Xanthi cifs guest,iocharset=iso8859-7 0 0

  8. #508
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by akahige View Post
    I'm on a Hardy system, and while I have been able to browse/read network shares -- WinXP, and an Infrant ReadyNAS (cifs, smb, nfs capable) -- I've had problems writing to them (I get timeout errors that result in empty files). So I decided to try your way of doing things.

    Followed the directions. Everything seemed to go okay, but now I'm seeing differences and problems.

    1) I'm able to mount some of the shares, but many -- not all -- of the files/directories have locks indicating that I don't have permission to write to them. This isn't an issue when I browse the same share with the same credentials from Windows.

    2) I see that now smbtree no longer displays everything in the network (even though I can browse things that "aren't there" in Nautilus)

    3) On certain shares, even though it mounts (or appears to mount) I can't browse it. I get "The folder contents could not be displayed. You do not have the permissions necessary to view the contents of..."

    This is about the point where I decided that it's in my best interests to stop experimenting with things I don't grok, and ask for help.
    what is the exact mount command you're using?

  9. #509
    Join Date
    Apr 2007
    Beans
    123

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    what is the exact mount command you're using?
    Code:
    //RGONAS-01/media    /media/nas_media        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    And then simply changing the share and mount point to mount different ones.

  10. #510
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay, post the output of:
    Code:
    ls -l /media/nas_media
    ls -n /media/nas_media
    cat /etc/passwd

Page 51 of 137 FirstFirst ... 41495051525361101 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •