Page 49 of 137 FirstFirst ... 3947484950515999 ... LastLast
Results 481 to 490 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #481
    Join Date
    Jul 2007
    Beans
    277

    Re: Mount samba shares with utf8 encoding using cifs

    Interesting, thanks. I've only skimmed through it so far, but I post back if I get anywhere on a closer look.

  2. #482
    Join Date
    May 2008
    Beans
    9

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer,

    As your post is the no.1 hit on google for "ubuntu mount cifs" I thought I would add my experience as it may help someone else.

    I am using Hardy and have a dlink 323 NAS.

    When I tried the suggestions in your first post (incl. the 'nounix' part) it mounted but if I tried to copy and paste a file it would complain about permissions denied.

    Other times files would paste but I would get errors that files had not been copied successfully. Either way the file had a little lock icon on it.

    Even stranger was that I could create,delete and rename files but I could not edit a file and save the changes in gedit (though this could be a gedit problem looking at a few posts around).

    In the end what mostly fixed my problem was when I made my fstab line look like this:

    Code:
    //<NAS_IP_ADDR>/<SHARE>    /media/<MOUNT_DIR>    cifs    credentials=/root/.smbcredentials,rw,noperm,file_mode=0777,dir_mode=0777,domain=<COMPUTER NAME>  0       0
    This is the result of much googling and experimentation (all built on top of your very clear and helpful post at the beginning of this thread). I don't know what the noperm part is but without it this does not work.

    This very oddly makes it so that the shared volume is fully read/write BUT the subdirectories are all read only.

    CIFS is the most frustrating thing ever!
    Last edited by boardman; May 31st, 2008 at 09:58 AM.

  3. #483
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    thank you for your very informative post, boardman.

    i have had some limited success with a possible solution for your subdirectory ro issue.

    if you could post the output of:
    Code:
    ls -l /media/<MOUNT_DIR>/
    it could shed some light on why you cannot write to your sub directories.

  4. #484
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer thank you for referring me to your great guide, unfortunately I am a total noob to this, and after following your guide I get this error message:

    mount error 13 = Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    When I enter man mount.cifs I can't find a description what mount error 13 means and what causes it.

    I am using a Lacie Ethernet Disk and when I go to places, network, I can see the disk, as well as the windows pc.

    I tried to mount the public folder on my Vista PC with the same paramters and this works fine

    Thanks for any help,,,


    Sorry to bother you, found out the problem myself, was just a typo when entering the password for the NAS...
    Last edited by Irwin J. Finster; May 31st, 2008 at 08:32 PM.

  5. #485
    Join Date
    May 2008
    Beans
    2

    Re: Mount samba shares with utf8 encoding using cifs

    Hi,

    My problem with cifs mount is that it won't resolve netbios names. It tries to resolve using dns instead and gets the wrong addresses. I fixed this problem for smbclient by changing smb.conf to say
    name resolve order = lmhosts bcast host wins
    putting bcast before host. nmblookup works fine, and

    sudo mount -t cifs //192.168.1.149/e /mnt/whatever

    works fine, but if I replace the IP with the netbios name I get


    mount error 111 = Connection refused

    Any ideas?

  6. #486
    Join Date
    May 2008
    Beans
    9

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer,

    I tried a few things and the results are below. It does not seem to matter what I do I get pretty much the same result.

    Code:
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes but is read only. Oddly for a readonly file it can't be edited but can be deleted!
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 2 root root      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,noperm,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 2 root root      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,noperm,uid=<USERNAME>,gid=<USERNAME>,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 1 <USER> <USER>      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,uid=<USERNAME>,gid=<USERNAME>,file_mode=0777,dir_mode=0777	0	0
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 1 <USER> <USER>      0 2008-01-28 20:57 utils
    Possbily related: whenever I do anything at the commandline this pops up: unable to resolve host <COMPUTER NAME>

  7. #487
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    Sorry to bother you, found out the problem myself, was just a typo when entering the password for the NAS...
    no bother at all, i was quite asleep when you posted. glad you got it all worked out!

    Quote Originally Posted by dyerseve5867 View Post
    Hi,

    My problem with cifs mount is that it won't resolve netbios names. It tries to resolve using dns instead and gets the wrong addresses. I fixed this problem for smbclient by changing smb.conf to say
    name resolve order = lmhosts bcast host wins
    putting bcast before host. nmblookup works fine, and

    sudo mount -t cifs //192.168.1.149/e /mnt/whatever

    works fine, but if I replace the IP with the netbios name I get


    mount error 111 = Connection refused

    Any ideas?
    if you follow my howto from start to finish, you will end up with working name resolution. smb.conf ONLY handles sharing files from ubuntu to windows. it has nothing (or very little) to do with mounting windows shares on ubuntu.

    Quote Originally Posted by boardman View Post
    Hi dmizer,

    I tried a few things and the results are below. It does not seem to matter what I do I get pretty much the same result.

    Code:
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes but is read only. Oddly for a readonly file it can't be edited but can be deleted!
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 2 root root      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,noperm,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 2 root root      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,noperm,uid=<USERNAME>,gid=<USERNAME>,file_mode=0777,dir_mode=0777	0	0	
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 1 <USER> <USER>      0 2008-01-28 20:57 utils
    
    fstab line: //192.168.1.99/other	/media/toaster/other	cifs	credentials=/root/.smbcredentials,rw,nounix,uid=<USERNAME>,gid=<USERNAME>,file_mode=0777,dir_mode=0777	0	0
    Share Result: Pastes, no errors, file is read/write
    SubDir Result: Permission Denied.
    permission on subdir: drwxrwxrwx 1 <USER> <USER>      0 2008-01-28 20:57 utils
    Possbily related: whenever I do anything at the commandline this pops up: unable to resolve host <COMPUTER NAME>
    please post your /etc/hosts file, and the output of:
    Code:
    hostname
    also, you should configure your machine for windows netbios resolution so that you can mount by name instead of ip address, as that fixes many permissions problems.

  8. #488
    Join Date
    May 2008
    Beans
    9

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer.

    I tried installing netbios. Initally I skipped that step as it was all working perfectly in Gutsy. I restarted and tried your initial examples (with nounix for hardy heron) and got the same results.

    Permission denied on sub directories and either full r/w on the share folder itself or sort of read/file detail write.

    If I type 'hostname' it returns : fridge

    fridge is the name of my machine.

    I have been looking at firmware for the DNS323 and it seems there is a new firmware out. In the readme it has this:
    1. Migrate Samba from Samba 2.x to Samba 3.x to support Vista and Unicode.
    The weirdness of the error and the fact no-one else seems to be having it leads me to beleive it is a problem with the Dlink rather than

    Unfortunatly looking at the DNS323 wiki, once you go to the new firmware you cannot connect via smbfs so if cifs is still causing problems I have no fall back.

    What I intend to try is getting it working via smbfs. If that fails I'll upgrade the firmware and try cifs again. Seems strage it used to work and now does not though.

    Leslie

  9. #489
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    smbfs is not available in hardy. if you want to try smbfs, you will have to compile it from source. a better option may be for you to simply continue to use gutsy since it was working for you, and your upgrade broke. there's absolutely nothing wrong with gutsy, it's still a perfectly usable release.

    otherwise, please post the contents of:
    /etc/hosts

    do you get permission denied from all programs or just from open office?
    Last edited by dmizer; June 1st, 2008 at 12:11 PM.

  10. #490
    Join Date
    May 2008
    Beans
    9

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer. below is my /etc/hosts file.
    The MSHOME thing I think is from where I tried making my ubuntu workgroup MSHOME (which is the same windows workgroup name entered on my DNS323). I thought I had removed this in the Admin>Network gui but it seems to have stuck.

    Code:
    127.0.0.1 localhost
    127.0.1.1 fridge.MSHOME
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    I'd like to stay with Hardy as I have installed all the little bits and pieces I like, I don't want to redo all my fiddling

    There is a potential problem with upgrading the firmware which is that from reading a few forum posts etc it appears that the firmware upgrade nessesitates a reformat of the drives. I am going to ask a couple of questions on the DNS323 forum as I don't currently have enough free harddrive space to copy everything off the nas drive while I update.

    As an aside my mothers family from Hamamatsu, small planet I guess

Page 49 of 137 FirstFirst ... 3947484950515999 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •