Page 48 of 137 FirstFirst ... 3846474849505898 ... LastLast
Results 471 to 480 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #471
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    regarding changing the workgroup in server ...

    is there anything in /etc/samba/smb.conf?

    if so, change your workgroup on this line:
    Code:
    workgroup = vistaworkgrouphere
    then restart your samba server:
    Code:
    sudo /etc/init.d/samba restart
    then check the output of smbtree to see if your vista machine appears.

    edit:
    alternatively, it may be less trouble to change your vista machine to the WORKGROUP workgroup
    Last edited by dmizer; May 21st, 2008 at 02:32 AM.

  2. #472
    Join Date
    Apr 2006
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    regarding changing the workgroup in server ...

    is there anything in /etc/samba/smb.conf?

    if so, change your workgroup on this line:
    Code:
    workgroup = vistaworkgrouphere
    then restart your samba server:
    Code:
    sudo /etc/init.d/samba restart
    then check the output of smbtree to see if your vista machine appears.

    edit:
    alternatively, it may be less trouble to change your vista machine to the WORKGROUP workgroup
    well i added the ubuntu box to the right workgroup. but when i do a vdir it still is showing that it is being accessed by root. and now i'm getting an error that permission is denied. maybe my offbox rtorrent won't work so well.

  3. #473
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    when you do smbtree now, do you see the vista computer in the tree?

  4. #474
    Join Date
    Apr 2006
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    yeah the vista computer shows up now.

  5. #475
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    are you using the exact same username on both the ubuntu and vista machines?

    edit:
    also, do you have the root login enabled on the ubuntu machine?

  6. #476
    Join Date
    Apr 2006
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    are you using the exact same username on both the ubuntu and vista machines?

    edit:
    also, do you have the root login enabled on the ubuntu machine?
    i have created a specific account for rtorrent in vista with full privileges to the files tor and download. i'm not sure if the root account is enabled on my ubuntu server, i have never tried to log into root and never set a password for it that i can think of

  7. #477
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    the rtorrent account has little to do with cifs. the account you should add to your vista machine is your ubuntu user because that's the account that has to negotiate the permissions for the share.

    so, if your ubuntu user account has been added to your vista machine, and your current fstab line looks like this:
    Code:
    //NERDY/tor        /home/maddox/tor  cifs    credentials=/root/.smbcredentials,nounix,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    then about the only thing i have left to suggest to you is to look into your vista setup.
    Last edited by dmizer; May 22nd, 2008 at 02:53 AM.

  8. #478
    Join Date
    Apr 2006
    Beans
    42
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    that is kind of what i was starting to think after all that i have done with this. i didn't have any problems setting this type stuff up on xp, but vista is making this a real pain

  9. #479
    Join Date
    Jul 2007
    Beans
    277

    Re: Mount samba shares with utf8 encoding using cifs

    xoppaw - I was having a similar problem with vdir reporting the share mounted as root. I've now fixed it by adding uid=<username> to my line in fstab.

    Unfortunately this does not fix the real problem I'm having. When I try to edit a document on the smb share (using openoffice) I get:

    Error saving the document <whatever>:
    General input/output error while accessing <pathname>

    I had assumed this was a permissions issue, but it may be an openoffice problem. I just tried editing an image with GIMP and that seemed to work fine.

    Any ideas anyone?

  10. #480
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Krydahl View Post
    xoppaw - I was having a similar problem with vdir reporting the share mounted as root. I've now fixed it by adding uid=<username> to my line in fstab.

    Unfortunately this does not fix the real problem I'm having. When I try to edit a document on the smb share (using openoffice) I get:

    Error saving the document <whatever>:
    General input/output error while accessing <pathname>

    I had assumed this was a permissions issue, but it may be an openoffice problem. I just tried editing an image with GIMP and that seemed to work fine.

    Any ideas anyone?
    There is a very similar bug report open for gedit at the moment, i think you'll get helpful information from it: https://bugs.launchpad.net/gedit/+bug/34813

Page 48 of 137 FirstFirst ... 3846474849505898 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •