Page 42 of 137 FirstFirst ... 3240414243445292 ... LastLast
Results 411 to 420 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #411
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... now, try this command:
    Code:
    smbtree
    if you still only see your ubuntu machine, you probably have a firewall issue. do you have firestarter installed in ubuntu? how about the xp firewall?

    you do not need to install samba. you only need that if you want to share files from ubuntu to windows.

  2. #412
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    I see everything i need to get to:

    lucana@laptop:~$ smbtree
    Password:
    CHOPPERS
    \\MEDIA Server
    \\MEDIA\Movies2 (F)
    \\MEDIA\C$ Default share
    \\MEDIA\ADMIN$ Remote Admin
    \\MEDIA\Music (E)
    \\MEDIA\F$ Default share
    \\MEDIA\Movies1 (D)
    \\MEDIA\SharedDocs
    \\MEDIA\D$ Default share
    \\MEDIA\IPC$ Remote IPC
    \\MEDIA\E$ Default share
    \\LAPTOP Samba 3.0.26a
    \\LAPTOP\IPC$ IPC Service (Samba 3.0.26a)
    \\****
    \\****\Printer Microsoft Office Document Image Writer
    \\****\SharedDocs
    \\*****\print$ Printer Drivers
    \\*****\IPC$ Remote IPC
    lucana@laptop:~$

  3. #413
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by love2learn View Post
    Code:
    #  //192.168.1.***/Movie1    /media/Movies1       cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07$
    //MEDIA/Movies1 /media/movies1 cifs credentials=/home/lucana/.smbcredentials,uid=1000 0 0
    # ,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    okay ... the above lines just seem messed up, so just remove them.

    Quote Originally Posted by love2learn View Post
    I see everything i need to get to:

    lucana@laptop:~$ smbtree
    Password:
    CHOPPERS
    \\MEDIA Server
    \\MEDIA\Movies2 (F)
    \\MEDIA\C$ Default share
    \\MEDIA\ADMIN$ Remote Admin
    \\MEDIA\Music (E)
    \\MEDIA\F$ Default share
    \\MEDIA\Movies1 (D)
    \\MEDIA\SharedDocs
    \\MEDIA\D$ Default share
    \\MEDIA\IPC$ Remote IPC
    \\MEDIA\E$ Default share
    \\LAPTOP Samba 3.0.26a
    \\LAPTOP\IPC$ IPC Service (Samba 3.0.26a)
    \\****
    \\****\Printer Microsoft Office Document Image Writer
    \\****\SharedDocs
    \\*****\print$ Printer Drivers
    \\*****\IPC$ Remote IPC
    lucana@laptop:~$
    with the above knowledge, you should now be able to automatically mount your samba shares via fstab with the following line:
    Code:
    //MEDIA/Movies1 /media/Movies1 cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    the above should all appear on one line in fstab.

    then try this command:
    Code:
    sudo /etc/init.d/networking restart
    and see if your share gets mounted or not.

    edit:
    no need to obscure your local ip address, as it cannot resolve from the internet anyway.
    Last edited by dmizer; April 9th, 2008 at 06:59 AM. Reason: typing mistake

  4. #414
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    lucana@laptop:~$ sudo nano /etc/fstab
    [sudo] password for lucana:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=eafe81a0-359c-4f9e-8289-a2bdc8d1b196 / ext3 defaults,erro$
    # /dev/sda5
    UUID=ff38c1b7-89b0-4066-84d4-687e910a18e7 none swap sw $
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    /MEDIA/Movies1 /media/Movies1 cifs credentials=/root/.smbcredentials,iochars$

    lucana@laptop:~$ sudo /etc/init.d/networking restart
    * Reconfiguring network interfaces... [ OK ]

    lucana@laptop:~$ sudo mount -a
    mount error: improperly formatted UNC name. /MEDIA/Movies1 does not begin with \\ or //
    No ip address specified and hostname not found
    lucana@laptop:~$


    *edit*
    I also tried with this:

    //MEDIA/Movies1 /media/Movies1 cifs credentials=/root/.smbcredentials,iochars$

    but got this:

    lucana@laptop:~$ sudo /etc/init.d/networking restart
    * Reconfiguring network interfaces... [ OK ]
    lucana@laptop:~$ sudo mount -a
    Password:
    retrying with upper case share name
    mount error 6 = No such device or address
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    lucana@laptop:~$
    Last edited by love2learn; April 9th, 2008 at 07:01 AM.

  5. #415
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by love2learn View Post
    mount error: improperly formatted UNC name. /MEDIA/Movies1 does not begin with \\ or //
    No ip address specified and hostname not found
    lucana@laptop:~$
    oops i made a typing mistake ... sorry.

    edit the fstab so there are two "/" marks in front of MEDIA like so:

    Code:
    //MEDIA/Movies1 /media/Movies1 cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    then try:
    Code:
    sudo /etc/init.d/networking restart
    again

  6. #416
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    check my edit above, we must be typing at the same time

  7. #417
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    indeed it appears as though we were.

    okay ... what's the output of this:
    Code:
    ls /media
    and this:
    Code:
    ping MEDIA
    (you can stop the ping by hitting <ctrl>+c

  8. #418
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    lucana@laptop:~$ ls /media
    cdrom cdrom0 movies movies1 Movies1
    lucana@laptop:~$ ping MEDIA
    PING MEDIA (192.168.1.100) 56(84) bytes of data.
    64 bytes from 192.168.1.100: icmp_seq=1 ttl=128 time=0.788 ms
    64 bytes from 192.168.1.100: icmp_seq=2 ttl=128 time=0.888 ms
    64 bytes from 192.168.1.100: icmp_seq=3 ttl=128 time=0.797 ms
    Last edited by love2learn; April 9th, 2008 at 07:16 AM.

  9. #419
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... try this:
    Code:
    sudo aptitude install smbfs
    also this:
    Code:
    sudo mount -v /media/Movies1

  10. #420
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    couple more questions ... can you post the output of:
    Code:
    sudo cat /root/.smbcredentials
    (be sure to replace your password with stars "*")

    also, are you using opendns domain servers?

Page 42 of 137 FirstFirst ... 3240414243445292 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •