Page 41 of 137 FirstFirst ... 3139404142435191 ... LastLast
Results 401 to 410 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #401
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Bluecube View Post
    It's a Thecus n2100.
    okay ... post the output of this:
    Code:
    sudo mount -tv cifs //Cube/Video /media/Video -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777

  2. #402
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    okay, a few fixes and still the same thing. lets start with my nsswitch for netbios.

    I have this:

    hosts: files wins dns mdns4_minimal [NOTFOUND=return] dns mdns4
    networks: files

    my fstab now says this:

    //192.168.1.100/movie1 /media/music1 cifs guest

    and i have disabled my windows xp firewall.

    I still get this when trying to sudo mount -a:


    lucana@laptop:~$ sudo mount -a
    mount error 111 = Connection refused
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)


    I have also put forward routing on my router ports 137-139 as suggested for samba. ( if that matters for this application)


    any other information i can provide? I want to give you as much of a picture as you need. Thank you very much for your help.
    Last edited by love2learn; April 6th, 2008 at 04:07 PM.

  3. #403
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    i think i see something else wrong, when i go to places then network i see that it is on workgroup instead of CHOPPERS for my network. how do i change that?

  4. #404
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Okay, I got everything to work but I can't mount the drives. I am perfectly okay with that. I can just go to places > network>windows network>choppers>then whatever drive i need to get into. I am perfectly happy with this. Thanks dmizer!!

  5. #405
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i think you'll find that: "places > network > windows network > choppers" will be inadequate and too slow for most applications, but if it works for what you need power to you.

    you're really close to making this work though. all you need to do is make sure all the computers on your network are under the same workgroup. here's how:
    http://ubuntuforums.org/showpost.php...64&postcount=2

  6. #406
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    sorry I am a little thick. click on the shared folder i made in the media folder?

    ubuntu: right-click on your shared folder --> General Windows sharing settings --> (change the domain/workgroup name)

  7. #407
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by love2learn View Post
    sorry I am a little thick. click on the shared folder i made in the media folder?

    ubuntu: right-click on your shared folder --> General Windows sharing settings --> (change the domain/workgroup name)
    okay ... you indicated that one computer in your network was not in the same workgroup as the rest. what os is that computer running?

  8. #408
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    the Ubuntu 7.10 laptop is on the original 'workgroup' and i need to get it to CHOPPERS instead.

  9. #409
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... edit /etc/samba/smb.conf like so:
    Code:
    sudo nano /etc/samba/smb.conf
    look for the section that reads:
    Code:
    # Change this to the workgroup/NT-domain name your Samba server will part of
       workgroup = workgroup
    change it so it reads:
    Code:
    # Change this to the workgroup/NT-domain name your Samba server will part of
       workgroup = CHOPPERS
    and restart samba:
    Code:
    sudo /etc/init.d/samba restart
    this should put your ubuntu computer in the workgroup of CHOPPERS.

  10. #410
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    phew, this is a difficult learning curve for me. I am so used to windows it is hard to grasp. But I am here for life and I cant go back so here it goes:

    I checked my smb.conf and there is absolutely Nothing
    in there. Totally blank. I did however go to system>admin>network>wireless config and in general put in CHOPPERS for the workgroup and now when i go into natilus I see my 2 laptops and my server which means I am on the CHOPPERS network.

    Here is the latest look at my fstab pay no attention to the # sections of course

    # //192.168.1.***/Movie1 /media/Movies1 cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 $
    //MEDIA/Movies1 /media/movies1 cifs credentials=/home/lucana/.smbcredentials,uid=1000 0 0
    # ,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

    I know it is a mess but i have tried multiple combinations to attempt a successful mount.

    according to this guide:

    https://help.ubuntu.com/community/SettingUpSamba

    it says:
    Do you need Samba?

    Samba is not necessary to:
    • Access shared folders, drives and printers on a Windows computer (that is, act as a client with Windows servers), you only need a smbfs plugin. See MountWindowsSharesPermanently

    so maybe you can help me understand why i need a samba config file in the first place and I can get past this mental block?
    I am sorry I am so thick-headed, I just want a full understanding of what I am doing.

Page 41 of 137 FirstFirst ... 3139404142435191 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •