Page 40 of 137 FirstFirst ... 3038394041425090 ... LastLast
Results 391 to 400 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #391
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by rkillcrazy View Post
    Yes, but what about the credentials? DO I just omit that line or is there something that must be used instead?

    03-31-08
    1353 EST
    the line for mounting shares without password protection is given in the howto.

  2. #392
    Join Date
    Jun 2006
    Beans
    11

    Lightbulb Re: Mount samba shares with utf8 encoding using cifs

    Hey guys,

    the last few days I was struggling with the same problem, you seem to have. Samba access to my landisk wasn't working at all since the upgrade to hardy. With gutsy everything worked fine. Seem to be issues related to the 3.x version of samba and cifs replacing smbfs.

    So here is my solution:

    To get the authentification work at all (mounting share through Nautilus) I had to add this line to my /etc/samba/smb.conf:

    client lanman auth = Yes

    My Landisk can only use the insecure lanman authentification, which is disabled by default in samba 3.x (same problem with vista by the way, http://www.builderau.com.au/blogs/co...tm?p=339270746). I don't know if this applies to your problem.

    Then mounting with Nautilus worked. But when trying cifs, I got the "not a directory"-error. Solution is simple and nowhere to be found and not very breathtaking. You have to add the option

    nounix

    to the mount - command. Which leads (in my case) to these lines:

    sudo mount -t cifs //192.168.1.42/PUBLIC /media/marvin -o nounix,credentials=/home/fruchtschwert/.smbcredentials,uid=1000,gid=1000

    and for the fstab:

    //192.168.1.42/PUBLIC /media/marvin cifs user,nounix,credentials=/home/fruchtschwert/.smbcredentials,uid=1000,gid=1000 0 0

    Hope this can set an end to your neverending thread

    Cheers
    Last edited by fruchtschwert; April 2nd, 2008 at 10:37 PM.

  3. #393
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by fruchtschwert View Post
    <snip>
    nounix

    to the mount - command. Which leads (in my case) to these lines:

    Code:
    sudo mount -t cifs //192.168.1.42/PUBLIC /media/marvin -o nounix,credentials=/home/fruchtschwert/.smbcredentials,uid=1000,gid=1000
    and for the fstab:

    Code:
    //192.168.1.42/PUBLIC   /media/marvin   cifs   user,nounix,credentials=/home/fruchtschwert/.smbcredentials,uid=1000,gid=1000   0   0
    Hope this can set an end to your neverending thread

    Cheers
    lol ... i don't have that kind of luck.

    where did you get that option from? it's not a legal cifs or smbfs mount option, which means this may not be a lasting solution.

  4. #394
    Join Date
    Jun 2006
    Beans
    11

    Unhappy Re: Mount samba shares with utf8 encoding using cifs

    hm .. i'm sorry ! Samba can be frustrating ..

    Found it while googling .. here

    http://lists.samba.org/archive/linux...er/002469.html

    and for the exact description I found this:

    http://kernel.org/pub/linux/kernel/p...git-cifs.patch

    + nounix Disable the CIFS Unix Extensions for this mount (tree
    + connection). This is rarely needed, but it may be useful
    + in order to turn off multiple settings all at once (ie
    + posix acls, posix locks, posix paths, symlink support
    + and retrieving uids/gids/mode from the server) or to
    + work around a bug in server which implement the Unix
    + Extensions.

  5. #395
    Join Date
    Dec 2007
    Location
    Brighton, United Kingdom
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Talking Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    see the last link in my sig for the howto on mounting nfs shares

    as to mounting different shares for different users ... i've yet to get around to that.
    Apos for the long wait. Was meant to post much earlier, but had a lot on.

    Essentially, using your guide this was a no-brainer. Got (most of-) all the stuff moved over to the NAS now.

    That said, it did crap out on me twice while moving over 3668 or so music files, so even NFS is not completely reliable. But when it did crap out, it did not take the OS down with it.

    Many many thanks, dmizer.

  6. #396
    Join Date
    Feb 2007
    Beans
    50

    Re: Mount samba shares with utf8 encoding using cifs

    I'm having a hell of a time here trying to get my shares to automount. I've followed the instructions on this thread and a load of others with no joy so I'm totally stumped as to what my problem is. Here's the entries from my fstab file -

    //Cube/Craig /media/Craig cifs auto,iocharset=utf8,uid=craig,gid=users,credential s=/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0

    //Cube/Music /media/Music cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77,auto 0 0
    //Cube/Video /media/Video cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77,auto 0 0
    //Cube/Pictures /media/Pictures cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77,auto 0 0
    //Cube/General /media/GeneralFiles cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77,auto 0 0

    As can be seen from above I'm trying to connect to a NAS called Cube. The first share is password protected while the other three are open to all. None will automount even when I use the IP address in place of the NAS name.

    The shares are accessible through the Nautilus network browser and Connect to Server function. Indeed I can add them as Bookmarks. So why can't I automount them?!? This is very frustrating so any help will be gratefully received. TIA.

  7. #397
    Join Date
    Feb 2006
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    okay, went through the walkthrough and got this:

    lucana@laptop:~$ sudo mount -a
    mount error 111 = Connection refused
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)


    lucana@laptop:~$ smbtree
    Password:
    WORKGROUP
    \\LAPTOP Samba 3.0.26a
    \\LAPTOP\IPC$ IPC Service (Samba 3.0.26a)
    lucana@laptop:~$


    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=eafe81a0-359c-4f9e-8289-a2bdc8d1b196 / ext3 defaults,erro$
    # /dev/sda5
    UUID=ff38c1b7-89b0-4066-84d4-687e910a1o8e7 none swap sw $
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    //192.168.1.100/d/movie1 /media/music1 cifs guest,rw,iocharset=utf$


    I should offer a bit more info. I have a ubuntu 7.10 gutsy laptop that is the client ( wireless connection ) I have XP (wired to same wireless router as ubuntu) used as a file server with 1.5 TBs of information across 4 drives.
    C:\
    D:\Movies1
    E:\Music
    F:\Movies2

    my server netbios name = Media
    Workgroup = CHOPPERS


    I am lost please help
    Last edited by love2learn; April 6th, 2008 at 12:33 PM.

  8. #398
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Bluecube View Post
    As can be seen from above I'm trying to connect to a NAS called Cube.
    what NAS device do you have? make and exact model number please.

  9. #399
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by love2learn View Post
    okay, went through the walkthrough and got this:


    Code:
    //192.168.1.100/d/movie1    /media/music1        cifs    guest <snip>
    possible problem one:
    are you positive that your share name is "d"?

    definite problem two:
    you cannot mount a directory within a share.
    so this is a valid mount command providing "d" is indeed the share name of your shared folder:
    Code:
    //192.168.1.100/d   /media/music1        cifs     guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    here's how to determine your share name in windows:
    Quote Originally Posted by dmizer View Post
    To find the share name in Windows xp:
    • Right click on the shared folder and select "properties", and click on the tab that says "sharing".

      The share name is listed under "network sharing and security" next to "share name".
    since you did not setup netbios name resolution with winbind and nsswitch, you cannot see the netbios name and sharename from your ubuntu computer with the "smbtree" command. so you can try to include netbios name resolution by following the directions under "pre-work".

    also ... don't forget to check your firewall on winXP to make sure that local filesharing is allowed through.

  10. #400
    Join Date
    Feb 2007
    Beans
    50

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    what NAS device do you have? make and exact model number please.
    It's a Thecus n2100.

Page 40 of 137 FirstFirst ... 3038394041425090 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •