Page 35 of 137 FirstFirst ... 2533343536374585135 ... LastLast
Results 341 to 350 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #341
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Paqman View Post
    to the line, but when I "mount -a" it spits it out as an error. Is my syntax wonky, or am I way off track here?
    what error do you get? this could be a problem with the way that samba is served on your NAS device.

    ========================

    Quote Originally Posted by abubin View Post
    Here is what I typed to mount :

    sudo mount -t cifs //192.168.10.32/Volume_1 /mnt/mynas2 -o rw,username=user111,password=pass111
    in order to connect with correct permissions, you will need to mount with the file and directory modes like so:
    Code:
    sudo mount -t cifs //192.168.10.32/Volume_1 /mnt/mynas2 -o rw,username=user111,password=pass111,file_mode=0777,dir_mode=0777
    you'll also have better luck if you mount with fstab instead of the command line. "sudo" means you're mounting as root, so it does mess with permissions.

    ========================

    Quote Originally Posted by Dan_N View Post
    The problem might have to do with NAS only supporting Samba 2.x, http://forum.dsmg600.info/t539-Swedi...rom-linux.html
    //Dan
    well, the problem is certainly related to the nas device rather than cifs. during testing, i could mount regular windows hosted samba shares with cifs and unicode and was able to view the sweedish characters just fine.

    looks like there are some updates to the thread which indicated that you can fix the problem by disabling easy search?
    Languange settings cannot be changed in EasySearch using 1.04. This could only be done downgrading firmware to 1.03 which I didn't like. I presume 1.04 supports UTF8 after all(?). So I dropped that alternative and tried to get it right with 1.04 without using EasySearch.
    ========================

    Quote Originally Posted by a_posse_ad_esse View Post
    Code:
    parsing options: credentials=x mount.cifs kernel mount options unc=//192.168.2.4\home,ip=192.168.2.4,user=tim,pass=x,ver=1,credentials=/sync/credentials/tim/laptop/home,prefixpath=tim
    mount error 13 = Permission denied
    The IP is correct and can be pinged, and both files are appropriately shared. I don't get it... Any suggestions? Thanks
    post the contents of your credential file. mask username and password with **** or similar (if you're concerned about security).

    if your network is dhcp, you may not be able to mount with an ip address. see the section in the howto under "prework" as well as the second post in the thread regarding how to find netbios names.

    on dhcp networks, i have run into this error when trying to mount with ip instead of mounting with netbios name.
    Last edited by dmizer; November 20th, 2007 at 03:24 AM.

  2. #342
    Join Date
    Jul 2007
    Beans
    3

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for the howto it worked great. I needed to add a couple of tweaks here and there for my network, but other then that it worked great.

  3. #343
    Join Date
    Dec 2007
    Beans
    21

    Re: Mount samba shares with utf8 encoding using cifs

    Hi guys,

    I've been a Fedora bloke for quite some time, and finally snapped over to Ubuntu, I've currently running 7.10 and have this issue I would love some info on...

    I have a Fedora server running samba, I have had this for several years and been using winXP to connect to my shares without any trouble in shared mode without user auth.

    Now I have an Ubuntu desktop machine if I use the built in Places/Connect to a server option I can connect and read and write to the share I have (which is a share without any username or password) without trouble. That is; this path works: smb://hanna/hanna_d/Mp3s

    If I then mount the path using this:
    mount -t cifs //hanna/hanna_d /mnt/hanna/j_drive -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=07 77

    It mounts ok, I can read everything from the new mounted point, but if I create a directory, I then can't delete the directory I just made. If i then go in this way -> smb://hanna/hanna_d/ I can then delete the folder and read and write fine, just not to the actual mounted location /mnt/hanna/j_drive.

    I know it's some permissions thing, but I would like to know how the smb: method avoids this, and how I can get my shares to mount with full read write access.

    Thanks for any help.

    Bj

  4. #344
    Join Date
    Nov 2005
    Beans
    15

    Re: Mount samba shares with utf8 encoding using cifs

    I found your tutorial after about 3 hours of hair pulling, teeth clinching, and obscenity laced web searching...
    Your directions were easy to follow and in the end every thing worked. I wanted to say,
    THANK YOU!

    now I am going to bed....

  5. #345
    Join Date
    Nov 2005
    Location
    Sydney, Australia
    Beans
    216
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mount samba shares with utf8 encoding using cifs

    I followed the first part of your guide up to 'Manual Mount' and all went well, but I cannot get 'Permanent Mount' to work. Here is a copy of my FSTAB and I would appreciate any suggestions:

    /etc/fstab: static file system information.
    #
    # -- This file has been automaticly generated by ntfs-config --
    #
    # <file system> <mount point> <type> <options> <dump> <pass>

    proc /proc proc defaults 0 0
    # Entry for /dev/hda5 :
    UUID=9f123026-fafc-4ffc-8279-a5fd7eeba0a5 / ext3 defaults,errors=remount-ro 0 1
    # Entry for /dev/hda1 :
    UUID=24F4B62EF4B6025A /media/hda1 ntfs-3g defaults,locale=en_AU.UTF-8 0 1
    # Entry for /dev/hda3 :
    UUID=14203FD2203FB996 /media/hda3 ntfs-3g defaults,locale=en_AU.UTF-8 0 1
    # Entry for /dev/hda6 :
    UUID=CA246D23246D142B /media/hda6 ntfs-3g defaults,locale=en_AU.UTF-8 0 1
    # Entry for /dev/sda1 :
    UUID=02505FF0505FE945 /media/sda1 ntfs-3g defaults,locale=en_AU.UTF-8 0 1
    # Entry for /dev/sda5 :
    UUID=13D61B93DEF50771 /media/sda5 ntfs-3g defaults,locale=en_AU.UTF-8 0 1

    # Entry for /dev/hda7 :
    UUID=f6b50d1f-8037-4c8c-b858-15a21f42bc46 none swap sw 0 0
    # Entry for /dev/sda6 :
    UUID=3e2dfddd-5548-7a88-2420-b67970126ad9 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    # Added for HP-LAPTOP
    //HP-LAPTOP/Public /media/HP-Laptop cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777
    Just think how boring life would be without Ubuntu

  6. #346
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i don't see anything wrong with it. what was the line you used for your manual mount?

    have you tried rebooting?

  7. #347
    Join Date
    Nov 2005
    Location
    Sydney, Australia
    Beans
    216
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mount samba shares with utf8 encoding using cifs

    sudo mount -t cifs //HP-Laptop/Public /media/HP-Laptop -o username=david,password=xxxxxxxx,file_mode=0777,di r_mode=0777

    This works fine and I have tried rebooting
    Just think how boring life would be without Ubuntu

  8. #348
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    please post the output of the following:
    Code:
    smbtree
    and
    Code:
    cat /etc/samba/smb.conf | grep netbios&& cat /etc/samba/smb.conf | grep workgroup
    also, double check your credentials file to make sure there are no spaces before or after the equal ( = ) sign.

  9. #349
    Join Date
    Nov 2005
    Location
    Sydney, Australia
    Beans
    216
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mount samba shares with utf8 encoding using cifs

    david@david-desktop:~$ smbtree
    WARNING: The "printer admin" option is deprecated
    Password:

    BAYVISTA
    \\HP-LAPTOP
    \\HP-LAPTOP\Users
    \\HP-LAPTOP\Send To OneNote 2007 Send To OneNote 2007
    \\HP-LAPTOP\Public
    \\HP-LAPTOP\print$ Printer Drivers
    \\HP-LAPTOP\IPC$ Remote IPC
    \\HP-LAPTOP\E$ Default share
    \\HP-LAPTOP\Documents
    \\HP-LAPTOP\D$ Default share
    \\HP-LAPTOP\C$ Default share
    \\HP-LAPTOP\ADMIN$ Remote Admin
    \\DAVID-DESKTOP
    \\DAVID-DESKTOP\DeskJet-960C DeskJet-960C
    \\DAVID-DESKTOP\PSC-2300 PSC-2300
    \\DAVID-DESKTOP\IPC$ IPC Service (david-desktop server (Samba, Ubuntu))
    \\DAVID-DESKTOP\Davids Docs davids docs folder
    \\DAVID-DESKTOP\backups backup folder
    \\DAVID-DESKTOP\print$ Printer Drivers
    david@david-desktop:~$

    david@david-desktop:~$ cat /etc/samba/smb.conf | grep netbios&& cat /etc/samba/smb.conf | grep workgroup
    # on a per machine basis. The %m gets replaced with the netbios name
    # Change this to the workgroup/NT-domain name your Samba server will part of
    workgroup = BAYVISTA
    david@david-desktop:~$

    No spaces in my .smbcredentials file
    Just think how boring life would be without Ubuntu

  10. #350
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    looks like you have everything set up correctly. having trouble figuring out what your problem might be, and why it works manually but not with fstab.

    try this

    as root (sudo), add this line:
    Code:
    mount /media/HP-Laptop
    before "exit 0" in the file /etc/rc.local

    reboot, and see if your share is mounted then. if not, please post the output of:
    Code:
    dmesg
    please enclose the dmesg output in [code] brackets so formatting is preserved.

Page 35 of 137 FirstFirst ... 2533343536374585135 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •