Page 30 of 137 FirstFirst ... 2028293031324080130 ... LastLast
Results 291 to 300 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #291
    Join Date
    May 2007
    Location
    Stockholm, Sweden
    Beans
    4
    Distro
    Kubuntu 7.04 Feisty Fawn

    Smile Re: Mount samba shares with utf8 encoding using cifs

    FYI
    I wrote the post at the end a while back, and today a solved the problem.
    I added the noperm option to my mount line, good or not, now it works.
    Excerpt from man mount.cifs:
    noperm
    Client does not do permission checks. This can expose files on this
    mount to access by other users on the local client system. It is
    typically only needed when the server supports the CIFS Unix Exten‐
    sions but the UIDs/GIDs on the client and server system do not match
    closely enough to allow access by the user doing the mount. Note
    that this does not affect the normal ACL check on the target machine
    done by the server software (of the server ACL against the user name
    provided at mount time).
    Quote Originally Posted by trixon View Post
    I'm using Kubuntu 7.04 connected to a WesternDigital MyBook World Edition NAS.

    It mounts, but I get problems with writing to the NAS.
    If I do a smbfs mount, I get full access, but it is too slow to use.

    fstab line:
    \\192.168.0.99\public /media/pub cifs credentials=/etc/fstab_smb_credentials_1,iocharset=utf8,file_mode=0 777,dir_mode=0777,uid=1000,gid=1000 0 0

    I get rw-access to files and directories in the root (not user root) /media/pub, but not to the subobjects.

    For /media/pub:
    drwxrwxr-x 8 root www-data 0 2007-05-12 11:29 pub
    And for ALL subobjects to /media/pub
    drwxr-xr-x 7 www-data www-data 0 2007-05-05 11:29 music

    I have added myself to the group www-data, but that only gave me rw to the first level of /media/pub.

    I've tried some chmod and chowns, as sudo, but the result is things like this:
    chown: changing ownership of `music': Permission denied

    Anyone?

  2. #292
    Join Date
    Jan 2007
    Beans
    59
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for this guide. It has proved to be a much better way for me to access my linkstation pro without any nasty timeouts. Great

    Thanks

  3. #293
    Join Date
    Aug 2007
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    I am trying to migrate from smbfs to cifs so I followed the instructions changing in fstab, this line:
    //netbiosname/share /mnt/dir smbfs auto,user,owner,guest 0 0
    to this line:
    //netbiosname/share /mnt/dir cifs guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

    I had a wrong IP resolution message, so the first thing I had to add is an ip= option in the cifs line (or add an entry in hosts file).

    Then I got a "mount error 20: not a directory" and this is a wall

    Any idea?

  4. #294
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    please post the EXACT fstab line with your actual netbios name and share name, as well as your actual mount directory path.

    also post the output of:
    Code:
    smbtree

  5. #295
    Join Date
    Aug 2007
    Beans
    10
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    I have a fun little problem.

    The share mounts automatically, but the owner is "500", not root. I can't edit permissions or access the drive. Where did I go wrong?

  6. #296
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    the samba server you're trying to connect to ... is it a windows server, or a linux samba server?

    are you able to access the same share from another computer (linux or windows)?

  7. #297
    Join Date
    Aug 2007
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    fstab:
    //NAS-300GB/DATOS /media/NAS cifs user,guest,ip=192.168.1.9,iocharset=utf8,file_mode =0777,dir_mode=0777 0 0

    smbtree:
    TRAUMA
    \\PORTATIL-JOSE portatil-jose server (Samba, Ubuntu)
    \\PORTATIL-JOSE\IPC$ IPC Service (portatil-jose server (Samba, Ubuntu))
    \\PORTATIL-JOSE\print$ Printer Drivers
    \\NAS-300GB
    \\NAS-300GB\IPC$
    \\NAS-300GB\DATOS
    \\NAS-300GB\MEDIA
    \\NAS-300GB\PUBLIC

    NAS-300GB is a Conceptronic CHD3LAN. No permissions stablished in it. Firmware upgraded to NAS-BASIC47 ...and still

  8. #298
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    try this:
    Code:
    //192.168.1.9/DATOS /media/NAS cifs user,guest,iocharset=utf8,file_mode =0777,dir_mode=0777 0 0

  9. #299
    Join Date
    Aug 2007
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Mount error 20 = not a directory



    PS: Ubuntu 7.04

  10. #300
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    post the output of this command:
    Code:
    sudo mount -t cifs //192.168.1.9/DATOS /media/NAS --verbose -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
    also, do you have iptables (firewall) configured via a gui of some kind like firestarter or shorewall?

Page 30 of 137 FirstFirst ... 2028293031324080130 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •