Page 3 of 137 FirstFirst 123451353103 ... LastLast
Results 21 to 30 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #21
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    actually, the file names on the samba server i have at work are already utf-8 encoded, but nautilus couldn't read them, and couldn't copy them correctly. this is why i was so happy to discover cifs with the utf8 option. same was true for smbfs ... couldn't read the shares that were created by the windows 2000 server.

  2. #22
    Join Date
    Mar 2006
    Location
    Toronto, Canada
    Beans
    855

    Re: Mount samba shares with utf8 encoding using cifs

    Oh, I see. A user may then want to convert from UTF-8 to another Japanese encoding to make browsing possibly easier.

    Anyway sorry for the hijack.

    And now back to our regularly scheduled program...

  3. #23
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    it's no problem ... i've always wanted to know how to convert encodings. but i realized it was going to be easier for me to mount the file system this way than to try to convert our network full of pobkac users.

  4. #24
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    [Bowing reverently]

    This is exactly the kind of clarification I needed!! Yes, I was on the wrong track in terms of my understanding of what the mount/fstab commands were trying to accomplish...

    Quote Originally Posted by dmizer View Post
    okay ... let's try this, just post the output of:
    Code:
    smbtree
    and we'll try to customize the line for your specific application, because essentially you have 4 separate systems you may desire to share files to and from.
    OK. Both machines are booted into Ubuntu, and here's what my smbtree just displayed:

    me@AMD-64:~$ smbtree
    Password:
    HOME
    \\DELL-UBUNTU Samba 3.0.22
    timeout connecting to 208.**.***.40:445
    timeout connecting to 208.**.***.40:139
    Error connecting to 208.**.***.40 (Operation already in progress)
    cli_start_connection: failed to connect to DELL-UBUNTU<20> (208.**.***.40)
    \\AMD-64
    Error connecting to 127.0.1.1 (Connection refused)
    cli_start_connection: failed to connect to AMD-64<20> (127.0.1.1)
    me@AMD-64:~$
    (Those ip's made me nervous...so I asterisked out some of the numbers)

    I'm off to work here soon; I'll check in tonight and see what I can get working! Thanks again for all the hand-holding!

    [Edit] There is a D-Link router that connects the two machines--will that be a possible issue re connectivity? (It wasn't under Dapper when I was just going through Nautilus to access the other machine...)
    Last edited by wilberfan; November 7th, 2006 at 05:23 PM.
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  5. #25
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    no problem to sensor your ip's. but since your shares are password protected (good for you), i can't see the share name, so you'll still have to provide that for me.

    you said you used stormbringers guide to configure your samba server. so tell me this. in the smb.conf file (gksudo gedit /etc/samba/smb.conf) on your dell-ubuntu, take a look at what you have in the place of the section from stormbringers guide that looks like this:
    Code:
    [MyFiles]
        path = /media/samba/
        browseable = yes
        read only = no
        guest ok = no
        create mask = 0644
        directory mask = 0755
        force user = YOUR_USERNAME
        force group = YOUR_USERGROUP
    you don't actually have to include your username or group, just so that i have what's in brackets at the top. ie: "[myfiles]", then do the same for your amd-64 box.

    also, you shouldn't need to worry about configuring your router at all.
    Last edited by dmizer; November 8th, 2006 at 01:50 AM.

  6. #26
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    no problem to sensor your ip's. but since your shares are password protected (good for you), i can't see the share name, so you'll still have to provide that for me.

    you said you used stormbringers guide to configure your samba server. so tell me this. in the smb.conf file (gksudo gedit /etc/samba/smb.conf) on your dell-ubuntu, take a look at what you have in the place of the section from stormbringers guide that looks like this:
    Code:
    [MyFiles]
        path = /media/samba/
        browseable = yes
        read only = no
        guest ok = no
        create mask = 0644
        directory mask = 0755
        force user = YOUR_USERNAME
        force group = YOUR_USERGROUP
    you don't actually have to include your username or group, just so that i have what's in brackets at the top. ie: "[myfiles]", then do the same for your amd-64 box.

    also, you shouldn't need to worry about configuring your router at all.

    Great!

    Here's the section from the Dell box:

    [MyFiles]
    path = /home/dell-share
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = mydellsigninname
    force group = mydellsigninname
    Here's the AMD-64 box:

    [MyFiles]
    path = /media/samba/
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = myAMDsigninname
    force group = myAMDsigninname
    I just tried this mount command (which gave me zero results):

    sudo mount -t cifs //DELL-Ubuntu/dell-share /media/samba -o user=mydellsigninname,password=********,iocharset= utf8,file_mode=0777,dir_mode=07
    I'm still getting smbtree weirdness, too:

    me@AMD-64:~$ smbtree
    Password:
    HOME
    \\DELL-UBUNTU Samba 3.0.22
    timeout connecting to 208.**.***.40:445
    timeout connecting to 208.**.***.40:139
    Error connecting to 208.67.219.40 (Operation already in progress)
    cli_start_connection: failed to connect to DELL-UBUNTU<20> (208.**.***.40)
    \\AMD-64
    Error connecting to 127.0.1.1 (Connection refused)
    cli_start_connection: failed to connect to AMD-64<20> (127.0.1.1)
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  7. #27
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    the samba tree is timing out because the password it's asking for is the password on the remote computer. it's trying to connect, but it's getting denied because you didn't type in the correct password and/or username. this is perfectly normal.

    a couple of things. first, you don't want to mount your remote computer's shares in the same directory as your local computer's shared files (in your case /mount/samba), so give them a new folder so you won't get your computer or yourself confused as to which computer the files are on:
    Code:
    sudo mkdir /mount/MyFiles
    okay, second ... the "sharename" is what's in brackets [sharename] in your smb.conf files. so in both cases, your sharename is going to be MyFiles.

    so, your manual mount line for the dell will look like so:
    Code:
    sudo mount -t cifs //AMD-64/MyFiles /media/MyFiles -o user=youramdsigninname,password=********,iocharset= utf8,file_mode=0777,dir_mode=0777
    your fstab line for your amd will look like this:
    Code:
    sudo mount -t cifs //DELL-UBUNTU/MyFiles /media/MyFiles -o user=yourdellsigninname,password=********,iocharset= utf8,file_mode=0777,dir_mode=0777
    in both cases, you can change "MyFiles" to whatever you like as long as it maches what's in [] in the smb.conf of the computer you are trying to connect to. or IOTW, fstab on local must equal smb.conf on remote
    Last edited by dmizer; November 9th, 2006 at 12:03 AM.

  8. #28
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    Bare with me; I'm almost there (I think!)...

    Quote Originally Posted by dmizer View Post
    the samba tree is timing out because the password it's asking for is the password on the remote computer. it's trying to connect, but it's getting denied because you didn't type in the correct password and/or username.
    That just seems impossible...at this point I only HAVE one password (I'm using it everywhere on both systems until I learn what I'm doing more thoroughly. But let's put that aside for awhile and move on...

    a couple of things. first, you don't want to mount your remote computer's shares in the same directory as your local computer's shared files (in your case /mount/samba), so give them a new folder so you won't get your computer or yourself confused as to which computer the files are on.

    okay, second ... the "sharename" is what's in brackets [sharename] in your smb.conf files. so in both cases, your sharename is going to be MyFiles.
    I think for me, using the same name to refer to two different things (or the same thing in two different places) may get confusing. So here's what I've done at this point: Here's the new smb.conf from AMD-64:

    [AMD-64Files]
    path = /media/samba/
    browsable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = amd64signinname
    force group = amd64signinname

    And here's the DELL-Ubuntu smb.conf:

    [DellFiles]
    path = /home/dell-share
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = dellsigninname
    force group = dellsigninname

    so, your fstab line for the dell will look like so:

    Code:
    sudo mount -t cifs //AMD-64/MyFiles /media/MyFiles -o user=youramdsigninname,password=********,iocharset= utf8,file_mode=0777,dir_mode=0777
    your fstab line for your amd will look like this:
    Code:
    sudo mount -t cifs //DELL-UBUNTU/MyFiles /media/MyFiles -o user=yourdellsigninname,password=********,iocharset= utf8,file_mode=0777,dir_mode=0777
    in both cases, you can change "MyFiles" to whatever you like as long as it maches what's in [] in the smb.conf of the computer you are trying to connect to. or IOTW, fstab on local must equal smb.conf on remote
    Technically, those are MANUAL mount commands, yes? Wouldn't the fstab entry look slightly different?

    OK, here's a good place to stop and make a request: I can see now that the reason I'm struggling with this, is that I don't completely understand what each part of the 'mount' command (or the fstab version when we get to that!) represents. I desperately appreciate you walking me through it, but it's not going to MAKE SENSE until I understand what it is I'm entering when I use that command.

    For example, if I'm on my AMD machine and want to connect to the DELL:

    mount ...This seems obvious

    -t ...I don't know what this is, but it's easy enough to just put it there, so, no prob...

    cifs invoking the cifs system, probably

    //DELL-Ubuntu This is the machine (technically the Net-bios name?) for the 'remote' machine (the machine I want to connect TO)?

    /XXXXXX This must be the folder specified in the smb.conf of the remote machine (DELL)?? The folder that I want to be able to access from the LOCAL (AMD) machine? It is into this folder that I will place things I want to 'share', yes?

    media/ Now, this the point on the LOCAL machine (AMD) where I want to 'mount' or 'attach' the folder specified in the previous parameter?

    XXXXXX Again, the folder within the previous directory? (In my case would this be /media/samba ?)

    -o Whatever

    user=remotesigninname,

    password=remotepassword,

    iocharset= utf8, Something to do with English?

    file_mode=0777, File permissions (read/write)?

    dir_mode=0777 Again, read-write permissions?

    So, my manual mount command (I'm not ready for the fstab one yet!) to connect TO the DELL-Ubuntu machine FROM the AMD-64 SHOULD look like this??:

    Code:
    sudo mount -t cifs //DELL-Ubuntu/DellFiles /media/samba -o user=dellsignin,password=dellpswd,iocharset= utf8,file_mode=0777,dir_mode=0777
    But when I tried it, I just get a sad little blinking cursor in my terminal window...



    Last edited by wilberfan; November 8th, 2006 at 06:04 PM.
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

  9. #29
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    sounds like you have the hang of things. but in your manual mount command that you posted though, you have a space after iocharset= so it looks like "iocharset= utf8" but there should be no space there: "iocharset=utf8".

    but in reality, you don't really NEED this option unless you have files with characters other than english. it doesn't hurt to have it, but it also won't hurt to leave it in.

    -t means mount as Type cifs
    -o means "options"

    the rest you seem to understand fairly well.

    but there's also another problem that may be causing you issues. when you mount your shared files, you will have to place them in an EMPTY directory. according to your amd-64 smb.conf, your amd samba shared files are in /media/samba. so when you mount your dell's shares, you will have to give them a new empty directory to mount in other than /media/samba

    so, be sure to make a new directory in /media on the amd-64 box.

    edit: despite the fact that you seem to grasp this anyway, better safe than sorry, so one more thing ...
    Quote Originally Posted by wilberfan View Post
    //DELL-Ubuntu This is the machine (technically the Net-bios name?) for the 'remote' machine (the machine I want to connect TO)?

    /XXXXXX This must be the folder specified in the smb.conf of the remote machine (DELL)?? The folder that I want to be able to access from the LOCAL (AMD) machine? It is into this folder that I will place things I want to 'share', yes?
    yes and no to your second point. this is a small, but important distinction. this should be what your remote computer calls the share on the network. ie: share name. it can be different than the name of the folder your files are in, as is the case with your situation for example. your smb.conf looks like this:
    Code:
    [AMD-64Files]
        path = /media/samba/
        browsable = yes
        read only = no
        guest ok = no
        create mask = 0644
        directory mask = 0755
        force user = amd64signinname
        force group = amd64signinname
    note, the files you want access to are in /media/samba, but it's called AMD-64Files on the network.
    Last edited by dmizer; November 9th, 2006 at 01:55 AM.

  10. #30
    Join Date
    Jul 2006
    Location
    Southern California
    Beans
    494
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    OK, I did a

    Code:
    sudo mkdir /media/MyFiles
    (And there's nothing in that directory...there was nothing in the /media/samba one either...)

    Then tried this mount command:

    Code:
    me@AMD-64:~$ sudo mount -t cifs //DELL-Ubuntu/dell-share /media/MyFiles -o user=dellsignin,password=dellpasswd,iocharset=utf8,file_mode=0777,dir_mode=0777
    ...and still just get a blinking cursor...
    "He who lives by the penguin, dies by the penguin."
    (at least 'till he figures out what he's doing!)

Page 3 of 137 FirstFirst 123451353103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •