Page 27 of 137 FirstFirst ... 1725262728293777127 ... LastLast
Results 261 to 270 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #261
    Join Date
    May 2007
    Location
    Brisbane AU
    Beans
    14
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Thank you for your question Dmizer re VMware. I believe I don't have it, the only closest thing to virtual OS is my Wine install.

  2. #262
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    vk4ebp ... gm es hello.

    i finally had this happen to my test machine the other night. the only thing different was that i disconnected the lan cable before i shut the machine down. i'll do some more testing if i have time today.

    73 sk ee

  3. #263
    Join Date
    May 2007
    Location
    Brisbane AU
    Beans
    14
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer, re the shutdown error:
    My LAN cables remain connected to all three Kubu machines when I get the error. When not connected, the Samba share naturally does not mount and there is no errors on shutdown.
    mni tnx es 73 de vk4ebp tu e e

  4. #264
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... i'm still coming up empty for this one. this is a bug. anyone experiencing this issue, please post a bug https://bugs.launchpad.net/ and link it to this thread please.

  5. #265
    Join Date
    May 2007
    Location
    Brisbane AU
    Beans
    14
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer, guess what....
    I have changed the distro on one of my machines from kubuntu to ubuntu and the bug dossappeared. This may sound like a silly question from a newb, but is it possible that system with KDE handles network differently to Gnome? (btw the reason for change was an unrelated display problem with an ATI card).

  6. #266
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i had it happen at least once in xubuntu, but as stated before ... it was a result of having the network cable disconnected. though xubuntu does carry some of the kde libs so it's still possible. i'll test directly to kde (i don't normally use it) tomorrow. thanks for the tip though.

    everyone else experiencing this bug using kde?

  7. #267
    Join Date
    Mar 2007
    Location
    Aus
    Beans
    264
    Distro
    Kubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    just wanna say thanks for the great how to! worked great for me! (kubuntu 7.04)
    A One that is not cold, is scarcely a One at all.

  8. #268
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Hi Dmizer
    I followed your tutorial but I am getting two problems:

    1) I configured three samba shares, but I only get one on the client desktop.
    2) Even with the one that appears, I have permission problems and cannot read the files within.

    I am posting below the contents of my client's fstab and the smb.conf from the server.
    What do you think I'm doing wrong?
    Thanks!

    Here is the current FSTAB on the client (Ubuntu Feisty with Nautilus)

    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda1
    UUID=081bcdf6-c016-4453-8348-5e87f529aa80 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/sda5
    UUID=681fff98-ab4e-40c3-ae39-4b91eaca97cb none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    
    # Added for supporting USB in virtual machines  
    # (http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=3862823)
    usbfs  /proc/bus/usb  usbfs  auto  0  0
    
    # Added to mount samba shares
    # http://ubuntuforums.org/showthread.php?t=288534
    //callisto/hda1    /media/hda1        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    //callisto/hdb1    /media/hdb1        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    //callisto/hdc1    /media/hdc1        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    This is the current SMB.CONF on the server (Ubuntu edgy-server)

    Code:
    #
    # Configuration file for the Samba suite from http://www.howtoforge.com/samba_setup_ubuntu_5.10_p4.
    #
    #
    #
    
    [global]
       workgroup = CIUSSIGROUP
       netbios name = callisto
       server string = %h
       
       # added to try to fix slow transfers
       socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
    
       passdb backend = tdbsam
       security = user
       username map = /etc/samba/smbusers
       name resolve order = wins bcast hosts
       domain logons = yes
       preferred master = yes
       wins support = yes
       
       # Set CUPS for printing
       printcap name = CUPS
       printing = CUPS
       
       # Default logon
       logon drive = X:
       # logon script = scripts/logon.bat
       logon path = \\server1\profile\%U
    
    
       # Useradd scripts
       add user script = /usr/sbin/useradd -m %u
       delete user script = /usr/sbin/userdel -r %u
       add group script = /usr/sbin/groupadd %g
       delete group script = /usr/sbin/groupdel %g
       add user to group script = /usr/sbin/usermod -G %g %u
       add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
       idmap uid = 15000-20000
       idmap gid = 15000-20000
    
    
       # sync smb passwords with linux passwords
       passwd program = /usr/bin/passwd %u
       passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
       passwd chat debug = yes
       unix password sync = yes
       
       # set the loglevel
       log level = 3
    
    
    [homes]
       comment = Home
       valid users = %S
       read only = no
       browsable = no
    
    
    [printers]
       comment = All Printers
       path = /var/spool/samba
       printable = yes
       guest ok = yes
       browsable = no
    
    
    [netlogon]
       comment = Network Logon Service
       path = /home/samba/netlogon
       admin users = Administrator
       valid users = %U
       read only = no
    
    
    [profile]
       comment = User profiles
       path = /home/samba/profiles
       valid users = %U
       create mode = 0600
       directory mode = 0700
       writable = yes
       browsable = no
    
    [hda1]
      comment = hda1
      path = /home/shares/hda1
      valid users = @users
      force group = users
      create mask = 0660
      directory mask = 0771
      writable = yes
    
    [hdb1]
      comment = hdb1
      path = /home/shares/hdb1
      valid users = @users
      force group = users 
      create mask = 0660
      directory mask = 0771
      writable = yes
    
    [hdc1]
      comment = hdc1
      path = /home/shares/hdc1
      valid users = @users
      force group = users 
      create mask = 0660
      directory mask = 0771
      writable = yes
    
    [USB]
      comment = USB
      path = /mnt/USB
      valid users = @users
      write list = @users
      force group = users 
      create mask = 0660
      directory mask = 0771
      writable = yes

  9. #269
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... let's see if we can get some more information.

    i don't know which share shows on the desktop and which doesn't ... but replace the following with one of the shares which do not display on your desktop (assuming i've guessed incorrectly).

    please post the output of the following:
    Code:
    sudo umount /media/hda1
    sudo mount -t cifs //callisto/hda1 /media/hda1 --verbose -o credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777

  10. #270
    Join Date
    Apr 2007
    Beans
    38
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dmizer ant thanks for your quick reply!

    Sorry for the omitted info:
    the share that mounts but cannot be browsed is hda1
    The shares that do not mount at all are hdb1 and hdc1

    Here are the outputs:

    For hda1:
    sudo mount -t cifs //callisto/hda1 /media/hda1 --verbose -o credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777
    Code:
    parsing options: rw,credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777
    
    mount.cifs kernel mount options unc=//callisto\hda1,ip=192.168.1.102,user=USER,pass=PASS,ver=1,rw,credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 
    mount error 11 = Resource temporarily unavailable
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    For hdb1:
    sudo mount -t cifs //callisto/hdb1 /media/hdb1 --verbose -o credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777
    Code:
    parsing options: rw,credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777
    
    mount.cifs kernel mount options unc=//callisto\hdb1,ip=192.168.1.102,user=USER,pass=PASS,ver=1,rw,credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777
    Thanks for helping!

Page 27 of 137 FirstFirst ... 1725262728293777127 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •