Page 22 of 137 FirstFirst ... 1220212223243272122 ... LastLast
Results 211 to 220 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #211
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, according to your smbtree output, the "videoshare" doesn't exist.

    so, please post the contents of your /etc/samba/smb.conf file and we'll fix the workgroup issue.

  2. #212
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    [global]
    ; General server settings
    netbios name = shrapnel
    server string =
    workgroup = MAUNAWILI
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

    passdb backend = tdbsam
    security = user
    null passwords = true
    username map = /etc/samba/smbusers
    name resolve order = hosts wins bcast

    wins support = yes

    printing = CUPS
    printcap name = CUPS

    syslog = 1
    syslog only = yes

    ; NOTE: If you need access to the user home directories uncomment the
    ; lines below and adjust the settings to your hearts content.
    ;[homes]
    ;valid users = %S
    ;create mode = 0600
    ;directory mode = 0755
    ;browseable = no
    ;read only = no
    ;veto files = /*.{*}/.*/mail/bin/

    ; NOTE: Only needed if you run samba as a primary domain controller.
    ; Not needed as this config doesn't cover that matter.
    ;[netlogon]
    ;path = /var/lib/samba/netlogon
    ;admin users = Administrator
    ;valid users = %U
    ;read only = no

    ; NOTE: Again - only needed if you're running a primary domain controller.
    ;[Profiles]
    ;path = /var/lib/samba/profiles
    ;valid users = %U
    ;create mode = 0600
    ;directory mode = 0700
    ;writeable = yes
    ;browseable = no

    ; NOTE: Inside this place you may build a printer driver repository for
    ; Windows - I'll cover this topic in another HOWTO.
    [print$]
    path = /var/lib/samba/printers
    browseable = yes
    guest ok = yes
    read only = yes
    write list = root
    create mask = 0664
    directory mask = 0775

    [printers]
    path = /tmp
    printable = yes
    guest ok = yes
    browseable = no

    ; Uncomment if you need to share your CD-/DVD-ROM Drive
    ;[DVD-ROM Drive]
    ;path = /media/cdrom
    ;browseable = yes
    ;read only = yes
    ;guest ok = yes

    [MyFiles]
    path = /media/videoshare/
    browseable = yes
    read only = no
    guest ok = no
    create mask = 0644
    directory mask = 0755
    force user = arthur
    force group = user

  3. #213
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, according to what you've told me about your xp machine, and what i see here in your smb.conf file, you are already a part of the same workgroup. however, both your xp and your ubuntu machine have the exact same name. we'll need to correct that.

    please change this line:
    Code:
    netbios name = shrapnel
    to something unique to your ubuntu box. alternatively, you could rename your xp ps3 box. but i think part of your problem is happening because the names are the same.

    also, comment out the fstab line i gave you earlier by putting a # in front of it.

    then reboot everything (xp and ubuntu) and retry smbtree.

  4. #214
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    Here's my smbtree after restarting:
    MAUNAWILI
    \\SWARLEY
    \\SWARLEY\ADMIN$ IPC Service ()
    \\SWARLEY\IPC$ IPC Service ()
    \\SWARLEY\MyFiles
    \\SWARLEY\print$

    I changed my smb.conf to read netbios name = swarley.

    So it looks like I can't even see my Windows PC at all; I'm only seeing my PS3. Is this correct?

  5. #215
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    that's what it looks like. could be a firewall issue or some such, but lets try to mount the thing anyway.

    you said your share was named 'videoshare', so now edit the fstab file again. remove the # and change "MyFiles" to 'videoshare' like so:

    Code:
    //shrapnel/videoshare    /media/shrapnel        cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    then try:
    Code:
    sudo mount -a
    again

  6. #216
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    Here are the results after editing the fstab and attempting to remount:

    retrying with upper case share name
    mount error 6 = No such device or address
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

  7. #217
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    sorry for the delay ... you caught me out at lunch.

    do you have the windows xp firewall enabled? if you don't know how to check: http://www.microsoft.com/windowsxp/u...nfirewall.mspx

    are your shares password protected?

  8. #218
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer,

    Thank you so much for all your help thus far.

    I saw that the Windows firewall might present some problems so I disabled it, but I still cannot see my Windows PC from Ubuntu. I also tried to see if I could see my PS3 from my Windows laptop (since, if I understand things correctly, I have a samba server set up) and I could not.

  9. #219
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, you almost have a samba server enabled. make a couple of changes and you'll be good to go.

    change this line: security = user to security = share
    change this line: guest ok = no to guest ok = yes
    change this line: force group = user to force group = arthur

    then, enter these commands:
    Code:
    sudo smbpasswd -L -a arthur
    sudo smbpasswd -L -e arthur
    sudo /etc/init.d/samba restart
    and you should then be able to see your ubuntu box from windows.

    you said you were using static ip on the windows box? let's try mounting by ip address instead of by netbios name.
    so in fstab, change "shrapnel" to the ip address of your windows box, save and retry the sudo mount -a
    Last edited by dmizer; April 9th, 2007 at 06:29 AM.

  10. #220
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    I see it now! Is that it?

Page 22 of 137 FirstFirst ... 1220212223243272122 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •