Page 21 of 137 FirstFirst ... 1119202122233171121 ... LastLast
Results 201 to 210 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #201
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... lets try cifs now. see if this works:
    Code:
    sudo mount -t cifs //phoenix/My_Documents /media/phoenix -o guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777
    also make sure that the ftp is unmounted first.

  2. #202
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    I'm starting to think this is a non starter with Ubuntu now....

    I got this message now:

    carl@angel:~$ sudo mount -t cifs //phoenix/My_Documents /media/phoenix -o guest,iocharset=utf8,file_mode=0777,dir_mode=0777
    mount error 20 = Not a directory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    carl@angel:~$

  3. #203
    Join Date
    Jun 2006
    Beans
    97
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Just followed your howto and works like a charm. However I would say that a reboot will be necessary if you are trying to connect linux to linux...I spent a good 15 - 25 minutes scratching my head as to why my windows shares mounted no problem but I couldn't hit a samba share on another linux box in my network. Renamed the hosts file etc....kept getting Error 5.

    Rebooted my Ubuntu desktop and all was mounted when it came back up. Very weird.

    Would love to know why I couldn't just restart a service or something but it works now so no biggy.

    Thanks for the howto!

  4. #204
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i've never had a problem with needing to reboot when connecting from linux to linux. i really have no idea what could have been causing that for you.

    you might have been successful by using this command:
    Code:
    sudo mount /media/sharename

  5. #205
    Join Date
    Mar 2007
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by mells View Post
    Yay, a step in the right direction at last!

    I reinstalled smbfs and typed this into the terminal:



    It mounted as phoenix2 as I already had a ftp connection (which is useless) as phoenix on the desktop.

    Problem is I cant read the file names (see screenshot), or open any of the files.

    http://i25.photobucket.com/albums/c7...Screenshot.png

    There is nothing in /etc/samba/smb.con

    My DNS is my wireless router (I think) which is always fixed to 192.168.0.1


    Hello,

    I had the same problem and fixed it thanks to these resources:-

    http://whirlpool.net.au/forum-replie...fm/424238.html

    discussed firmware and directed me to:

    http://www.aroundmyroom.com/landisk/
    where i used
    nas-basic45-69-r8.rar

    and upgraded the box.

  6. #206
    Join Date
    May 2006
    Location
    Mexico
    Beans
    33
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    I believe I followed your instructions carefully. I even went back and used nano after I had used gedit to modify fstab. When I run
    Code:
    sudo mount -a
    I get the following error:
    Code:
    [mntent]: line 19 in /etc/fstab is bad
    Line 19 reads as follows:

    Code:
    //shuttlex/Shared Media    /media/SharedMedia      cifs    guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Any idea what I'm doing wrong?

    Thanks,
    Howard

  7. #207
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by howardf42 View Post
    Code:
    //shuttlex/Shared Media    /media/SharedMedia      cifs    guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Any idea what I'm doing wrong?
    fstab reads a space as a prompt that the command is done and to move on to the next. so with //shuttlex/Shared Media ... it's trying to read the shared file as //shuttlex/Shared and mount it in Media.

    you can correct this one of two ways.

    1) it's preferable to eliminate the space in your share name.
    -or-
    2) indicate a space by using \040 like so:
    Code:
    //shuttlex/Shared\040Media    /media/SharedMedia      cifs    guest,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Last edited by dmizer; March 25th, 2007 at 12:24 AM.

  8. #208
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    I'm trying to get my PS3 running Ubuntu to see my file share created on a Windows XP computer.

    I followed the guide and tried the manual mount option first, but couldn't get it to work. I then went off and tried to configure a samba server, not knowing exactly what I was doing, but after reading through this thread, it looks like what I might have done is configured a file share on my PS3 that perhaps my Windows XP machine could see, rather than what I originally intended, which was to have my PS3 see my Windows share.

    Could I get some help removing samba from my PS3 (since I don't need the ability to see my PS3 from my Windows machine and I'm thinking this might make life a lot easier), and then achieve what I originally intended?

    I saw that requests were made to post my smbtree so here it is:

    MAUNAWILI
    \\SHRAPNEL
    \\SHRAPNEL\ADMIN$ IPC Service ()
    \\SHRAPNEL\IPC$ IPC Service ()
    \\SHRAPNEL\MyFiles
    \\SHRAPNEL\print$

    Keep in mind, however, that I have a samba server running so I don't know if this will affect the smbtree output.

    As far as how my network is set up, my Windows XP machine is connected wirelessly to a Netgear WRT54G router with a static IP. My PS3 is connected via wire to my router and is also assigned a static IP.

    Windows XP machine name: shrapnel.
    Workgroup: MAUNAWILI

    Note: When I right-clicked on "My Computer --> Properties" and then went to the "Computer Name" tab, the full name of the computer is displayed as "shrapnel."

    I saw that I need to get my Ubuntu environment onto the same workgroup as my Windows machine. At the moment, I don't know how to do that.

    Any help would be greatly appreciated.

    Thanks,

  9. #209
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... lets just try to get you connected before making the effort of changing work group for your ubuntu machine.

    you didn't indicate if your xp machine had password protected shares or not, but i'll assume that you don't.

    as indicated in the howto, you'll need to create a folder on your ubuntu machine in which to mount the remote directory. howto indicates a directory of /media/sharename. for you i suggest /media/shrapnel like so:
    Code:
    sudo mkdir /media/shrapnel
    now edit fstab as shown in the howto and include this line:
    Code:
    //shrapnel/MyFiles    /media/shrapnel        cifs    guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    save, exit, and try this command:
    Code:
    sudo mount -a
    you should see a folder appear on your desktop labeled "shrapnel" where you can browse, change, and save files to at will.

    if that doesn't work, then we'll go through the effort of making your ubuntu machine joing the same workgroup.

  10. #210
    Join Date
    Apr 2007
    Beans
    10

    Re: Mount samba shares with utf8 encoding using cifs

    I forgot to mention that the name of my share on the WinXP machine is called "videoshare"

    This is the output from "mount":

    mount: sys already mounted or /sys busy
    mount: according to mtab, /sys is already mounted on /sys
    mount error 5 = Input/output error
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    Last edited by swarles_barkley; April 9th, 2007 at 03:30 AM.

Page 21 of 137 FirstFirst ... 1119202122233171121 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •