Page 20 of 137 FirstFirst ... 1018192021223070120 ... LastLast
Results 191 to 200 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #191
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    eragorn or phazon,
    can i get a link to the synergy firmware? i'll stick it on the first post.
    Here you go

    http://www.synology.com/enu/news/07.01.12.php

  2. #192
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    eragorn or phazon,
    can i get a link to the synergy firmware? i'll stick it on the first post.

    @ mells:
    well, this thread is about cifs, not smbfs, but i THINK you should be able to get yours to work by adding two options to your mount line like so:
    Code:
    sudo mount -t smbfs -o guest,fmask=777,dmask=777 //192.168.0.3/My_Documents /media/phoenix
    you may also have to make sure that the /media/phoenix folder has 777 permissions:
    Code:
    sudo chmod 777 /media/phoenix
    Thanks dmizer, but I get the following message if I try the suggested:

    sudo mount -t smbfs -o guest,fmask=777,dmask=777 //192.168.0.3/My_Documents /media/phoenix
    mount: wrong fs type, bad option, bad superblock on //192.168.0.3/My_Documents,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

  3. #193
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    please post the output of:
    smbtree

  4. #194
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    please post the output of:
    smbtree
    Thats the funny thing.

    carl@angel:~$ sudo smbtree
    Password:
    carl@angel:~$
    Nothing comes up.

    I can ping the device //phoenix and its IP address 192.168.0.3 no problems..

  5. #195
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    humm ... do you have ubuntu set up as a samba server as well?

    try this line:
    Code:
    sudo mount -t smbfs -o guest,rw //phoenix/My_Documents /media/phoenix
    sometimes this works when attempting the mount by ip address does not.
    Last edited by dmizer; February 15th, 2007 at 04:11 AM.

  6. #196
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    humm ... do you have ubuntu set up as a samba server as well?

    try this line:
    Code:
    sudo mount -t smbfs -o guest,rw //phoenix/My_Documents /media/phoenix
    sometimes this works when attempting the mount by ip address does not.
    That doesnt work, its driving me nuts. Output:

    carl@angel:~$ sudo mount -t smbfs -o guest,rw //phoenix/My_Documents /media/phoenix
    Password:
    mount: wrong fs type, bad option, bad superblock on //phoenix/My_Documents,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    carl@angel:~$

  7. #197
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... i broke out the manual on your nas device. what filesystem did you use to format the drive with?

    also, where did you format the drive? did you format the drive with the "disk utility" while it was in the nas unit, or did you format it and then put it in the nas unit?

    also, can you post screenshots of the "SMB Server" and "status" sections from the web controll utility for your device?

    i swear ... i'm going to go out and buy myself one of these evil NAS things just so i can smash it to tiny bits with a blunt object.
    Last edited by dmizer; February 16th, 2007 at 11:36 AM.

  8. #198
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    The disk was formatted from NTFS to FAT32 by the NAS unit using the format feature in the menu.

    Thanks for spending so much time helping. Here is the requested screenshots, sorry I used a windows box (eewwh!!!) to grab them:

    Status
    http://i25.photobucket.com/albums/c77/cmelia/status.jpg

    SMB
    http://i25.photobucket.com/albums/c77/cmelia/smb.jpg

    IP address
    http://i25.photobucket.com/albums/c77/cmelia/ipaddy.jpg

    Thanks again, the unit so nearly has been thrown out of the window several times!

  9. #199
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    lol ... don't worry, if i get around to buying one, i'll take lots of pictures while i destroy it.

    okay ... have you set up samba to share files from your ubuntu box yet? if so, please post your current /etc/samba/smb.conf file. if not, i'll reply with a replacement for it.

    humm ... what about ipv6? has that been disabled on your box? what's listed in ubuntu as your dns servers?

    have you installed smbfs?
    Code:
    sudo aptitude install smbfs

  10. #200
    Join Date
    Dec 2006
    Location
    Maidstone, UK.
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    Yay, a step in the right direction at last!

    I reinstalled smbfs and typed this into the terminal:

    sudo mount -t smbfs -o guest,rw //phoenix/My_Documents /media/phoenix
    It mounted as phoenix2 as I already had a ftp connection (which is useless) as phoenix on the desktop.

    Problem is I cant read the file names (see screenshot), or open any of the files.

    http://i25.photobucket.com/albums/c7...Screenshot.png

    There is nothing in /etc/samba/smb.con

    My DNS is my wireless router (I think) which is always fixed to 192.168.0.1

Page 20 of 137 FirstFirst ... 1018192021223070120 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •