Page 14 of 137 FirstFirst ... 412131415162464114 ... LastLast
Results 131 to 140 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #131
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    It's working again now - it seems to just take time (1-2 hours) to work after mounting. So the situation is -

    1) mount as SMBFS, works immediately in terminal, but doesn't work in nautilus or from any GUI app (ie Songbird, VMware)
    2) mount as CIFS, works fine in all applications but not for an hour or two after mounting/booting. Not ideal...

    The NAS is 320Gb, so it's fairly large, but the fact I can access it immediately from the command line via smbfs, unless cifs has a totally different way of caching... Dunno, seems very weird.

    Dmizer, really appreciate your help with this. This thread shows just how helpful a community like this can be.

    Now if I could just get it working perfectly....

  2. #132
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, part of the reason smbfs isn't working in your other apps is because it doesn't cashe at all. it's also why you're getting instant access.

    that said, it should not take over 5 minutes to cashe a drive of that size with cifs, so there is still something wrong. lots of very large files 700meg + on that drive? i'm going to take a closer look at some of the settings for cifs and see if i can come up with a solution for ya.

  3. #133
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    well, part of the reason smbfs isn't working in your other apps is because it doesn't cashe at all. it's also why you're getting instant access.

    that said, it should not take over 5 minutes to cashe a drive of that size with cifs, so there is still something wrong. lots of very large files 700meg + on that drive? i'm going to take a closer look at some of the settings for cifs and see if i can come up with a solution for ya.
    OK I see, if smbfs doesn't do any caching then that makes a bit more sense then. I'll have to read up a bit more on that and cifs so I understand a bit more about how they work.

    There are a fair few large files on the drive I would think. I guess it's got about 200Gb on it in total.

    If you can find anything further I'd really appreciate it. Thanks again.

  4. #134
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... try adding the option "directio" in your mount options. i'll use my example from the howto:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,directio,iocharset=utf8,file_mode=0777,dir_mode=0777
    see if that doesn't get you faster response times. i think part of the reason is you have a huge amount of data on that drive. directio will turn cashing off so you should get better mount response times. since cifs is faster, you should also still be able to use other applications like nautilus and songbird (vmware might be pushing things).

  5. #135
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    Seems to be the same strangely, possibly it's a bit quicker but we're still talking an hour or so. I will have a further play with it in the morning.

    Thanks for the continued efforts.

  6. #136
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    no worries, but i'm starting to reach now.

    how about some information about your network setup?
    router make and model? are you wireless, and if so ... what card and driver are you using?

    try this ... shut the entire network down. turn everything off including your router and modem. power on in this order:
    modem first ... wait for sync.
    router next ... again, wait for sync.
    your nas device
    your ubuntu box.

    retry the connection and see if you get improved results.

  7. #137
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    here's something else to try for possibly getting more information. mount with the verbose option and see what the output is of the mount. like so:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename --verbose -o username=winusername,password=winpassword,directio,iocharset=utf8,file_mode=0777,dir_mode=0777

  8. #138
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    OK I'll try that last one and the reboot this morning.

    As for network, I've got a Netgear DG834G router/modem. That is connected via Netgear XE103 powerline network devices to a Netgear gigabit 8-port switch. Plugged into the switch are the Synology NAS and the Ubuntu box, via a Netgear gigebit ethernet card.

  9. #139
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    here's something else to try for possibly getting more information. mount with the verbose option and see what the output is of the mount. like so:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename --verbose -o username=winusername,password=winpassword,directio,iocharset=utf8,file_mode=0777,dir_mode=0777
    Here's the output from the verbose mode

    nick@home-desktop:~$ sudo mount -t cifs //192.168.0.5/MyDocs /home/nick/nas --verbose -o username=xyz,password=1mogen,directio,iocharset=ut f8,file_mode=0777,dir_mode=0777
    parsing options: rw,username=admin,password=123,directio,iocharset= utf8,file_mode=0777,dir_mode=0777

    mount.cifs kernel mount options unc=//192.168.0.5\MyDocs,ip=192.168.0.5,ver=1,rw,usernam e=admin,password=1mogen,directio,iocharset=utf8,fi le_mode=0777,dir_mode=0777
    nick@home-desktop:~$ ls nas
    nick@home-desktop:~$
    As you can see, 'ls nas' retrieves nothing. I'm timing it and will keep trying to see how long it takes to come back with something.

    To be honest I guess it's working as it's supposed to, it's just the implementation of cifs takes a while to deal with the amount of data involved. I'm surprised to the directio option doesn't solve it though.

    When this is done I'll try rebooting the network.

  10. #140
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well according to the verbose mode, the directio was actually sent. the only thing i can think of now would be network related. you do have an enormous amount of information on that drive, but it still shouldn't take more than 15 minutes to complete the mount.

    what was the result of your network reboot?

    if that was unsuccessful, how about attempting to connect directly to it with a crossover cable?

Page 14 of 137 FirstFirst ... 412131415162464114 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •