Page 136 of 137 FirstFirst ... 3686126134135136137 LastLast
Results 1,351 to 1,360 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1351
    Join Date
    Apr 2009
    Location
    India
    Beans
    22
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Hi

    I am using Ubuntu 10.04.3 LTS. I have permaentaly mounted samba shares on few pcs and running dos application by using dosemu. while I calling same exe file which is using another system that not running, ie I can run same dos application in serval system.

    Using 11.04, I am suceessfully running dos application on shared environment. Because 10.04.3 is LTS version I planning change from 11.04 to 10.04.3. Kindly Help...

    my fstab enty on Ubuntu 11.04 is

    //192.168.0.1/share /mnt/share smbfs username=********,password=******* 0 0

  2. #1352
    Join Date
    Jun 2012
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Hello everyboby,

    I folowed all the steps in the first message of the thread, all went ok.

    The folder I want to mount automatically is on a Win7 computer, on the Desktop.
    The machine I want to mount it on is Ubuntu 12, fresh install (my main computer broke and I have to finish a project before yesterday so I popped an old laptop and put ubuntu on it)

    the test resulted in the following error:

    adrian@adrian-PC:~$ sudo mount -a
    mount: wrong fs type, bad option, bad superblock on //laptop-catalina/users/catalina/Desktop/WORDFAST_TMs,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    I am a total zero on Linux, please tell me if I can mak it work somehow.

    Thank you.
    Dan

  3. #1353
    Join Date
    Oct 2004
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    This is so weird! After some updates to cifs/smb last month my fstab entry stopped working. I am continuously getting error 13 now. After messing with it for weeks I decided to try and replace my .smbcredentials part by a username/password part. And now all is fine, mounts perfectly when I try sudo mount -a !

    So a few questions:
    Anyone know why it stopped working after the update?
    Anyone know how I can get it to work again using the .smbcredentials file?

    Should the username/password be in the first or second format for it to work?
    Code:
    username=blaat,password=blabla
    Code:
    username=blaat
    password=blabla
    I was using the last, not tried the first yet.

  4. #1354
    Join Date
    Sep 2007
    Location
    Yakima, WA
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I've only used the second form, two separate lines in .smbcredentials.
    This signature line intentionally blank.

  5. #1355
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Due to recent changes in the samba packages, the prework section is a little out of date.

    Instead of
    Code:
    sudo apt-get install smbfs
    It should now read:
    Code:
    sudo apt-get install cifs-utils

  6. #1356
    Join Date
    Apr 2010
    Beans
    118

    Re: Mount samba shares with utf8 encoding using cifs

    Can't thank you enough for this clear, easy to follow tutorial. I've been struggling for weeks to get a NAS box permanently mounted so I can run automated backups, and after reading dozens of threads and trying umpteen supposed solutions, yours finally delivers. Many, many thanks!

  7. #1357
    Join Date
    Apr 2010
    Beans
    118

    Re: Mount samba shares with utf8 encoding using cifs

    Having successfully completed a first backup set, I've been playing around a bit and found something I don't fully understand. When I open the mounted NAS share (it's actually an external usb drive attached to an old QNAP TS-109: //NAS-2-QNAP/USBDisk1/) from its icon on the desktop, I can see the backup folder and manually create other folders on the share; however I can't add a further folder inside any of them - the option is greyed out. I thought this might be something to do with permissions (which I struggle to get my head round) - that somehow the permissions on the share (created when I set up the NAS) are not being applied recursively (I vaguely remember reading about this as an issue with the QNAP a long time ago, but I can't find it now). However, if I navigate to the same share via Places>Network>Windows Network>Mygroup>NAS-2-QNAP>USBDisk1, I can create folders within folders to my heart's content, without any problems. This isn't an issue, therefore: I mainly want the share for auto-backup and that is working, and if I want to save extra stuff I can remember to go via the network rather than the cifs mounted icon; but I'm curious as to how this all fits together.

  8. #1358
    Join Date
    Nov 2007
    Location
    USA-ish
    Beans
    206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mount samba shares with utf8 encoding using cifs

    Is there any way to get rid of these 101 errors at bootup, which presumable are due to the fact that the network drivers aren't yet loaded, or something.

    Code:
    mount error(101): Network is unreachable
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    mount error(101): Network is unreachable
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    mountall: mount /media/data [736] terminated with status 32
    Desktop: Quantal on Core2 Duo E8500/Asus P5Q
    Laptop: Precise on S76 Pangolin

  9. #1359
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Cammy View Post
    Is there any way to get rid of these 101 errors at bootup, which presumable are due to the fact that the network drivers aren't yet loaded, or something.

    Code:
    mount error(101): Network is unreachable
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    mount error(101): Network is unreachable
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    mountall: mount /media/data [736] terminated with status 32
    Sorry for the delay. If you still have not solved this, I assume you are using wireless and have to log in before you can connect to the internet.

    In that case, you're better off using automount instead. Here is some documentation for automount: https://help.ubuntu.com/community/Autofs

  10. #1360
    Join Date
    Jul 2007
    Location
    Saskatoon, SK
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Recently made the switch to 13.04 from 12.04, and can no longer get my NAS drive (D-Link DNS-323) to mount as I now get mount error(13): Permission denied.

    Under 12.04 my fstab entry looked like this:
    Code:
    //192.168.0.101/Volume_1 /home/USERNAME/DNS-323 cifs guest,rw,iocharset=utf8,gid=1000,uid=1000,nounix,file_mode=0777,dir_mode=0777 0 0
    while my wife's (also using 12.04 and having no mount issues) looks like this:
    Code:
    //192.168.0.101/Volume_1 /home/USERNAME/DNS-323 cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Both of these entries do not work for me, any ideas as to why?
    (All initial steps were taken: installed cifs-utils and winbind, DNS-323 folder has been made).
    Does not hide his beans.
    Is a proud supporter of nuclear energy.

Page 136 of 137 FirstFirst ... 3686126134135136137 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •