Page 133 of 137 FirstFirst ... 3383123131132133134135 ... LastLast
Results 1,321 to 1,330 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1321
    Join Date
    Jan 2010
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Alright, I've stumbled upon this thread thanks to an old archive in ubuntu, but I figured I'd hop in here.

    I'm on 11.04 Narwhal server, and I'm using win server 2k3.

    I'm having a problem someone had a long time ago, which is that I'm mounting successfully but I can't edit the files. I can copy them but I cannot write to them. I'm using something that looks like this in my fstab:


    //compression1.mydomain.local/share /media/share cifs iocharset=utf8,credentials=/root/.smbcredentials,noperm,file_mode=0777,dir_mode=077 7,uid=0,gid=0 0 0

    As you can see, I've tried specifying root's uid and gid (I'm doing this all as root for the moment), and I'm specifying noperm. The file and dir mode are both 0777, and doing an ls shows that it's owned by root/root, and it's allowing rwx to everyone.

    That being said, I still get "permission denied" if I try to make a new directory in there, or edit a file, or delete something. I've checked the windows machine, the user I'm logging in as has FULL permissions to the share, and the files are NOT set to read-only.

    Anything else I'm not trying?


    EDIT:

    Never mind, I'm a complete idiot. I had changed the local file permissions but not the share permissions, our support guy figured it out. Problem Exists in Windows. (pew pew!)

    Sorry for adding more glut to this pile, but now everyone knows: check the *share* permissions on windows, too!
    Last edited by NateDSaint; July 13th, 2011 at 05:22 PM.

  2. #1322
    Join Date
    Jan 2008
    Beans
    13

    Re: Mount samba shares with utf8 encoding using cifs

    I'm having a really weird error. I have an ubuntu server I just had to wipe and reinstall 11.04 after it crashed. It hasn't been used for a few months until now, but it was able to mount network shares from my windows 2003 server without any problems.

    Now, I am mounting my shares in fstab with all of the options specified in this guide. The drives seem to mount ok, but when I do anything recursive such as an rsync(There are different versions of the same fileserver on the ubuntu and windows server), I will get locked out of the share and get Permission Denied. Also I keep getting this:

    CIFS VFS: Unexpected SMB signature
    Last edited by brandn; July 21st, 2011 at 04:57 PM.

  3. #1323
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I get the following error when trying to mount in xubuntu:

    wrong fs type, bad option, bad superblock on //WHITE_RABBIT/NAS,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)

    It's a new install, on my old PC this worked fine...

  4. #1324
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    I get the following error when trying to mount in xubuntu:

    wrong fs type, bad option, bad superblock on //WHITE_RABBIT/NAS,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)

    It's a new install, on my old PC this worked fine...
    Please refer to the "Prework" section. Particularly where it says to install smbfs.

  5. #1325
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by brandn View Post
    CIFS VFS: Unexpected SMB signature
    Try adding this option: sec=ntlmv2i

  6. #1326
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Sorry to be such a pain, I did all the prework, and smbfs is installed. The option you told me, where do I add it? Just at the end, separated by a , ?

    The strange thing is if i go into the xubuntu file manager and browse to network-windows-network to the share I want to access and enter the correct info I can get into the share.
    Last edited by Irwin J. Finster; August 14th, 2011 at 06:54 PM.

  7. #1327
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    Sorry to be such a pain, I did all the prework, and smbfs is installed. The option you told me, where do I add it? Just at the end, separated by a , ?
    That was a reply to a different post. Don't worry about the option.

    Quote Originally Posted by Irwin J. Finster View Post
    The strange thing is if i go into the xubuntu file manager and browse to network-windows-network to the share I want to access and enter the correct info I can get into the share.
    Please post your mount command or /etc/fstab line.

  8. #1328
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    This is what I do and get:

    *************e:~$ sudo mount -t cifs //WHITE_RABBIT/NAS /media/NAS -o username=********,password=********,iocharset=utf8 ,file_mode=0777,dir_mode=0777
    [sudo] password for pirchl:
    mount: wrong fs type, bad option, bad superblock on //WHITE_RABBIT/NAS,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)
    Manchmal liefert das Syslog wertvolle Informationen – versuchen
    Sie dmesg | tail oder so





    I suspect I am missing some files, for if I enter mount-cifs at the command line I get the answer that it is not installed and I should apt-get cifs-utils but when I do that I get the message that cifs-utils is already in the newest version.....


    if I input dmesg | tail

    I get:

    dmesg | tail
    [ 14.457259] forcedeth 0000:00:0a.0: irq 47 for MSI/MSI-X
    [ 15.292768] ppdev: user-space parallel port driver
    [ 18.172848] usb 1-1: usbfs: interface 1 claimed by usblp while 'usb' sets config #1
    [ 23.827457] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
    [ 24.580019] eth0: no IPv6 routers present
    [ 35.543212] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
    [ 46.986405] EXT4-fs (sdb1): warning: maximal mount count reached, running e2fsck is recommended
    [ 47.013212] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
    [ 119.832225] CIFS VFS: cifs_mount failed w/return code = -22
    [ 1092.781199] CIFS VFS: cifs_mount failed w/return code = -22
    Last edited by Irwin J. Finster; August 15th, 2011 at 11:22 AM.

  9. #1329
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    LOL, when I enter the ip address instead of the server name it works flawlessly! Why could that be?

  10. #1330
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    LOL, when I enter the ip address instead of the server name it works flawlessly! Why could that be?
    Lots of possible reasons for that. Most commonly it's a firewall issue. It could also be a result of network configuration, server configuration, client configuration, a problem with the router, or a number of possible problems.

Page 133 of 137 FirstFirst ... 3383123131132133134135 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •