Page 132 of 137 FirstFirst ... 3282122130131132133134 ... LastLast
Results 1,311 to 1,320 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1311
    Join Date
    Mar 2011
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    Alright I wrote out the first line for the entry I made.

    Code:
    //192.168.1.104/Volume_1/Media /media/NT-DR2-1 cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    I made the same entry for the second drive.

    Nothing appears and I don't see any error messages.

    When I try:

    Code:
    sudo mount -t smbfs -o username=*****,password=***** //192.168.1.104/Volume_1/Media /media/NT-DR2-1
    it appears temporarily but goes away after a reboot.
    Last edited by dmizer; March 22nd, 2011 at 04:00 PM. Reason: added code tags.

  2. #1312
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by iliekpie View Post
    Alright I wrote out the first line for the entry I made.
    Your mount should look like this:
    Code:
    sudo mount -t cifs //192.168.1.104/sharename /media/NT-DR2-1 -o username=*****,password=*****
    Where "sharename" is the name of the share on your windows computer, not a directory path.

  3. #1313
    Join Date
    Mar 2011
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    I looked at it again and yeah the share name is listed as simply Volume_1 and Volume_2.

    I tried typing the code you wrote in the terminal. It works and the drives pop up on the desktop. It goes away after a reboot though.

    I tried changing the sharename in /etc/fstab to just Volume_1 and smbfs back to cifs but nothing happens.

  4. #1314
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by iliekpie View Post
    I tried changing the sharename in /etc/fstab to just Volume_1 and smbfs back to cifs but nothing happens.
    Ok, reboot your system and see what happens if you run the following command:
    Code:
    sudo mount /media/NT-DR2-1

  5. #1315
    Join Date
    Mar 2011
    Beans
    6
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    Typing that into the terminal gave me the message "Permission Denied"

    That clued me in right there. I typed the wrong password in .smbcredentials

    Thanks for your help and for the guide. It works automatically now after a reboot. All drives appear on the desktop permanently.

  6. #1316
    Join Date
    May 2010
    Beans
    27

    Re: Mount samba shares with utf8 encoding using cifs

    sorry, i know this thread is really old i'm just hoping that its still monitored..

    i followed the instructions and i also created a smbcredentcials file with my windows server 2008 administrator and password.

    but when i run:

    sudo mount -a

    i get:

    Code:
     
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    have i missed something out?

    thanks
    zac


    edit......

    looks like i got it working. i must have used the wronf line of code when setting the permenant mount. ive tested it by moving a .txt file around and its visable from bother ends (windows & linux machine). the only thing that seems to not work is the sudo mount -, it doesnt seem to display anything.... i'll work on this.
    Last edited by zac123; June 26th, 2011 at 02:10 PM.

  7. #1317
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Yes, this thread is still monitored and I still keep the tutorial current as updates sometimes change things and people find and solve errors.

    Quote Originally Posted by zac123 View Post
    looks like i got it working.
    Good to hear!

    Quote Originally Posted by zac123 View Post
    the only thing that seems to not work is the sudo mount -, it doesnt seem to display anything.... i'll work on this.
    If the mount is successful, the sudo mount -a command will not output anything, if it is not successful you will see an error.

  8. #1318
    Join Date
    May 2010
    Beans
    27

    Re: Mount samba shares with utf8 encoding using cifs

    yes sorry i went back and tried it without the -a and it showed me the mounts etc.

    thanks so much fow taking the time to write a plain english tutorial.

  9. #1319
    Join Date
    Jun 2011
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    So, after weeks of frustration, this tutorial in combination with another tutorial that I found finally allowed me to share files between my W7 server and my Ubuntu htpc. My question now is: how would I add more than one share? For instance, right now I have my movies directory shared, how would I go about being able to share my music share as well?

  10. #1320
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by BPCreations View Post
    So, after weeks of frustration, this tutorial in combination with another tutorial that I found finally allowed me to share files between my W7 server and my Ubuntu htpc. My question now is: how would I add more than one share? For instance, right now I have my movies directory shared, how would I go about being able to share my music share as well?
    That's really a topic for a new thread because this is only about mounting shares, not about sharing directories.

    However, if you're sharing your movies directory via smb.conf, you'll just need to add another share stanza like so:
    Code:
    [movies]
            comment = My Movies
            path = /home/dmizer/Movies
            read only = no
            guest only = yes
            guest ok = yes
    	force user = dmizer
    	force group = dmizer
    	browsable = yes
    
    [music]
            comment = My Music
            path = /home/dmizer/Music
            read only = no
            guest only = yes
            guest ok = yes
    	force user = dmizer
    	force group = dmizer
    	browsable = yes
    If you need more help than that, please start a new thread

Page 132 of 137 FirstFirst ... 3282122130131132133134 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •