Page 13 of 137 FirstFirst ... 311121314152363113 ... LastLast
Results 121 to 130 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #121
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    lol ... you know, that's the EXACT same reply narky had. one post it didn't work and was ready to give up. and the next ... shezam ... everything's hunky dory. you find narky's magic words? lol

    perhaps this is because the first time the mount is found, it takes time to cashe everything. after that, it should respond much more quickly.

    no worries about the beer. i work for a wine import company

  2. #122
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    OK, so I've got the same issue as eragorn and narky, and it is driving me insane! I've run through everything as described, try and list the mounted folder and get nothing. If I run exactly the same mount command but as smbfs, it lists fine, but doesn't work in nautilus (see here for description of that one).

    Smbtree returns nothing, just blinks for a few seconds and then bcak to the command line.

    It seems from the last few posts that no-one knows how to solve it, it just suddenly starts working. If anyone does have any ideas, please post it because I've been trying to get this working for a while now and I'm going to have to go back to Windows soon if I can't get it going.

    BTW, I'm trying to connect to a Synology 106e NAS, similar to narky I think.

  3. #123
    Join Date
    Nov 2006
    Location
    Toronto, Canada
    Beans
    12
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    lol ... you know, that's the EXACT same reply narky had. one post it didn't work and was ready to give up. and the next ... shezam ... everything's hunky dory. you find narky's magic words? lol

    perhaps this is because the first time the mount is found, it takes time to cashe everything. after that, it should respond much more quickly.

    no worries about the beer. i work for a wine import company
    It ended up being folder permissions for me! Doh....Other than that I had to mount using cifs and I have not added it to fstab yet. I only mounted manually.

    I believe the 106e is running a linux kernal already so maybe you need to follow easier steps for mounting. I can not help you with this but maybe dmizer. Also check this out http://www.synology.com/enu/forum/vi...402f36419dad98

    its from the synology forum. Good luck!

    If that doesn't work I think you can install alternative firmware since your NAS is a power pc (faster than my 101j)

  4. #124
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by phazon. View Post
    Smbtree returns nothing, just blinks for a few seconds and then bcak to the command line.
    okay ... let's concentrate on this issue, because if we can get the name to resolve, then you can get the mount to work properly. there are several possible causes for this:
    1) firestarter blocks the samba port by default, so you'll have to open it if you've installed the firestarter iptables frontend.

    2) something was not configured correctly with wins or the winbind daemon isn't running. in this case, simply review the first few steps in the howto.

    can you ping the nas by name? can you ping the nas by ip? have you attempted to mount the nas by ip instead of by name?

    btw, the link that eragorn gave outlines the exact same process for mounting the nas as i gave here, except that it's tailored for fedora core instead of ubuntu.

  5. #125
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    Guys

    Thanks for your responses. Dmizer, on your two points

    1) I don't have Firestarter installed. I will do that, but I want to get this working before adding anything else to confuse the issue.
    2) This is an all linux issue, no Windows, so I'm presuming I don't need WINS...? But regardless, yes I can ping the NAS by name and IP. I'm generally only trying to mount by IP anyway (fixed lease).

    This mounts fine via smbfs, but then stops working via nautilus.

    This is the output from the ping and smbtree;

    nick@home-desktop:~$ ping NJW_Diskstation
    PING NJW_Diskstation (192.168.0.5) 56(84) bytes of data.
    64 bytes from 192.168.0.5: icmp_seq=1 ttl=64 time=0.220 ms
    64 bytes from 192.168.0.5: icmp_seq=2 ttl=64 time=0.181 ms
    64 bytes from 192.168.0.5: icmp_seq=3 ttl=64 time=0.179 ms
    64 bytes from 192.168.0.5: icmp_seq=4 ttl=64 time=0.181 ms
    64 bytes from 192.168.0.5: icmp_seq=5 ttl=64 time=0.169 ms
    64 bytes from 192.168.0.5: icmp_seq=6 ttl=64 time=0.152 ms
    64 bytes from 192.168.0.5: icmp_seq=7 ttl=64 time=0.181 ms

    --- NJW_Diskstation ping statistics ---
    7 packets transmitted, 7 received, 0% packet loss, time 6023ms
    rtt min/avg/max/mdev = 0.152/0.180/0.220/0.022 ms
    nick@home-desktop:~$ smbtree NJW_Diskstation
    Password:
    nick@home-desktop:


    Thanks for your help.

  6. #126
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    okay ... if there are no windows machines in your network then that may be part of your problem, as there is no domain for the nas and your ubuntu box to join.

    although there are no windows machines in your network, you are using a windows protocol to connect to your nas device, so you have to play by windows networking rules.

    try this:
    Code:
    sudo aptitude install samba
    sudo /etc/init.d/samba stop
    sudo mv /etc/samba/smb.conf /etc/samba/smb.conf.template
    sudo touch /etc/samba/smb.conf
    sudo nano /etc/samba/smb.conf
    now, in this file, you'll have to enter the following data. but keep in mind you're going to have to change the specifics to meet your situation's needs:
    Code:
    [global]
        ; General server settings
        netbios name = YOUR_HOSTNAME
        workgroup = YOUR_WORKGROUP
        announce version = 5.0
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    now ... be sure to change "YOUR_HOSTNAME" to a name unique to your ubuntu computer, and change YOUR_WORKGROUP to a workgroup name common to both your ubuntu computer and your nas device (most likely mshome).

    save the file and exit.

    now, don't forget to modify the permissions on your mount folder. for example from my howto:
    Code:
    sudo chmod 777 /media/sharename
    and finally ... restart the samba daemon:
    Code:
    sudo /etc/init.d/samba start
    then see if you can mount again.

  7. #127
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    OK done that, rebooted, no joy. This is my smb.conf;

    nick@home-desktop:~$ more /etc/samba/smb.conf
    [global]
    ; General server settings
    netbios name = home-desktop
    workgroup = intl
    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_S
    NDBUF=8192
    nick@home-desktop:~$

    The reason the domain is intl is cos that is the domain on my work laptop.

    Still nothing from smbtree...

  8. #128
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    well, according to what i've seen with eragorn and narky, your nas device isn't going to show up in smbtree anyway. but you still should be able to mount the device by either netbios name or ip address.

    what directory are you trying to mount the shares to? and have you changed the permissions yet?

  9. #129
    Join Date
    Jun 2006
    Beans
    45
    Distro
    Ubuntu 6.10 Edgy

    Re: Mount samba shares with utf8 encoding using cifs

    The share on the NAS is MyDocs. I've changed permissions on the directory on the ubuntu box (/home/nick/nas) to 0777 before trying to do the mount, that's right I think?

    OK now this is weird... I've been out this afternoon for a few hours, and before I went out I rebooted and tried to 'ls /home/nick/nas' with the usual result. Now having come home, with no other changes and in the same terminal window, I 'ls /home/nick/nas' and it's working fine! It's like it needs time to register or something.

    Rebooted and now it doesn't work again. I guess if I wait for a few hours it will work - but why doesn't work first time?!

  10. #130
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by phazon. View Post
    The share on the NAS is MyDocs. I've changed permissions on the directory on the ubuntu box (/home/nick/nas) to 0777 before trying to do the mount, that's right I think?
    no, you should only change permissions on the folder once. you don't have to change the permissions every time you mount the device, only the first time when you create the folder.

    i don't know how big your storage unit is, but the more space you have, the longer it will take to cashe initially. but ... the more you use it, the faster it will get. and it shouldn't be long (two or three mounts with some use) before you will have instant access.

Page 13 of 137 FirstFirst ... 311121314152363113 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •