Page 129 of 137 FirstFirst ... 2979119127128129130131 ... LastLast
Results 1,281 to 1,290 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1281
    Join Date
    Sep 2007
    Location
    Yakima, WA
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I don't know what my problem is with a manual mount. Still get a mount that is read only to linux user, owned by root 0777, even after I tried the syntax in the trouble shooting section adding my gid and uid. Also tried getting the username and password from .smbcredentials.

    This doesn't work:
    sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o rw,username=xxxx,password=xxxxx,iocharset=utf8,gid =1000,uid=1000,nounix,file_mode=0777,dir_mode=0777
    This doesn't work:
    sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o rw,credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,n ounix,file_mode=0777,dir_mode=0777
    And now this works doesn't work in fstab:
    //paule6500/elevation /home/paul/elevation cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
    Wait, the problem has been permissions on the Windows side for my test directory (elevation) all this time. I had to give myself full control on windows before I could get a rw samba mount.
    This signature line intentionally blank.

  2. #1282
    Join Date
    May 2010
    Beans
    67
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Mount samba shares with utf8 encoding using cifs

    Couple of things.

    I use 10.10 an my server is basically Buffalo NAS.

    Here is my fstab line:
    //xxx.xxx.xxx.xxx/myfolder /media/test cifs rw,noperm,iocharset=utf8,credentials=/etc/.smbcredentials,file_mode=0777,dir_mode=0777,users 0 0

    smbcredentials contains usernam and password.

    It mounts is successfully, but with the wrong owner. If I mount it with root, owner of every file is root, if I mount it with user1, owner of every file is user1.

    1. It seems that is disregards .smbcredentials. If I don't specify .smbcredentials, it asks for a pwd, but I cantput any random key combination and it ould be ok and mount the remote share

    2. Unmount from the user1 is impossible. Always have to umount with root. If I try to umount with user1 I get an error that says:

    user1@ubuntu10-lap:~$ umount /media/test
    umount: /media/test mount disagrees with the fstab

    3. Shutdown hanging when cifs is mounted is permanent. There seems to be no workaround. I applied MANY solutions, but seems that there is no permanent solution.

    My question is - is there a solution to any of these problems that you might be aware of?

    Thanks!

  3. #1283
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by peshko-lnx View Post
    If I mount it with root, owner of every file is root, if I mount it with user1, owner of every file is user1.
    This is expected behavior. The same is true with Windows servers and Windows clients. If this is a problem, you need to create group permissions on the server and add all of your client user names to the group.

    Quote Originally Posted by peshko-lnx View Post
    1. It seems that is disregards .smbcredentials. If I don't specify .smbcredentials, it asks for a pwd, but I cantput any random key combination and it ould be ok and mount the remote share
    Double check the formatting of the samba credentials file as this usually happens if there is an extra space or there could be a problem if the file was created with a gui text editor.

    Quote Originally Posted by peshko-lnx View Post
    2. Unmount from the user1 is impossible. Always have to umount with root. If I try to umount with user1 I get an error that says:

    user1@ubuntu10-lap:~$ umount /media/test
    umount: /media/test mount disagrees with the fstab
    This is a bug. The bug report is here: https://bugs.launchpad.net/ubuntu/+s...nux/+bug/99437

    A fix is posted in the bug report.

    Quote Originally Posted by peshko-lnx View Post
    3. Shutdown hanging when cifs is mounted is permanent. There seems to be no workaround. I applied MANY solutions, but seems that there is no permanent solution.
    This one has been my arch nemesis. It works fine if you use the old networking stack available in earlier versions of Ubuntu, but network-manager hoses things up. Edit the network connection and make sure that there is a check mark next to "Available to all users". If that still doesn't fix the problem and you have a wired ethernet connection, you can consider changing to the old networking stack by uninstalling network-manager and installing gnome-network-admin. Then you can configure networking under system > admin > network (not "network tools")
    Last edited by dmizer; November 24th, 2010 at 06:08 AM.

  4. #1284
    Join Date
    May 2010
    Beans
    67
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post

    This is a bug. The bug report is here: https://bugs.launchpad.net/ubuntu/+s...nux/+bug/99437

    A fix is posted in the bug report.
    I checked the bug. Do you think that the solution there would be applicable to 10.10. It is 3+ years old? I also looked at the code. It is talking about devuuid. I am not sure you would get this in samba. So how applicable this is?

    Thanks!
    Last edited by peshko-lnx; November 24th, 2010 at 04:12 PM.

  5. #1285
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by peshko-lnx View Post
    I checked the bug. Do you think that the solution there would be applicable to 10.10. It is 3+ years old? I also looked at the code. It is talking about devuuid. I am not sure you would get this in samba. So how applicable this is?

    Thanks!
    Yes, even though that bug is old, that's the bug you need to watch. The fix posted won't work, but that's still the correct bug report. I see you've added a comment to the bug and that's the correct thing to do. Just keep an eye on it and see if there's any development.

  6. #1286
    Join Date
    Oct 2010
    Beans
    3

    Re: CIFS VFS error during boot

    Quote Originally Posted by Hieronymus View Post
    I have the same issue as Gorkster, I guess, I need my wireless connection to be up and running before fstab mounts the drives. _netdev won't work with cifs ... I don't know what I did exactly, but it seems to be working now... Just took _netdev out of /etc/fstab
    Thanks for sharing! I kept futzing but never could get anywhere. I added the _netdev option in and removed it. Since my issue perplexed me and apparently everyone else I finally gave up on it and now use autofs. Since I don't need the network connection open constantly anyway it seemed a better match for me.

    Of course now I'm getting some weird error when I log OFF instead! But that's for a different thread...
    Last edited by Gorkster; November 26th, 2010 at 02:42 PM.

  7. #1287
    Join Date
    Mar 2010
    Location
    Slovakia
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    Hi, I am running Ubuntu 9.10 with smbfs 2:3.4.0-3, and I had used your tutorial long time ago to mount my WD NAS.. (permanent mount via CIFS + .smbcredentials) Everything worked just perfect until recently when it just started acting weirdly over night. The problem was pretty bizarre, I could create and delete directories, but it would create them read-only which meant I couldn't copy any files in there. Also, I couldn't copy/create any files anywhere on my NAS, but I could delete the existing. My file_mode and dir_mode were both 0777; Like I said super bizarre. Well so first I looked at troubleshooting in your first post, but I missed the fix, because it said
    Files owned by root / "The folder contents could not be displayed". If you can view but not change, delete, or add new files to your Samba share, or if you get an error in Nautilus which says, "The folder contents could not be displayed"; try this fix:
    Which wasn't exactly my problem, only error I got from Nautilus said "You don't have permission to do that".. I came back after your comment on a different thread.

    What worked for me was adding both gid=1000,uid=1000,nounix, and noserverino, into my fstab, so now it looks like:

    //NAS_IP/sharename /mnt/sharename cifs credentials=/root/.smbcredentials,iocharset=utf8,noserverino,gid=1000,uid=1000,nounix,file_mode=0777,dir_mode=0777 0 0
    I don't know if my problem was something different and the same solution worked, or if it is the same problem I just didn't understand it anyways, I just thought it might help someone with the same problem in future.

    Thanks for very well organized tutorial and well maintained thread.
    Last edited by Lonoki; January 27th, 2011 at 04:23 PM.

  8. #1288
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Lonoki View Post
    I don't know if my problem was something different and the same solution worked, or if it is the same problem I just didn't understand it anyways, I just thought it might help someone with the same problem in future.

    Thanks for very well organized tutorial and well maintained thread.
    Your quite welcome. Despite the different wording, the error you encountered is indeed "Files owned by root". I've updated the preface to this troubleshooting section to include the current Nautilus wording.

    Thanks!

  9. #1289
    Join Date
    Mar 2010
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Disabling posix extensions fixed my problem on a clustered Microsoft share.

    Thanks.

  10. #1290
    Join Date
    Dec 2010
    Beans
    9

    Re: Mount samba shares with utf8 encoding using cifs

    Hello everyone!

    First I want to thank dmizer for the great guide!

    But I'm stuck on some problems by mounting my networkdrive.
    I edited the fstab in the following manner:

    Code:
    //192.168.0.195/MyShare /media/myshare cifs user=<user>,passwd=<password>,auto,uid=1000,gid=1000,nounix 0 0
    //192.168.0.195/OpenShare /media/openshare cifs auto,uid=1000,gid=1000,nounix 0 0
    On my networkdrive they are 2 folders one, the OpenShare, which (I thought) is not protected and the other, MyShare, which is protected by password. But if I want to mount the drive, first I've to deliver a password for the OpenShare and second an error occurs for the MyShare:

    Code:
    mount error(127): Key has expired
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    The funny thing now is that for the OpenShare with the same password as for the MyShare mounts without problems and if I connect by ftp with MyShare all works perfectly, no key expired issue comes up?

    If I now add password and user field to OpenShare in fstab, the same error appears as for the MyShare before.

    Can somebody help me to get through it? I googled and searched this forum a lot but didn't found a solution. And how can I change a key for my networkdrive? Is there some credential file on it?

    Thanks a lot
    Cheers Reza

Page 129 of 137 FirstFirst ... 2979119127128129130131 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •