Page 128 of 137 FirstFirst ... 2878118126127128129130 ... LastLast
Results 1,271 to 1,280 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1271
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by PaulHuffman View Post
    Tried "sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o username=xxxx,password=xxxx,iocharset=utf8,file_mo de=0777,dir_mode=0777" Got a mount, but it was writable for su only.

    Why did Ubuntu take mount away from ordinary users?
    Mount has not been taken away from ordinary users. Mount has always been a root only command.

    Try this:
    Code:
    sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o rw,username=xxxx,password=xxxx,iocharset=utf8,file_mode=0777,dir_mode=0777

  2. #1272
    Join Date
    Sep 2007
    Location
    Yakima, WA
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for getting back to me so quickly.

    I wasn't correct when I said mount stopped working for users, and is available for root. I meant that on 10/23/2010, smbmount stopped working for user. http://ubuntuforums.org/showthread.php?t=764319

    I've tried adding the rw option to the mount -t cifs syntax. Same result. Mount is read only to user, even thought the mount point is 777, owned by root.

    Are shares mounted with the Nautilus GUI expected to be read only?
    This signature line intentionally blank.

  3. #1273
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by PaulHuffman View Post
    Thanks for getting back to me so quickly.

    I wasn't correct when I said mount stopped working for users, and is available for root. I meant that on 10/23/2010, smbmount stopped working for user. http://ubuntuforums.org/showthread.php?t=764319

    I've tried adding the rw option to the mount -t cifs syntax. Same result. Mount is read only to user, even thought the mount point is 777, owned by root.

    Are shares mounted with the Nautilus GUI expected to be read only?
    There are some suggestions for fixing the "files owned by root" problem in the troubleshooting section of the howto.

    As to smbmount, I have never used it so I have no input on that issue.

    Shares mounted via Nautilus tend to be finicky.

  4. #1274
    Join Date
    Oct 2010
    Beans
    3

    CIFS VFS error during boot

    First, grats on the Web's longest thread and longest-running thread EVAH!

    I've spent hours combing through this thread but have to admit there are several pages in the middle, between 50-100, which I may have missed. If this has been discussed and I missed it I'm more than happy to continue my combing.

    I receive the following two errors when booting up my Ubuntu 10.10 install. This error has not always displayed, and I have no idea when it started. It could have been an update, or something I've done.
    Code:
     
    [ 23.442935] CIFS VFS: Error connecting to socket. Aborting operation
    [ 23.443894] CIFS VFS: cifs_mount failed w/return code = -101
    I have the following entry in /etc/fstab:
    Code:
     
    //192.168.1.120/Data /mnt/world-data cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    I have confirmed that the error is not displayed during boot if I comment out this line.

    Here's the odd thing... The mount point actually mounts, in spite of this error. (Of course, it does not if I comment out that line in /etc/fstab.)

    I can umount and use mount -a to remount without any issues. Even though things seem to be fine, my reasons for wanting to fix this are: 1) I'm concerned this will lead to some other problem at some point; and 2) This is driving me NUTS!

  5. #1275
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: CIFS VFS error during boot

    Quote Originally Posted by Gorkster View Post
    First, grats on the Web's longest thread and longest-running thread EVAH!

    I've spent hours combing through this thread but have to admit there are several pages in the middle, between 50-100, which I may have missed. If this has been discussed and I missed it I'm more than happy to continue my combing.
    No need to read the entire thread. As you can see by the change log at the bottom of the first post, I keep the first post continually updated with the latest information.

    Quote Originally Posted by Gorkster View Post
    I receive the following two errors when booting up my Ubuntu 10.10 install. This error has not always displayed, and I have no idea when it started. It could have been an update, or something I've done.
    <snip>
    Even though things seem to be fine, my reasons for wanting to fix this are: 1) I'm concerned this will lead to some other problem at some point; and 2) This is driving me NUTS!
    It's probably happening because mount is trying to establish the connection before your network is up. In order to solve this, you can add the _netdev option to your fstab line like so:
    Code:
    //192.168.1.120/Data /mnt/world-data cifs guest,_netdev,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    The _netdev option prevents the mount from being attempted before there is an active network present.

  6. #1276
    Join Date
    Oct 2010
    Beans
    3

    Re: CIFS VFS error during boot

    Quote Originally Posted by dmizer View Post
    No need to read the entire thread ... It's probably happening because mount is trying to establish the connection before your network is up.
    Yeah, I can see that you keep that first post in the thread up to date and I really appreciate that. It took me several days to figure out how to get Ubuntu 10.10 to recognize/mount/auto-mount my NAS, and in those days I read through your entire first post many times. (Along with countless other bits of information found via Google searches.)

    I had high hopes that the _netdev option you suggested would work. I had assumed the same thing you did, that the share was being mounted before the network was available. I hadn't run across the _netdev option before reading your suggestion... Sadly, this error still shows up during boot. Same as before, the network share is mounted in spite of the error.

    I'm no guru, but I REALLY find this strange now!

    EDIT:
    Well, here's a possible reason the _netdev option didn't make any difference anyway...
    Code:
    Oct 31 00:21:23 ubuntu kernel: [   38.677922] CIFS: Unknown mount option _netdev
    Oct 31 00:21:23 ubuntu kernel: [   38.739491] CIFS VFS: Error connecting to socket. Aborting operation
    Oct 31 00:21:23 ubuntu kernel: [   38.740592] CIFS VFS: cifs_mount failed w/return code = -101
    Oct 31 00:21:23 ubuntu NetworkManager[765]: <info> NetworkManager (version 0.8.1) is starting...
    Oct 31 00:21:23 ubuntu NetworkManager[765]: <info> Read config file /etc/NetworkManager/nm-system-settings.conf
    Do the following lines about NetworkManager indeed verify that the mount is (at least initially) happening before the nework is ready?

    EDIT2:
    Sorry for so many edits, since nobody's posted anything and I had more to add I figurd it'd be ok.

    I think maybe I see in the syslog why the share is mounting in spite of that error. I just rebooted and show the following in the log. After the first three CIFS related lines I see something farther down:
    Code:
    Oct 31 01:23:29 ubuntu kernel: [ 28.836565] CIFS: Unknown mount option _netdev
    Oct 31 01:23:29 ubuntu kernel: [ 28.836669] CIFS VFS: Error connecting to socket. Aborting operation
    Oct 31 01:23:29 ubuntu kernel: [ 28.836684] CIFS VFS: cifs_mount failed w/return code = -101
    ## {MANY MORE LOGS HERE, many of which are related to NetworkManager}
    Oct 31 01:23:32 ubuntu kernel: [ 31.744592] CIFS: Unknown mount option _netdev
    Would this not indicate that my mount is being attempted more than once? It appears to me that maybe the mount is attempted once before the network is set up, then again after the network is running. There are no CIFS VFS errors after the second attempt.

    Of course this doesn't explain why the _netdev option isn't working.. Plus, I find it curious that the mount is being attempted twice.

    EDIT3
    Day off, working graves, what can I say?

    Found this in the Ubuntu manual under common options for fstab:
    from https://help.ubuntu.com/community/Fstab

    "_netdev - this is a network device, mount it after bringing up the network. Only valid with fstype nfs."

    So apparently _netdev is not a valid option to use with CIFS? I did look on the ubuntu manual page for mount.cifs and didn't find any similar option:
    http://manpages.ubuntu.com/manpages/...nt.cifs.8.html

    So, still no solution - hanging my hat for a bit. I'll wait to see what you or anyone mght have to say before I continue dissecting this issue.
    Last edited by Gorkster; October 31st, 2010 at 09:56 AM.

  7. #1277
    Join Date
    Sep 2007
    Location
    Yakima, WA
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I figured out why I was confused about what kind of users can use mount. If you use the user or users option in a line in fstab, then ordinary users can mount the file system described in that line. Back in the Pleistocene I used to run Solaris systems and that's how ordinary users were able to mount these new fangled "CDs".
    This signature line intentionally blank.

  8. #1278
    Join Date
    Mar 2006
    Beans
    308
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by mip View Post
    I have a Lacie NAS at mylacie.local.

    I'm trying to mount it using the following command:

    Code:
    mount -t cifs //mylacie.local/directory /media/share -o username=***,password=***,iocharset=utf8,file_mode=0777,dir_mode=0777
    I'm getting the following error:

    Code:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    dmesg returns:

    Code:
    [13992.766847] Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    [13992.766857]  CIFS VFS: Send error in SessSetup = -13
    [13992.766870]  CIFS VFS: cifs_mount failed w/return code = -13
    Anyone have any ideas?
    Quote Originally Posted by dmizer View Post
    Take a look at the troubleshooting section of the howto. There is a fix for the error 13, It's marked for Hardy, but it is valid for other versions as well.
    I have the same/similar issue. I have tried the error 13 fix in the troubleshooting but no difference. I have used the /root/.smbcredentials as well, because when writing my password which contains a "!" the direct mount did not process. However when setting up with .smbcredentials I get the same error and dmesg as above.

    I wonder it has something to do with AD? When I connect to a network share through nautilus I have to put in "domain: ad" but I don't if or where I should put it when following this guide?

  9. #1279
    Join Date
    Oct 2010
    Location
    Sweden
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Great thread, thanks!

    This worked for me in Ubuntu Karmic, mounting a Buffalo Linkstation NAS (model name LS-CHL, firmware 1.07) which is also connected to a number of windows boxes:

    Code:
    sudo mount.cifs //192.168.1.139/HEM /home/staffan/mont/hem -o uid=1000,gid=1000,pass=hemligkod,iocharset=utf8,nounix
    The "Windows Client Language" is ISO8859-15 according to the NAS web interface, but using "iocharset=iso8859-15" yielded strange results when filenames had Swedish characters such as åäö. I changed into utf8 which worked fine.

    ...it remains to transmit this into a working fstab.

  10. #1280
    Join Date
    Apr 2005
    Location
    Terborg, The Netherlands
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: CIFS VFS error during boot

    Edit: I don't know what I did exactly, but it seems to be working now... Just took _netdev out of /etc/fstab and now it seems to wait until wifi is up anyway. I hope this is not just a one time event (or 2 as I tried rebooting twice).

    Hi guys,

    Great thread this, almost there. Just one hurdle to navigate. I am trying to mount my NAS iot play my music with mpd. This will only work when actually mounting the NAS drives, symlink won't work.

    I have the same issue as Gorkster, I guess, I need my wireless connection to be up and running before fstab mounts the drives. _netdev won't work with cifs, as Gorkster already mentioned.

    Is there any other way to make this happen?

    Thanks in advance,

    H
    Last edited by Hieronymus; November 16th, 2010 at 08:43 AM. Reason: SOLVED !?
    The only person who got all his work done by Friday, was Robinson Crusoe

Page 128 of 137 FirstFirst ... 2878118126127128129130 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •