Page 125 of 137 FirstFirst ... 2575115123124125126127135 ... LastLast
Results 1,241 to 1,250 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1241
    Join Date
    Jan 2008
    Beans
    186

    Re: Mount samba shares with utf8 encoding using cifs

    Hi Dmizer,
    you helped me in the past hope you can do the same again, when I was running Hardy I followed your tutorial and with help from you got my Ready NAS duo backup drives mounting on boot. I upgraded to jaunty and then to Karmic everything continued to work.

    I have now done a clean install of Lucid, I can browse to all my network through nautilus including windows shares, digital entertainment centre and my NAS back up drive.

    I decided to try to manually mount the drive as per your tutorial with the following command without doing any of the pre work you list just to see if Lucid would work straight out of the box

    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharset=utf8,file_mode=0777,dir_mode=0777
    This is the error message I get

    mount: wrong fs type, bad option, bad superblock on //NAS-88-7D-78/backup,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Should i do all the pre work as before ie samba?

  2. #1242
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by corkscrew View Post
    Should i do all the pre work as before ie samba?
    You'll need to install smbfs. I suggest that you avoid the rest of the prework as it could break your currently working samba browsing.

  3. #1243
    Join Date
    Jan 2008
    Beans
    186

    Re: Mount samba shares with utf8 encoding using cifs

    Did as you suggested and installed smbfs,the erroe message I got was to do with the nebios name which I found a bit strange since as I said in my 1st post all the shares are visible in nautilus by their netbios name?
    Maybe somthing to do with the settings in my ReadyNas duo which has 3 shares in it one read write for me only and it's cifs & NFS, the other 2 shares are read write for me and read only for everyone else and they are cifs cant remember why i set it up that way maybe that will cause me other problems.
    Anyway ran the next 2 commands from your tutorial for nsswitch and winbind and everyhting works again all 3 mount on boot and no shut down problems.

    Just for my own knowledge maybe I should un tick the nfs

  4. #1244
    Join Date
    Jan 2008
    Beans
    186

    Re: Mount samba shares with utf8 encoding using cifs

    help, spoke to soon
    story so far have installed smbfs, nsswitch and winbind, I can mount my 3 shares on ReadyNas duo. I can also browse to my digital entertainment centre.

    I cannot see the 2 laptops on my network both running karmic, and I cant see windows vista desktop on same network. I could see all these prior to moving from karmic to Lucid.

    Any ideas?

    Regards

  5. #1245
    Join Date
    Nov 2004
    Beans
    38

    Re: Mount samba shares with utf8 encoding using cifs

    I have a Lacie NAS at mylacie.local.

    I'm trying to mount it using the following command:

    Code:
    mount -t cifs //mylacie.local/directory /media/share -o username=***,password=***,iocharset=utf8,file_mode=0777,dir_mode=0777
    I'm getting the following error:

    Code:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    dmesg returns:

    Code:
    [13992.766847] Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    [13992.766857]  CIFS VFS: Send error in SessSetup = -13
    [13992.766870]  CIFS VFS: cifs_mount failed w/return code = -13
    Anyone have any ideas?

  6. #1246
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by mip View Post
    I have a Lacie NAS at mylacie.local.

    I'm trying to mount it using the following command:

    Code:
    mount -t cifs //mylacie.local/directory /media/share -o username=***,password=***,iocharset=utf8,file_mode=0777,dir_mode=0777
    I'm getting the following error:

    Code:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    dmesg returns:

    Code:
    [13992.766847] Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
    [13992.766857]  CIFS VFS: Send error in SessSetup = -13
    [13992.766870]  CIFS VFS: cifs_mount failed w/return code = -13
    Anyone have any ideas?
    Take a look at the troubleshooting section of the howto. There is a fix for the error 13, It's marked for Hardy, but it is valid for other versions as well.

  7. #1247
    Join Date
    Nov 2004
    Beans
    38

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks dmizer. I'll give it a try.

    M.

  8. #1248
    Join Date
    Feb 2007
    Beans
    52

    Re: Mount samba shares with utf8 encoding using cifs

    All my 'mount' commands are preceded by 'sudo', never tried to mount anything other than as su...

  9. #1249
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by fcigoi View Post
    All my 'mount' commands are preceded by 'sudo', never tried to mount anything other than as su...
    I am confused by this comment. I do not suggest that you perform any mounts without sudo unless the mount lines appear in /etc/fstab configuration file. Since /etc/fstab has root permissions, it is not necessary to prepend the command with sudo.

  10. #1250
    Join Date
    Aug 2006
    Beans
    69
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I have some weird filename on Samba mounted fs which can't be read and since this file includes network key of a program, this program does not run. If I mount same filesystem with NFS it's ok.

    The fstab with smb mounted system has a line:
    //192.168.50.5/desk /media/desk cifs guest,iocharset=utf8,noperm,file_mode=0777,dir_mod e=0777,rw 0 0

    The problematic file has a filename ASP32$$$.ID2. No metter what I try with this file, I always get permission denied under CIFS

    Is there a way to get around this?

Page 125 of 137 FirstFirst ... 2575115123124125126127135 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •