Page 124 of 137 FirstFirst ... 2474114122123124125126134 ... LastLast
Results 1,231 to 1,240 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1231
    Join Date
    May 2006
    Beans
    Hidden!

    Re: Mount samba shares with utf8 encoding using cifs

    Nice tutorials. before reading them I couldn't get any connection to speak of. Currently I am able to use
    Code:
    smbclient //ourserver.domain.com/shares -U myusername
    to connect. (it asks for a password, which I enter and gain access)

    The Places > Connect to Server... and the mount methods don't work though.

    Code:
    $ sudo mount -t cifs //ourserver.domain.com/shares /media/shares -o username=myusername
    Password: 
    retrying with upper case share name
    mount error(6): No such device or address
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Any ideas on why one works, but not the other?

    Relevant lines from config files.

    Code:
    /etc/nsswitch.conf
    hosts:          files mdns4_minimal [NOTFOUND=return] wins dns mdns4
    Code:
    /etc/samba/smb.conf
       workgroup = OURGROUP
       netbios name = myhostname
       name resolve order = lmhosts wins bcast host
    In part of my earlier testing, I got this bit of information about the server:
    Code:
    Domain=[OURGROUP] OS=[Windows Server 2008 R2 Enterprise 7600] Server=[Windows Server 2008 R2 Enterprise 6.1]
    I am using Ubuntu 10.04

    Note: I did sanitize the domain/hostnames/usernames above, but the styles should match

  2. #1232
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer, THANK YOU SIR. I was having the worst time trying to keep my windows shares connected and this howto fixed the issue. I was worried that I'd have no choice but to go back to windows but thankfully you have saved me from that. Again, THANKS.

  3. #1233
    Join Date
    Jul 2010
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Hi Demizer, Brilliant post. I always refer when adding network devices. Just added a Netgear Stora NAS. I have limited access, (no delete rights) on my share after implimenting your post for mounting on boot. Curiously if i use Places Network, I have full access.
    In short smb://familylibrary link has full access but /media/FamilyLibrary has no delete rights. from /etc/fstab
    //stora/FamilyLibrary /media/FamilyLibrary cifs credentials=root/.nascredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
    I have a small USB NAS device that does not have this issue, the /media/usbnas link has full read write links. One subtle difference, the credentials password for the USB NAS is different to the Stora NAS. Stora NAS has same password as ubuntu login. Any advice on how to get full access with /media/FamilyLibrary?
    Thanks
    Mark

  4. #1234
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by lifecycled View Post
    Hi Demizer, Brilliant post. I always refer when adding network devices. Just added a Netgear Stora NAS. I have limited access, (no delete rights) on my share after implimenting your post for mounting on boot. Curiously if i use Places Network, I have full access.
    In short smb://familylibrary link has full access but /media/FamilyLibrary has no delete rights. from /etc/fstab
    //stora/FamilyLibrary /media/FamilyLibrary cifs credentials=root/.nascredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
    I have a small USB NAS device that does not have this issue, the /media/usbnas link has full read write links. One subtle difference, the credentials password for the USB NAS is different to the Stora NAS. Stora NAS has same password as ubuntu login. Any advice on how to get full access with /media/FamilyLibrary?
    Thanks
    Mark
    Try adding the rw option like so
    Code:
    //stora/FamilyLibrary   /media/FamilyLibrary cifs rw,credentials=root/.nascredentials,iocharset=utf8,file_mode=0777,dir_mode=07

  5. #1235
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by orsonj View Post
    Nice tutorials. before reading them I couldn't get any connection to speak of. Currently I am able to use
    Code:
    smbclient //ourserver.domain.com/shares -U myusername
    to connect. (it asks for a password, which I enter and gain access)
    If your server has an actual fully qualified domain (ourserver.domain.com) for access, that means you have a DNS sserver on your local network. Because of that, you should not use wins for host name resolution and this could be the source of your problem.

    Instead, you should remove the winbind server and the references to wins, and make sure that your network is pointed to your office's correct DNS servers.

    Sorry I took so long to reply to this. I thought I'd already done so.

  6. #1236
    Join Date
    Jul 2010
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try adding the rw option like so
    Code:
    //stora/FamilyLibrary   /media/FamilyLibrary cifs rw,credentials=root/.nascredentials,iocharset=utf8,file_mode=0777,dir_mode=07
    Thanks, Tried, made no difference. (rebooted ubuntu to be sure). I see this is permissions related but not sure of the difference in passing login credentials via nautilus- samba mount with fstab, or via nautilus Network.
    Some more tests:- When accessing via Stora webtool I copied a folder. This copied folder was locked and contents not viewable via samba mount. Also I tried creating a file via samba mount. This was available for deletion. Any new file not created from samba mount has restricted permissions. Perhaps i should discuss this on a Stora user forum instead?
    Mark

  7. #1237
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by lifecycled View Post
    Perhaps i should discuss this on a Stora user forum instead?
    Mark
    Looks that way to me. That, or just review the permission settings on the Stora device.

  8. #1238
    Join Date
    Jul 2010
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Looks that way to me. That, or just review the permission settings on the Stora device.
    WORKING: I am a little baffled and humbled. Do not know what the fix was. After a few days confirming the problem was still there, it simply disappeared today. Now my auto mount of the network NAS folders are unlocked. I have recently modified the web login to my Stora NAS to bypass MYStora.com as default and login via direct local LAN IP but do not think this is related. I have no server PC on my LAN. My wireless router provides IP addresses, and most devices on LAN are allocated permanent IP addresses.

    Oh well.

    Mark

  9. #1239
    Join Date
    Jul 2010
    Location
    51.508056, -0.128056
    Beans
    205
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Mount samba shares with utf8 encoding using cifs

    A thank you to dmizer in 2006 from 2010.

    I was using Unison to sync between a mounted folder and a local folder, but I noticed the troubles it was having with unicode file names. Found your tutorial, simple change to fstab, things are faster now and the synchronization works perfectly.

  10. #1240
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by mendhak View Post
    A thank you to dmizer in 2006 from 2010.

    I was using Unison to sync between a mounted folder and a local folder, but I noticed the troubles it was having with unicode file names. Found your tutorial, simple change to fstab, things are faster now and the synchronization works perfectly.
    Glad to know it helped.

Page 124 of 137 FirstFirst ... 2474114122123124125126134 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •