Page 123 of 137 FirstFirst ... 2373113121122123124125133 ... LastLast
Results 1,221 to 1,230 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1221
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Problem with mounting
    Hi,

    I've been trying to follow this great tutorial but I have problem.

    I can mount my network drive just fine with:

    sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharse t=utf8,file_mode=0777,dir_mode=0777

    But when I follow the rest of the instructions I get the Mount error 13. If you are seeing "mount error 13 = Permission denied" when running sudo mount -a.

    I tried the Fix for Hardy users, but it won't work here - I am running lucid.

    Any help would be great!

    Thanks!

  2. #1222
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,092
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    Problem with mounting
    Hi,

    I've been trying to follow this great tutorial but I have problem.

    I can mount my network drive just fine with:

    sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharse t=utf8,file_mode=0777,dir_mode=0777

    But when I follow the rest of the instructions I get the Mount error 13. If you are seeing "mount error 13 = Permission denied" when running sudo mount -a.

    I tried the Fix for Hardy users, but it won't work here - I am running lucid.

    Any help would be great!

    Thanks!
    show us the result of this command after issuing sudo mount -a
    Code:
    tail dmesg
    are you sure that the above fstab entry is the one that is causeing hte error when issuing sudo mount -a. how many other smb shares are you mounting with sudo mount -a? can you post your entire fstab? is this something the forum did? put a space in the word iocharset? (iocharse t)
    you can ping the windows machine by netbios name correct? what are the permission on the dfolder named /media/sharename? also, who owns it and the group owner?
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  3. #1223
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dannyboy79 View Post
    show us the result of this command after issuing sudo mount -a
    Code:
    tail dmesg
    When I enter tail dmesg I get the reply:

    tail: "dmesg" can not be opened to read: No such file or directory

    Quote Originally Posted by dannyboy79 View Post
    are you sure that the above fstab entry is the one that is causeing hte error when issuing sudo mount -a. how many other smb shares are you mounting with sudo mount -a? can you post your entire fstab? is this something the forum did? put a space in the word iocharset? (iocharse t)
    you can ping the windows machine by netbios name correct? what are the permission on the dfolder named /media/sharename? also, who owns it and the group owner?
    root owns the folder /media/NAS and it can read and write.

    I am only mounting this one share here is my fstab:

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda1 during installation
    UUID=e0519f9a-d3bd-41d6-9c56-8e62f4d54f65 / ext4 errors=remount-ro 0 1
    # swap was on /dev/sda5 during installation
    UUID=ece0e11a-c5d4-48ac-a2fc-523828dbbdcf none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    //WHITE_RABBIT/NAS /media/NAS cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
    Last edited by Irwin J. Finster; May 6th, 2010 at 08:38 PM.

  4. #1224
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,092
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    When I enter tail dmesg I get the reply:

    tail: "dmesg" can not be opened to read: No such file or directory



    root owns the folder /media/NAS and it can read and write.

    I am only mounting this one share here is my fstab:

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda1 during installation
    UUID=e0519f9a-d3bd-41d6-9c56-8e62f4d54f65 / ext4 errors=remount-ro 0 1
    # swap was on /dev/sda5 during installation
    UUID=ece0e11a-c5d4-48ac-a2fc-523828dbbdcf none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    //WHITE_RABBIT/NAS /media/NAS cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
    sorry, it's
    Code:
    dmesg | tail
    if the folder is owned by root, that may be your problem. here is the permissions of a folder I mount a smb share to. the folder is named fat32 and is located within /media/
    Code:
    drwxr-xr--  2 daniel daniel 4096 2009-06-16 14:38 fat32
    /media/ has these permission.
    Code:
    drwxr-xr-x  12 daniel daniel  4096 2010-05-05 18:32 media
    my fstab line is this
    Code:
    //192.168.0.5/fat32     /media/fat32    cifs    auto,noexec,users,nounix,uid=1000,gid=1000,credentials=/etc/samba/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777        0       0
    and the file .smbcredentials has these permissions.
    Code:
    -r-------- 1 daniel daniel 35 2009-06-21 01:55 /etc/samba/.smbcredentials
    look at these things. also, can you show me the smb.conf for the share from the server? this is mine

    [fat32]
    path = /media/fat32
    comment = Movies on dell
    available = yes
    browsable = yes
    read only = No
    store dos attributes = no
    create mask = 0755
    directory mask = 0755
    public = yes
    writable = yes
    guest ok = yes
    force user = daniel
    force group = daniel


    good luck
    Last edited by dannyboy79; May 6th, 2010 at 10:11 PM.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  5. #1225
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Irwin J. Finster View Post
    Code:
    //WHITE_RABBIT/NAS    /media/NAS        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Quote Originally Posted by Irwin J. Finster View Post
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename -o username=winusername,password=winpassword,iocharse t=utf8,file_mode=0777,dir_mode=0777
    The difference between these two is that you are not using /root/.smbcredentials to mount manually. Take a look at your .smbcredentials file and make sure it's formated correctly.

    Also try this to test the credentials file:
    Code:
    sudo mount -t cifs //netbiosname/sharename /media/sharename -o credentials=/root/.smbcredentials,iocharse t=utf8,file_mode=0777,dir_mode=0777

  6. #1226
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dannyboy79 View Post
    bump, anyone else still having this issue in lucid besides me?
    I haven't had much time to play with this, but the problem is related to network-manager.

    If you're willing to remove network-manager, and use gnome-network-admin instead, this will resolve your problem.

  7. #1227
    Join Date
    Aug 2006
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks folks, now it works, don't really know why caus I didn't do anything but hey IT WORKS

    THANKS!

  8. #1228
    Join Date
    May 2010
    Beans
    5

    Re: Mount samba shares with utf8 encoding using cifs

    This guide is WIN.

    I successfully connected to my Western Digital My Book World Edition. Thank-you.

    This type of guide is very helpful to an inexperienced user like myself.

    Now to put in my 2c regarding the "My Book World Edition" specifically:

    I had some trouble finding the netbios name. To find it yourself, type in the drive's IP address into your browser address bar (eg. mine is 192.168.0.150) and login using usr:admin pw:admin (unless you've changed it of course). Go into "System Status" and see the netbios name under System Information - Device Name. Default is "MyBookWorld". The share name on this drive is "public"

    Thanks again.

  9. #1229
    Join Date
    May 2010
    Beans
    5

    Re: Mount samba shares with utf8 encoding using cifs

    I have one question:

    Does anyone know how to make the desktop icon show up in the Netbook Remix under "Files and Folders", either under Folders or Volumes?

    Thanks

  10. #1230
    Join Date
    May 2010
    Beans
    2

    Talking Re: Mount samba shares with utf8 encoding using cifs

    WOW! you just save my day, thanks for the post regarding with the mount samba share... it helps a lot...

Page 123 of 137 FirstFirst ... 2373113121122123124125133 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •