Page 115 of 137 FirstFirst ... 1565105113114115116117125 ... LastLast
Results 1,141 to 1,150 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1141
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Humanity to others View Post
    same result as by using cifs insted of smbfs
    There is a fix for this listed in the howto under
    KARMIC: Files owned by root / "The folder contents could not be displayed"

  2. #1142
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by arryo View Post
    I use permanent mount like the guide, but whenever I start ubuntu computer, the mount is gone until I type "sudo mount -a"

    Is there any way that the mount is actually permanent?

    I'm using Ubuntu 9.10 and mount to a share folder in Windows 7

    Thank you
    Add "mount -a" to the /etc/rc.local file before the "exit 0" line like so:
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    mount -a
    exit 0

  3. #1143
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by moorsey View Post
    just to make clear, the nounix option is the cause of the blank files, removing this option fixes the file corruption, but then the folder locking starts, so it's one or the other it seems
    You can't only add the "nounix" option. You have to also add the uid and gid options as listed in the Files owned by root / "The folder contents could not be displayed" troubleshooting section.

  4. #1144
    Join Date
    Sep 2009
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Add "mount -a" to the /etc/rc.local file before the "exit 0" line like so:
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    mount -a
    exit 0
    Thank you very much. It worked!

  5. #1145
    Join Date
    Apr 2009
    Location
    India
    Beans
    22
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    There is a fix for this listed in the howto under
    Fix the problem by adding noserverino

    Thank you very much

    Ubuntu Fan

  6. #1146
    Join Date
    Nov 2008
    Beans
    74

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    You can't only add the "nounix" option. You have to also add the uid and gid options as listed in the Files owned by root / "The folder contents could not be displayed" troubleshooting section.
    thanks for the reply

    I gave this another try, but can confirm it still causes the same problem, corrupt files are copied to the samba server.

    So, I decided instead of killing myself from stress trying to get this working, I setup NFS for Ubuntu sharing and left Samba running for the Windows clients also. I'm sure it is totally insecure with completely open permissions etc, but I honestly don't care any more. This whole experience has been a massive stress and desperately needs integrating into Ubuntu.

    Windows has one checkbox to do what fstab does for example. I do love Ubuntu, but this has put me of a little.

  7. #1147
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,257
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by moorsey View Post
    Windows has one checkbox to do what fstab does for example. I do love Ubuntu, but this has put me of a little.
    windows boxes are also controlled in 50,000 count netbot's that take down bank websites and hack social security numbers. if you don't mind that your windows box lets anyone and everyone have root access at any given time so be it.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  8. #1148
    Join Date
    Jul 2007
    Location
    Saskatoon, SK
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I currently run Ubuntu 9.10 and connect to a D-Link DNS-323.

    Previously, I used the guide found here to connect.

    What is the advantage to using the method listed in this guide?
    More precisely, why mount my NAS drive under /media instead of /home ?
    Also, what does adding the guest,rw do, exactly?
    Does not hide his beans.
    Is a proud supporter of nuclear energy.

  9. #1149
    Join Date
    Nov 2006
    Beans
    8

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Looks like you've converted an old smbfs mount command instead of following the howto. Also, you're using the "exec" mount option which could be causing you problems, and finally you're not using the "file_mode" and "dir_mode" options like the examples in the howto. Try this instead:
    Code:
    //192.168.1.100/public  /media/public   cifs rw,noserverino,nounix,credentials=/etc/cifspw,iocharset=cp1251,gid=****,uid=****,file_mode=0777,dir_mode=0777 0       0
    Thanks for suggestion. Tried the option mentioned with putting UID & GID details - now i works fine
    However - all Russian letters are now as �����.......any ideas ?

    P.S. thanks a lot for your help
    Last edited by Sader; November 17th, 2009 at 05:47 AM.

  10. #1150
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by DownTown22 View Post
    I currently run Ubuntu 9.10 and connect to a D-Link DNS-323.

    Previously, I used the guide found here to connect.

    What is the advantage to using the method listed in this guide?
    More precisely, why mount my NAS drive under /media instead of /home ?
    Also, what does adding the guest,rw do, exactly?
    This guide (for the most part) is basically the same. Really, it doesn't matter WHERE you mount the drive, but when you mount in /media, nautilus automatically adds a mounted volume icon to your desktop.

    You can find more information about all the cifs options by looking at the manual for mount.cifs:
    Code:
    man mount.cifs
    Here's the reason for the guest option:
    Code:
           password=arg
               specifies the CIFS password. If this option is not given then the
               environment variable PASSWD is used. If the password is not
               specified directly or indirectly via an argument to mount,
               mount.cifs will prompt for a password, unless the guest option is
               specified.
    The major difference between the guide you followed is that my guide covers more material, and comes with my personal support

Page 115 of 137 FirstFirst ... 1565105113114115116117125 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •