Page 114 of 137 FirstFirst ... 1464104112113114115116124 ... LastLast
Results 1,131 to 1,140 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1131
    Join Date
    Dec 2007
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    I am running Karmic on an EeePC 1005ha.

    Your "How To" worked perfectly except for having the "CIFS VFS: No response for cmd 50 ..." error on shutdown.

    Your fix listed for Jaunty under troubleshooting solved it perfectly for Karmic, too. [edit: I first thought it solved, but on subsequent shutdowns and restarts found erratic boot and shutdown behaviour, such as going into recovery mode menu screen during shutdown, thence to a login cursor. See last paragraph below for more.]

    The first fix by adding links removed the "CIFS..." error notice, but left a one minute hang with a blinking cursor during shutdown, so that way is apparently not good for Karmic.

    After much suffering, I removed all the edits and used the dmizer "Howto: Fix Windows share browsing issues". This requires manual share mount, but it works without any problems.
    Last edited by shug33; November 4th, 2009 at 04:58 PM. Reason: To correct due to later experience

  2. #1132
    Join Date
    Oct 2008
    Location
    Bergen, Norway
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Question Re: Mount samba shares with utf8 encoding using cifs

    Hello
    Have upgraded to 9.10 from 9.04. Have been using mounting of network folders via fstab entry since 8.04. The fixes to get pass the "CIFS VFS: noe response form server mid 50 mid nnn" does not work for 9.10; putting "/etc/init.d/umountnfs.sh" in the /etc/gdm/PostSession/Default file even stop shutdown from getting passed the white ubuntu ring prior to the cifs vfs ... error message.

    I'm using WLAN, so this might have an impact on this issue?
    I have set wlan accessible for all users, as this was necessary to make cifs work in 9.04...

    Have created a script w/ sudo /etc/init.d/umountnfs.sh that I run before shutdown, but look forward to a permanent fix...

  3. #1133
    Join Date
    Nov 2006
    Beans
    8

    Re: Mount samba shares with utf8 encoding using cifs

    Hello

    Thanks for how-to. I was able to mount the windows share via /etc/fstab.... However I'm not able to write it as normal user....any Ideas ?

    Code:
    //192.168.1.100/public  /media/public   cifs rw,exec,credentials=/etc/cifspw,iocharset=utf8,codepage=cp1251,gid=****,uid=**** 0       0
    Pls can you help me with an advise.....

  4. #1134
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Sader View Post
    Hello

    Thanks for how-to. I was able to mount the windows share via /etc/fstab.... However I'm not able to write it as normal user....any Ideas ?

    Code:
    //192.168.1.100/public  /media/public   cifs rw,exec,credentials=/etc/cifspw,iocharset=utf8,codepage=cp1251,gid=****,uid=**** 0       0
    Pls can you help me with an advise.....
    Looks like you've converted an old smbfs mount command instead of following the howto. Also, you're using the "exec" mount option which could be causing you problems, and finally you're not using the "file_mode" and "dir_mode" options like the examples in the howto. Try this instead:
    Code:
    //192.168.1.100/public  /media/public   cifs rw,noserverino,nounix,credentials=/etc/cifspw,iocharset=cp1251,gid=****,uid=****,file_mode=0777,dir_mode=0777 0       0
    Last edited by dmizer; November 6th, 2009 at 03:26 PM.

  5. #1135
    Join Date
    Nov 2008
    Beans
    74

    Re: Mount samba shares with utf8 encoding using cifs

    Firstly, massive thanks to dmizer for this incredible guide, there is very little info on the web that pulls everything together like this.

    I tried to avoid asking a question, but have been banging my head for weeks now. Mounting shares in Ubuntu has been the single hardest thing I have tried to do, hope someone can help.

    I have 2 samba shares running on a 9.10 server, and 2 users that access them, one user can write to both, the other user can write to one and only read from the other.

    My smb.conf is as follows (could be correct and the fstab that is causing the problems, not sure):

    Code:
    [global]
        ; General server settings
        netbios name = SERVER146
        server string =
        workgroup = WORKGROUP
        announce version = 5.0
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    
        passdb backend = tdbsam
        security = user
        null passwords = true
        username map = /etc/samba/smbusers
        name resolve order = hosts wins bcast
    
        wins support = yes
    
        printing = CUPS
        printcap name = CUPS
    
        syslog = 1
        syslog only = yes
    
    [read]
        path = /shared/read
        browseable = yes
        write list = airc
        read list = cadet airc
        guest ok = no
        create mask = 0777
        directory mask = 0777
    
    [write]
        path = /shared/write
        browseable = yes
        write list = cadet airc
        read list = cadet airc
        guest ok = no
        create mask = 0777
        directory mask = 0777
    This has been seup according to the guide here:
    http://ubuntuforums.org/showthread.php?t=202605

    Only difference is that the shares are symlinks to other directories, hope this doesn't cause issues, haven't thought to test that one!

    Now, my fstab on the client PCs, also 9.10, have been setup according to your guide, using the credentials file:

    Code:
    //server/read    /media/read        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    //server/write    /media/write        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    This worked fine, but any folders that was created in the writable share, came with a padlock on them. This meant that once a folder was created, it couldn't be edited or written inside.

    Looking in the troubleshooting, I added the "nounix" switch to prevent this, which worked a treat! BUT, as a consequence, files copied to the share become corrupted.

    What I mean by this, when a spreadsheet for example is copied to the write share and then opened again from the share, it is blank! Opening the same file in Windows shows a corrupted file, with some of the original data there, but very garbled.

    Copying the file 4 or 5 times and opening from the share after each one will work sometimes on one of the attempts, bit hit and miss though.

    I did also try adding the gid and uid lines in fstab. Finally, I tried the nobrl command in fstab. Same results.

    Any help appreciated!

  6. #1136
    Join Date
    Nov 2008
    Beans
    74

    Re: Mount samba shares with utf8 encoding using cifs

    just to make clear, the nounix option is the cause of the blank files, removing this option fixes the file corruption, but then the folder locking starts, so it's one or the other it seems

  7. #1137
    Join Date
    Apr 2009
    Location
    India
    Beans
    22
    Distro
    Ubuntu 10.04 Lucid Lynx

    Unhappy Re: Mount samba shares with utf8 encoding using cifs

    I have also upgraded to 9.10 from 9.04. Have been using mounting of network folders from windows 2003 server via fstab entry since 8.04. Now I am facing the same problem that permanently mounted windows shares are getting readonly.

    I was used the help following topic to configure windows shares on my Ubuntu desktop.

    https://help.ubuntu.com/community/Mo...resPermanently

    my fstab entry as follows
    //192.168.0.5/e /home/anil/work smbfs username=administrator,password=admin 0 0

    How can use my windows shares with read write & execute permissions as I enjoyed in 9.04

    Thanks in advance

    Anil

  8. #1138
    Join Date
    Oct 2008
    Location
    Bergen, Norway
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount samba shares with utf8 encoding using cifs

    if you followed the howto in the link (https://help.ubuntu.com/community/Mo...ermanently)you, you probably already have added smbfs(which include cifs) trough this command
    > sudo apt-get install smbfs

    in that case, just try changing smbfs to cifs in your fstab entry
    like this
    //192.168.0.5/e /home/anil/work cifs username=administrator,password=admin 0 0

    try sudo mount -a in terminal afterwards to check if it works...

    you probably get the cifs vfs: server not responding... error during shutdown, but thats already covered in the tread. Except for the jaunty fix for putting /etc/init.d/umountnfs.sh above exit 0 in the /etc/gdm/PostSession/Default file. Doesn't work trough wireless in 9.10

    I run the same command as root> sudo /etc/init.d/umountnfs.sh before shutdown and the pc shuts down without any probl..

  9. #1139
    Join Date
    Sep 2009
    Beans
    11

    Re: Mount samba shares with utf8 encoding using cifs

    I use permanent mount like the guide, but whenever I start ubuntu computer, the mount is gone until I type "sudo mount -a"

    Is there any way that the mount is actually permanent?

    I'm using Ubuntu 9.10 and mount to a share folder in Windows 7

    Thank you

  10. #1140
    Join Date
    Apr 2009
    Location
    India
    Beans
    22
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    //192.168.0.5/e /home/anil/work cifs username=administrator,password=admin 0 0

    same result as by using cifs insted of smbfs

    I AM GETTING THE FOLDER AS MOUNTED BUT IT IS GETTING READ ONLY, IN 9.04 I HAD NO PROBLEM !

Page 114 of 137 FirstFirst ... 1464104112113114115116124 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •