Page 113 of 137 FirstFirst ... 1363103111112113114115123 ... LastLast
Results 1,121 to 1,130 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1121
    Join Date
    Mar 2008
    Beans
    29

    Re: Mount samba shares with utf8 encoding using cifs

    I used the trouble shooting section and entered these commands:

    ln -s /etc/init.d/umountnfs.sh /etc/rc0.d/K15umountnfs.sh
    ln -s /etc/init.d/umountnfs.sh /etc/rc6.d/K15umountnfs.sh

    Had to enter sudo before them.

    A word of warning, it caused my wireless to stop working. I believe it was those commands because I used them, rebooted (and it didn't fix the cifs vfs problem for me), and now wireless is gone.
    Last edited by BETELGEUSE58; October 27th, 2009 at 03:24 PM.

  2. #1122
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by BETELGEUSE58 View Post
    I used the trouble shooting section and entered these commands:

    ln -s /etc/init.d/umountnfs.sh /etc/rc0.d/K15umountnfs.sh
    ln -s /etc/init.d/umountnfs.sh /etc/rc6.d/K15umountnfs.sh

    Had to enter sudo before them.

    A word of warning, it caused my wireless to stop working. I believe it was those commands because I used them, rebooted (and it didn't fix the cifs vfs problem for me), and now wireless is gone.
    It's not possible for the above two lines to break your wireless. It's possible that the wins edit in /etc/nsswitch.conf did though.

    There are two fixes for the CIFS VFS: Server not responding. Use the one listed under "Jaunty Users"

  3. #1123
    Join Date
    Sep 2007
    Beans
    6

    Re: Mount samba shares with utf8 encoding using cifs

    What I was looking for was to access my network shares from any program. Since the out of the box samba share (via GVFS) was only visible in Nautilus I had a problem. For me following post solved my problem:

    www.g-loaded.eu/2008/12/08/access-gvfs-mounts-from-the-command-line/

    which simply identified the "virtual mount point" (I don't know how to name it otherwise) of the GVFS mount as follows:
    Code:
    /home/<USER>/.gvfs/<server_connection_name>
    Now I simply created a link in my favourites to the folder:
    Code:
    /home/<USER>/.gvfs/
    so I could always approach easily the network share from anywhere.

    After a quick search in this thread I thought nobody mentioned it earlier. So I hope this is not a double or irrelevant post...

  4. #1124
    Join Date
    Jan 2009
    Beans
    7

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer,

    thanks for your reply. I failed to explain that it is the Ubuntu shares I am having the most trouble with. I had hoped someone would come up with a simple solution for four people to use three computers without the complexity of LDAP to keep their files separate

  5. #1125
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Dr_Hugh View Post
    dmizer,

    thanks for your reply. I failed to explain that it is the Ubuntu shares I am having the most trouble with. I had hoped someone would come up with a simple solution for four people to use three computers without the complexity of LDAP to keep their files separate
    Perhaps I've misunderstood but ... the 6th link in my sig has nothing to do with LDAP at all.

  6. #1126
    Join Date
    May 2008
    Location
    near Milan, Italy
    Beans
    35
    Distro
    Ubuntu

    Unhappy Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Then perhaps it's time for a bug report?
    I just looked in launchpad and that's what I found.

    Known issue and high priority...

    EDIT: BUT there's a workaround: if the fs is mounted with the "noserverino" option, the files become visible again
    Last edited by Dareus; October 29th, 2009 at 03:45 PM.

  7. #1127
    Join Date
    Oct 2009
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Hi

    first of all, I'd like to thank you for this great tutorial, it worked perfectly in jaunty!

    However, I installed karmic yesterday (clean install), and folowing your guide, when I try to mount -a I get the following error:

    mount error: could not resolve address for homenas: Name or service not known
    No ip address specified and hostname not found
    this is the line I added to /etc/fstab (exactly the same as what worked in jaunty):

    Code:
    //homenas/public    /media/Server        cifs    credentials=/root/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,nounix,file_mode=0777,dir_mode=0777 0 0
    the strange thing is, that if I select the connect to server option in nautilus, and put in homenas as server, public as folder, and the correct username and password, it works. This isn't a good enough solution for me because my music library is on the nas and most music players aren't very good at connecting to samba shares...

    additional info: smbtree won't show anything, and trying to browse to the shared folders in nautilus doesn't work.

    Thanks in advance!

  8. #1128
    Join Date
    Feb 2009
    Location
    Moralzarzal, Spain
    Beans
    142
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Mount samba shares with utf8 encoding using cifs

    Then, you probably crash against this bug: https://bugs.launchpad.net/bugs/406466. You have to put noserverino option to go.

    This worked for me.

    Regards,
    ^_Pepe_^^

    Quote Originally Posted by naftali View Post
    Hi

    first of all, I'd like to thank you for this great tutorial, it worked perfectly in jaunty!

    However, I installed karmic yesterday (clean install), and folowing your guide, when I try to mount -a I get the following error:



    this is the line I added to /etc/fstab (exactly the same as what worked in jaunty):

    Code:
    //homenas/public    /media/Server        cifs    credentials=/root/.smbcredentials,rw,iocharset=utf8,gid=1000,uid=1000,nounix,file_mode=0777,dir_mode=0777 0 0
    the strange thing is, that if I select the connect to server option in nautilus, and put in homenas as server, public as folder, and the correct username and password, it works. This isn't a good enough solution for me because my music library is on the nas and most music players aren't very good at connecting to samba shares...

    additional info: smbtree won't show anything, and trying to browse to the shared folders in nautilus doesn't work.

    Thanks in advance!

  9. #1129
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by ^_Pepe_^ View Post
    Then, you probably crash against this bug: https://bugs.launchpad.net/bugs/406466. You have to put noserverino option to go.
    Thanks to Dareus, I added this information to the troubleshooting section.

    However, this error doesn't seem to be related to the bug:

    Quote Originally Posted by naftali View Post
    Code:
    mount error: could not resolve address for homenas: Name or service not known
    No ip address specified and hostname not found
    naftali, have you checked for firewalls both on your Karmic machine as well as on the server?

  10. #1130
    Join Date
    Oct 2009
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Hi,

    My problem was that going a second time through the tutorial, I accidentaly skipped editing /etc/nsswitch.conf and installing winbind...

    I didn't need to add the noserverino option once I did these steps.

    Thanks!
    naftali

Page 113 of 137 FirstFirst ... 1363103111112113114115123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •